Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.

Do-It-Yourself H.Q.
Share your DIY projects or ask questions about how to fix something on your own. Help fellow Bimmerfest members improve your wrench turning skills! All BMW DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-08-2012, 09:55 PM
Barry.J.K. Barry.J.K. is offline
Registered User
Location: south africa
 
Join Date: Oct 2012
Posts: 3
Mein Auto: bmw
320d problem

Hi all, I'm barry! I have a BMW E46 320D 2003 & when I drive constant and switch off and shortly after want to start,and the intrument panels come on the heat gage shows in the red and won't start but the car is not overheated as such. Sometimes when I switch the ignition on & off a couple of times the temp gage will show normal in the middle and wil start then.lately its getting worse & the other day was stuck like that for 45 min. Had diagnostics done & when it is like that shows faults like glow plugs, pressure rail and temp at 101 'c but a minute or two later when turning the ignition on & off and comes to normal the diagnostics shows no faults & 86 'c all normal. They told me maybe water pump so I left it by them now they say it might be the computer box which costs an arm & a leg here. I don't know anymore so pls help!
Reply With Quote
Ads by Google
  #2  
Old 10-08-2012, 09:57 PM
Barry.J.K. Barry.J.K. is offline
Registered User
Location: south africa
 
Join Date: Oct 2012
Posts: 3
Mein Auto: bmw
Hi all, I'm barry! I have a BMW E46 320D 2003 & when I drive constant and switch off and shortly after want to start,and the intrument panels come on the heat gage shows in the red and won't start but the car is not overheated as such. Sometimes when I switch the ignition on & off a couple of times the temp gage will show normal in the middle and wil start then.lately its getting worse & the other day was stuck like that for 45 min. Had diagnostics done & when it is like that shows faults like glow plugs, pressure rail and temp at 101 'c but a minute or two later when turning the ignition on & off and comes to normal the diagnostics shows no faults & 86 'c all normal. They told me maybe water pump so I left it by them now they say it might be the computer box which costs an arm & a leg here. I don't know anymore so pls help!
Reply With Quote
  #3  
Old 10-14-2012, 02:21 PM
Tastylicious34 Tastylicious34 is offline
Registered User
Location: Shoreham
 
Join Date: Oct 2012
Posts: 1
Mein Auto: BMW 320d
Hi I have all of the same problems as above pls help people are saying it doesn't need glow plugs some say it does heels pls
Reply With Quote
  #4  
Old 10-19-2012, 08:21 PM
tator_tot_1991 tator_tot_1991 is offline
Registered User
Location: Odessa, TX, USA
 
Join Date: Oct 2012
Posts: 8
Mein Auto: 08 328i
Its def a sensor. These cars are loaded with electronicz

Sent from my DROID BIONIC using Bimmer App
Reply With Quote
  #5  
Old 10-19-2012, 08:25 PM
tator_tot_1991 tator_tot_1991 is offline
Registered User
Location: Odessa, TX, USA
 
Join Date: Oct 2012
Posts: 8
Mein Auto: 08 328i
I had to replace some pc board on mine recently and it no longer throws codes. It was a hub. 1 hub runs separate things in the car. Mine was the SZL $1299. That's with coding and programming

Sent from my DROID BIONIC using Bimmer App
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms