Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-04-2012, 01:51 PM
AlanEP AlanEP is offline
Registered User
Location: Canada
 
Join Date: Nov 2012
Posts: 3
Mein Auto: 2002 X5
Unhappy 2002 X5 Left & Right Turn Signal Not Working Good!!!

Hi, someone could help me to fix this problem when i turn my signal to left the right turn signal was working if i switch to right nothing is working. how can i fixed myself or do i need to bring this to service cnter?

Thanks,

Alan
Reply With Quote
Ads by Google
  #2  
Old 11-05-2012, 06:50 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 804
Mein Auto: 2001 X5 3.0L
Do all lights work when you turn on the Hazards?
If so I would suspect the turn signal stalk or the LKM. The stalk is cheapest so start there first. The LKM will require "Coding" to get it to work with your vehicle and is an expensive little module.
Reply With Quote
  #3  
Old 11-05-2012, 03:43 PM
motordavid's Avatar
motordavid motordavid is offline
RetiredBum
Location: Mtns of Western NC & SW FLA
 
Join Date: Sep 2004
Posts: 745
Mein Auto: '01 X5 3.0 '02VetteVert
Sometimes the no turn sig situ can be 'fixed'/stalled with cleaning the turn signal bulb contacts; a knuckle busting job, in my experience.
Or, a new relay(s) wiring harness: pretty inexpensive, not hard to replace, but a good BMW Indie will have seen/done dozens of that repair on various models of
BMWs, and can fix it 15 mins. If it isn't the bulb(s), bulb contacts, or relay(s), I have no clue...
GL, mD
__________________
Ol'Uncle Motor
'01 X5 3.0 Sport, 5 Spd Manual, etc.
'02 VetteVert 6 Spd, Z51 susp.
'10 Hyundai Tucson for the CEO, & 3 Assorted M'Cycles.
BMW CCA mem. Tarheel Chapter
My Flickr...Scenes,Cars & Road Trip Pics:
http://www.flickr.com/photos/45275375@N00/
Reply With Quote
  #4  
Old 11-07-2012, 08:55 PM
AlanEP AlanEP is offline
Registered User
Location: Canada
 
Join Date: Nov 2012
Posts: 3
Mein Auto: 2002 X5
2002 x5 left & right is now ok!

i did not touch anything now its working i dont really know why? it's due to heavy rain or what?
Reply With Quote
  #5  
Old 11-08-2012, 12:56 PM
motordavid's Avatar
motordavid motordavid is offline
RetiredBum
Location: Mtns of Western NC & SW FLA
 
Join Date: Sep 2004
Posts: 745
Mein Auto: '01 X5 3.0 '02VetteVert
Quote:
Originally Posted by AlanEP View Post
i did not touch anything now its working i dont really know why? it's due to heavy rain or what?
Could be...my left turn signal would go on 'fast blink' often, and on occasion work only 'manually', and then sometimes not at all. Did this for a year; I cleaned the socket and put in a new bulb, (knuckle buster). It worked ok for awhile...then started the above mannerisms again. When I was into my Indie for other stuff I had them change the turn signal relay.

If yours works for awhile/forever, great. But, I suspect it will glitch again sooner or later. A new relay harness will cure it, imo.
GL, mD
__________________
Ol'Uncle Motor
'01 X5 3.0 Sport, 5 Spd Manual, etc.
'02 VetteVert 6 Spd, Z51 susp.
'10 Hyundai Tucson for the CEO, & 3 Assorted M'Cycles.
BMW CCA mem. Tarheel Chapter
My Flickr...Scenes,Cars & Road Trip Pics:
http://www.flickr.com/photos/45275375@N00/
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms