Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-11-2012, 01:55 AM
cowper69 cowper69 is offline
Registered User
Location: Newcastle Australia
 
Join Date: Apr 2010
Posts: 14
Mein Auto: Bmw 91 325i manual sedan
Idle Control Valve

Hi,Could somebody please tell me, is the Idle Control Valve from an 1992 E34 M50 supposed to buzz when the engine is running or only when the ignition is turned on before the engine starts.
Thanks Ian
Reply With Quote
Advertisement
  #2  
Old 11-11-2012, 02:45 AM
_Ethrty-Andy_'s Avatar
_Ethrty-Andy_ _Ethrty-Andy_ is offline
E34 Converted E30 Fanatic
Location: Humble New Zealand
 
Join Date: Nov 2008
Posts: 6,140
Send a message via MSN to _Ethrty-Andy_
Mein Auto: E34 Touring AC Schnitzer
pretty sure its all the time, but you usually wont be able to hear it when the engine is on obviously. sorry i dont have an M50 in the shop to check at the moment
__________________

E30 above Sold

E34 V12 Project Thread Here: http://www.bimmerfest.com/forums/sho...=502437&page=4
Last updated 2nd January 2014
Reply With Quote
  #3  
Old 11-11-2012, 04:04 AM
cowper69 cowper69 is offline
Registered User
Location: Newcastle Australia
 
Join Date: Apr 2010
Posts: 14
Mein Auto: Bmw 91 325i manual sedan
Thanks for the reply, I started the car the other day with the air filter box out and touched the idle control valve, couldn't feel it vibrating, it buzzes with ignition on, cleaned it and checked the resistance, all within spec, car is stalling as you stop when it has been parked for more than ten minutes after being at operating temperature, checked the sensors all in spec except for coolant temp. sender so replaced it, 02 sensor replaced recently, stomp test does not work on my car for some reason. Bentley manual says ICV should buzz while engine running
Thanks Ian
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms