Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2012, 07:28 AM
Chaoul1 Chaoul1 is offline
Registered User
Location: Fairfax,VA
 
Join Date: Nov 2012
Posts: 10
Mein Auto: BMW 528i
1998 528i Speedometer Not working!

I have a BMW 528i and the Speedometer isn't working. All I found while searching around was that it could be the ABS Sensor or the DSC Module. Are these the two possiblities? I heard that if it is the DSC Module, I can get it rebuilt. If it's the ABS Speed Sensor I'll replace that myself. Any suggestions as to what it would be?

I'm at school now driving my Jeep. The BMW is at home and I'll be home at around 5:30. I'll check and see what lights are on/off.

Will bringing it to advanced auto parts help tell me what's happening? I don't feel like going to the dealership where the rate is $150 to do a Diagnostic check.

Everything else works great. Nothing else is wrong with the car except for the Speedometer not working.



Thanks!

Last edited by Chaoul1; 11-13-2012 at 07:29 AM.
Reply With Quote
Advertisement
  #2  
Old 11-13-2012, 07:39 AM
cn90 cn90 is offline
Officially Welcomed to the 'Fest
Location: Omaha NE
 
Join Date: Mar 2006
Posts: 12,882
Mein Auto: 1998 528i 5-sp 140K+
Likely bad speed sensor (mounted at the wheel hub).
Reply With Quote
  #3  
Old 11-13-2012, 11:50 AM
black528i black528i is offline
Registered User
Location: Lincoln, NE
 
Join Date: Jan 2012
Posts: 68
Mein Auto: 97 528i
Wheel speed sensor on the left-rear wheel, see part #24 at RealOEM.
Reply With Quote
  #4  
Old 11-13-2012, 01:32 PM
Chaoul1 Chaoul1 is offline
Registered User
Location: Fairfax,VA
 
Join Date: Nov 2012
Posts: 10
Mein Auto: BMW 528i
I hope so. Will a scan tool from advance auto parts being up a code? Ill look at it once I get home from school and see what lights are on again.

Thanks guys!
Reply With Quote
  #5  
Old 11-13-2012, 03:38 PM
AntsE39 AntsE39 is online now
Registered User
Location: sunny Florida
 
Join Date: Oct 2012
Posts: 76
Mein Auto: E39 528iA
I dont believe there scanner can read that deep into our cars.

Anthony
Reply With Quote
  #6  
Old 11-13-2012, 05:25 PM
Chaoul1 Chaoul1 is offline
Registered User
Location: Fairfax,VA
 
Join Date: Nov 2012
Posts: 10
Mein Auto: BMW 528i
I'll buy the wheel sensor and see if it works! Thanks for the help!
Reply With Quote
  #7  
Old 11-13-2012, 06:49 PM
black528i black528i is offline
Registered User
Location: Lincoln, NE
 
Join Date: Jan 2012
Posts: 68
Mein Auto: 97 528i
Make sure you get an OEM one. It will save you the time and the hassle of returning the cheap one that doesn't work.
Reply With Quote
  #8  
Old 11-14-2012, 11:14 AM
Chaoul1 Chaoul1 is offline
Registered User
Location: Fairfax,VA
 
Join Date: Nov 2012
Posts: 10
Mein Auto: BMW 528i
Okay so everything is good! Thanks, but I got another problem.....I have a check engine light. I got the code. It's P0319 which is a Rough Road Sensor A- Circuit Malfunction. What do I have to replace now?
Reply With Quote
  #9  
Old 11-14-2012, 12:39 PM
mlnotl mlnotl is offline
Registered User
Location: Canada
 
Join Date: Nov 2012
Posts: 1
Mein Auto: 528i
Hi:
My 2000 528i has been showing the Abs sensor light in the dash and now the speedometer and odometer are not working. I have had the car checked and the sensors looked at but that doesn't seem to be the problem. Could it be a short somewhere or a loose wire?
Reply With Quote
  #10  
Old 11-14-2012, 01:40 PM
Chaoul1 Chaoul1 is offline
Registered User
Location: Fairfax,VA
 
Join Date: Nov 2012
Posts: 10
Mein Auto: BMW 528i
Quote:
Originally Posted by mlnotl View Post
Hi:
My 2000 528i has been showing the Abs sensor light in the dash and now the speedometer and odometer are not working. I have had the car checked and the sensors looked at but that doesn't seem to be the problem. Could it be a short somewhere or a loose wire?
Did you replace the Left Rear Speed Sensor? How did you check?
Reply With Quote
  #11  
Old 11-14-2012, 12:41 PM
black528i black528i is offline
Registered User
Location: Lincoln, NE
 
Join Date: Jan 2012
Posts: 68
Mein Auto: 97 528i
DTC Codes P0300-P0399 are for Ignition System or Misfire in OBD II. Thats all I could find.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms