Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-11-2013, 05:38 PM
bpress365 bpress365 is offline
Registered User
 
Join Date: May 2012
Posts: 1
Mein Auto:
"limp mode"

I have a 1998 528i and the transmission has a sensor that has gone bad (I think). The sensor will cause it to go into" limp mode" (almost like it is slipping) I knew before I bought the car it had a new transmission. So I checked the fluid it was fine. I cleaned the connector on the sensor and it is working now but if I have to replace it does anyone know of a good reputable place to buy used parts?

Regards
Bpress365

Last edited by bpress365; 01-11-2013 at 06:15 PM.
Reply With Quote
Ads by Google
  #2  
Old 01-12-2013, 10:22 AM
rdl rdl is offline
Officially Welcomed to the 'Fest
Location: Ontario, Canada
 
Join Date: Jun 2010
Posts: 1,020
Mein Auto: 530i 2003
For a start try the sites that show up here
http://www.furiousmethod.com/

Also check out Bluebee's best links thread on page 1 of this E39 forum. I'm sure there is a section on recommended vendors.

Also search the best links thread for transmission for help with diagnosis. You don't sound certain of the sensor being at fault. BTW, limp mode will feel like a lot of slip. Slip mode defaults to 4th gear so the torque converter does need a lot of slip while pulling away from a stop.
__________________
Regards
RDL
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms