Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-25-2013, 01:47 AM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 57
Mein Auto: E66 750li
BMW E66 problem when refueling

Hi


I had this problem for over a year now



skip to ( 1:05 )

When refueling the filler thingy clicks at a random tank level ( mostly less than a half ) while it normally should only clicks if the tank is fully filled


And therefore as you can see it takes 4 minutes to refill the tank 0_0


What do you think is the issue ?


the computer gives this fault code :

2A13 DMTL Leak Diagnosis pump, activation



Thank you

Last edited by See-5; 01-25-2013 at 01:48 AM.
Reply With Quote
Advertisement
  #2  
Old 01-25-2013, 01:54 AM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 57
Mein Auto: E66 750li
Is this the solution http://www.bimmerfest.com/forums/sho...d.php?t=555805


?
Reply With Quote
  #3  
Old 01-27-2013, 04:23 AM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 57
Mein Auto: E66 750li
up
Reply With Quote
  #4  
Old 01-27-2013, 07:13 AM
gmcclintock's Avatar
gmcclintock gmcclintock is offline
Maintainin'
Location: Alabama
 
Join Date: Aug 2009
Posts: 923
Mein Auto: 2006 750Li
Yes I think that thread is the solution, I had the same problem a while back and I had the vent valve replaced and never had that issue since. You might want to show that video to your SA and he/she will tell you exactly what is causing the problem.
__________________
<div align=center>
85 Honda Accord(Sold), 93 Lexus GS 300(Gave to lil Bro), 96 Lexus LS 400(Sold)
03 BMW 525i(Traded/Sold), 06 BMW 750Li(daily driver), 07 BMW 530i(My Baby's daily dirver)
Reply With Quote
  #5  
Old 01-27-2013, 12:13 PM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 57
Mein Auto: E66 750li
Quote:
Originally Posted by gmcclintock View Post
Yes I think that thread is the solution, I had the same problem a while back and I had the vent valve replaced and never had that issue since. You might want to show that video to your SA and he/she will tell you exactly what is causing the problem.


Thx !
Reply With Quote
  #6  
Old 01-28-2013, 08:11 AM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 57
Mein Auto: E66 750li
So it isn't the Vapor canister ?





It costs 407 $ :\
Reply With Quote
  #7  
Old Yesterday, 06:01 PM
cl1987 cl1987 is offline
Registered User
Location: Dallas, Tx
 
Join Date: Aug 2014
Posts: 17
Mein Auto: 750i
Quote:
Originally Posted by See-5 View Post
So it isn't the Vapor canister ?





It costs 407 $ :\

Where is this hose on a bimmer 07 750i. I think i need to clean mine out.
Reply With Quote
  #8  
Old 01-28-2013, 10:36 AM
See-5 See-5 is offline
Registered User
Location: Saudi Arabia
 
Join Date: Jan 2013
Posts: 57
Mein Auto: E66 750li
this part is what the fault codes described !

http://www.eeuroparts.com/Parts/2934...p-16137193479/


I must check with the workshop to ensure though
Reply With Quote
  #9  
Old Yesterday, 10:37 AM
meangreen94z meangreen94z is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Jun 2010
Posts: 117
Mein Auto: 2004 BMW 745i sport
It sounds like you top your tank off. When the pump clicks once, that's it. If you top your tank off fuel will spill into the canister and saturate the charcoal filter and ruin your DMTL pump. You won't be able to pump fuel normally and it will set a fault sometimes for the pump.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms