Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2013, 11:17 AM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
07 530i jerk forward when coming to a stop Please HELP

Hi all, I'm new on this forum and try doing a search for this as well but ended up with no answer to my question.

I just got a 2007 530i and notice that when I'm driving the car and coming to a red light or stop the car jerks forward a little right before I stop? I had seen some people with this problem but has anyone gotten it taken care of and what had to be done or replace for this problem to go away ? Any help will be great !
THANKS
John

Last edited by JOHNNY2271; 01-27-2013 at 11:19 AM.
Reply With Quote
Advertisement
  #2  
Old 01-27-2013, 11:54 AM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
Anyone ?
Reply With Quote
  #3  
Old 01-27-2013, 12:46 PM
H F H F is offline
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 1,961
Mein Auto: 2005 545i
Quote:
Originally Posted by JOHNNY2271 View Post
Anyone ?
i had the same problem on my 545.. at the time it was still under waranty.. once they updated the tranny software the problem went away.....
__________________
Reply With Quote
  #4  
Old 01-27-2013, 12:49 PM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
Thank you H F, by any chance do you know if the tranny software can only be done at BMW ? I'm new to BMW sorry for the rookie questions.
Thanks John
Reply With Quote
  #5  
Old 01-27-2013, 01:47 PM
H F H F is offline
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 1,961
Mein Auto: 2005 545i
Quote:
Originally Posted by JOHNNY2271 View Post
Thank you H F, by any chance do you know if the tranny software can only be done at BMW ? I'm new to BMW sorry for the rookie questions.
Thanks John
not sure.. it would b worth it,,,, to find out if a indy shop can update the tranny. keep reading the posts on this site u will defitnatly learn a tremondous amount. this is a great site.. evryone is willing to help and some of these guys are pretty informative. ive learned more about my 545 in the last 6 months from reading here,,, than i have in the 5 years that ived owned it.... keep looking thru the posts theres alot of info on ur exact issue....
__________________

Last edited by H F; 01-27-2013 at 01:49 PM.
Reply With Quote
  #6  
Old 01-27-2013, 02:05 PM
Vapiano's Avatar
Vapiano Vapiano is offline
Officially Welcomed to the 'Fest
Location: Maryland
 
Join Date: Jan 2013
Posts: 155
Mein Auto: Dinan E60 M5 & 545i
This site is amazing, lots to learn for sure.
Reply With Quote
  #7  
Old 01-27-2013, 02:20 PM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
Thanks for the info guys
Reply With Quote
  #8  
Old 01-27-2013, 02:29 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Replace your mechatronik adapter
Reply With Quote
  #9  
Old 01-27-2013, 02:54 PM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
SFBAY did you have to replace your mechatronic adapter to get this problem fix on your car ? and if so does the adapter cost a lot ?
Thanks John
Reply With Quote
  #10  
Old 01-27-2013, 03:11 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by JOHNNY2271 View Post
Thank you H F, by any chance do you know if the tranny software can only be done at BMW ? I'm new to BMW sorry for the rookie questions.
Thanks John
It CAN be done outside of the dealerships, but they are probably your best bet. WinKFP software can do the upgrade but I've never been brave enough to try it.

Quote:
Originally Posted by SFbay View Post
Replace your mechatronik adapter
Do you mean sealing sleeve?
Reply With Quote
  #11  
Old 01-27-2013, 05:09 PM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
well i'm going to check out this problem this week and will make sure to post the info and what was fix for anyone who is having the same problem.
Reply With Quote
  #12  
Old 01-27-2013, 05:50 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by JOHNNY2271 View Post
SFBAY did you have to replace your mechatronic adapter to get this problem fix on your car ? and if so does the adapter cost a lot ?
Thanks John
Yes it did fix my and many others tranny issues. Software update won't do a sht.
25$ adapter
23$ sleeve
Dealer knows these parts
Reply With Quote
  #13  
Old 01-27-2013, 06:02 PM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
Thank you SFBAY going to check this out 1st thing tomorrow morning.
Reply With Quote
  #14  
Old 01-27-2013, 06:07 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
I'm sure there's more to it than just replacing the adapter and sleeve. Will you have to clean it out with isopropyl alcohol, parts cleaner or anything like that? It's my understanding that its the degraded sleeve allowing trans fluid in the connection creating the tranny malfunction/jerk. Is this correct?
Reply With Quote
  #15  
Old 01-28-2013, 08:45 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,627
Mein Auto: '06 530i, '07 C280, ML320
Sleeve (electrical connector to the mechatronics unit on the transmission) itself is not the problem. The o-rings on the sleeve degrade and allows the trans fluid to seep out.

Leaking sleeve in itself doesn't cause transmission problems. If the leakage is severe enough and enough fluid has leaked out, DUE TO LOW TRANS FLUID, transmission starts to have problems.

If you don't see any leakage around the sleeve, then it's not causing the trans problems. It's easy to see if the sleeve is leaking.
Reply With Quote
  #16  
Old 01-28-2013, 10:54 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by pcy View Post
Sleeve (electrical connector to the mechatronics unit on the transmission) itself is not the problem. The o-rings on the sleeve degrade and allows the trans fluid to seep out.

Leaking sleeve in itself doesn't cause transmission problems. If the leakage is severe enough and enough fluid has leaked out, DUE TO LOW TRANS FLUID, transmission starts to have problems.

If you don't see any leakage around the sleeve, then it's not causing the trans problems. It's easy to see if the sleeve is leaking.
I was coming in here to say exactly that...

A seal leaking does NOT make the transmission do weird things. A low fluid level (caused by leaking seal) on the other hand..

He is right--if it's leaking enough to be the source of your issue, it's pretty noticeable
Reply With Quote
  #17  
Old 01-28-2013, 10:19 AM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by pcy View Post
Sleeve (electrical connector to the mechatronics unit on the transmission) itself is not the problem. The o-rings on the sleeve degrade and allows the trans fluid to seep out.

Leaking sleeve in itself doesn't cause transmission problems. If the leakage is severe enough and enough fluid has leaked out, DUE TO LOW TRANS FLUID, transmission starts to have problems.

If you don't see any leakage around the sleeve, then it's not causing the trans problems. It's easy to see if the sleeve is leaking.
Exactly. But even if it leaks you can add fluid and you'll be fine for a while, but mechatronik adapter is way way more important, bc it's responsible for fluid pressure inside!
Reply With Quote
  #18  
Old 01-28-2013, 01:51 PM
JoeFromPA JoeFromPA is offline
Officially Welcomed to the 'Fest
Location: West Chester, PA
 
Join Date: Jan 2007
Posts: 1,738
Mein Auto: 01 M5, 08 535xit
Quote:
Originally Posted by JOHNNY2271 View Post
Hi all, I'm new on this forum and try doing a search for this as well but ended up with no answer to my question.

I just got a 2007 530i and notice that when I'm driving the car and coming to a red light or stop the car jerks forward a little right before I stop? I had seen some people with this problem but has anyone gotten it taken care of and what had to be done or replace for this problem to go away ? Any help will be great !
THANKS
John
Hi John,

My 08 535xit I just got has the same symptom that feels like a shudder right as I come to a stop. Please let me know if you get a fix for it.
__________________
01 m5 - 127k miles 11/2013....08 535xit - 94k miles
Reply With Quote
  #19  
Old 01-28-2013, 03:33 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Ppl, don't even think that software update will fix anything.
You had a car for a while and for some reason your sw crashed, or what??? This is ridiculous to think that sw is related, was it what hacked through Internet, or what happened to the old sw??
Reply With Quote
  #20  
Old 01-28-2013, 05:02 PM
JOHNNY2271 JOHNNY2271 is offline
Registered User
Location: NEW YORK
 
Join Date: Jan 2013
Posts: 23
Mein Auto: E60 530I
Hi everyone, so this morning i went to my shop and try getting this done but the guy was supper busy. I'm going back tomorrow morning to check for low tranny fluid level and any types of leaks. I just got this car not more then a week ago, I just hope it nothing big for i have big plans for the car. I will keep everyone posted for those who has this problem as soon as i know more.

*joefrompa i can msg you as soon as i know more info tomorrow morning.
*bmwoem1 thanks for reaching out to me, I live in Brooklyn but if it does come down to a software update i will hit you up for sure and meet up with you. But as a master tech have you seen these problems on the 5 series before and if so what are the steps to checking/ treating the problem. Thanks again!
Reply With Quote
  #21  
Old 01-28-2013, 06:01 PM
Frenchyrider267 Frenchyrider267 is offline
Frenchy
Location: Hawaii
 
Join Date: Sep 2012
Posts: 172
Mein Auto: 2004 525i
Okay, we'll I think I know what I need to do then.

-fluid/filter change (I'm at 110k miles)
-change sleeve/o-rings/adapter
-ensure fluid is at proper level when filling.
-reset adaptions.

That's all right?
Reply With Quote
  #22  
Old 01-28-2013, 06:16 PM
H F H F is offline
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 1,961
Mein Auto: 2005 545i
Quote:
Originally Posted by Frenchyrider267 View Post
Okay, we'll I think I know what I need to do then.

-fluid/filter change (I'm at 110k miles)
-change sleeve/o-rings/adapter
-ensure fluid is at proper level when filling.
-reset adaptions.

That's all right?
i think frequent fluid change is crutial on these high tech trannys im at 90,000 and just did my 3rd fluid change..
__________________
Reply With Quote
  #23  
Old 01-28-2013, 07:02 PM
Vapiano's Avatar
Vapiano Vapiano is offline
Officially Welcomed to the 'Fest
Location: Maryland
 
Join Date: Jan 2013
Posts: 155
Mein Auto: Dinan E60 M5 & 545i
Interesting thread; I am going to change out my transmission fluid in the next few weeks. At 60k miles it seems that this will be considered preventive maintenance. I understand that swapping out the tranny fluid in these cars is somewhat a complicated process and you never really get all the gunk out.

Last edited by Vapiano; 01-28-2013 at 07:07 PM.
Reply With Quote
  #24  
Old 01-28-2013, 07:03 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,318
Mein Auto: 2004 545i
Quote:
Originally Posted by Vapiano View Post
Interesting thread; I am going to change out my transmission fluid in the next few weeks. At 60k miles it seems that this will be considered preventive maintenance.
You should reset adaptations as well via INPA. Too many people don't do this step.
Reply With Quote
  #25  
Old 01-28-2013, 07:24 PM
Vapiano's Avatar
Vapiano Vapiano is offline
Officially Welcomed to the 'Fest
Location: Maryland
 
Join Date: Jan 2013
Posts: 155
Mein Auto: Dinan E60 M5 & 545i
Quote:
Originally Posted by schpenxel View Post
You should reset adaptations as well via INPA. Too many people don't do this step.
schpenxel, can you please elaborate on this? Thanks.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms