Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E90/E92/E93 M3 (2008 - 2014)

E90/E92/E93 M3 (2008 - 2014)
4th generation E90 M3 sedan, E92 M3 coupe and E93 M3 convertible. The last of the naturally aspirated M3s, powered by a 4.0 liter V8 making 414hp and 295 lb-ft of torque.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-23-2013, 03:23 PM
BR1060 BR1060 is offline
I'm rolling. they hating!
Location: Pflugerville,TX
 
Join Date: Jul 2011
Posts: 14
Mein Auto: 2007 335i
Driver Side Rear Speaker doesn't output any sound

2009 E92 with iDrive, and pretty sure I have the hi-fi system, there are 11 speakers and they are a gold color.

Driver side Rear speaker, DOA. Uninstalled it, ran it to a voltmeter, saw some current, thought it was the speaker itself. Replaced it. Still DOA.

Not sure what to do next, or where to check? Do these speakers require the mid and the high to be hooked up to work properly? I've not checked the high, but figured since the mid itself wasn't working, that was the culprit...
__________________
2009 //M3
Reply With Quote
Advertisement
  #2  
Old 02-24-2013, 10:11 PM
Technic's Avatar
Technic Technic is offline
Test... 1, 2 ,3
Location: Florida
 
Join Date: Jun 2002
Posts: 4,939
Mein Auto: 2012 M3 - 2014 528i
Quote:
Originally Posted by BR1060 View Post
2009 E92 with iDrive, and pretty sure I have the hi-fi system, there are 11 speakers and they are a gold color.

Driver side Rear speaker, DOA. Uninstalled it, ran it to a voltmeter, saw some current, thought it was the speaker itself. Replaced it. Still DOA.

Not sure what to do next, or where to check? Do these speakers require the mid and the high to be hooked up to work properly? I've not checked the high, but figured since the mid itself wasn't working, that was the culprit...
That's not the HiFi (black cones), it is the Enhanced Premium Audio system (yellow cones).

Take it to the dealer.
Reply With Quote
  #3  
Old 02-25-2013, 04:25 AM
BR1060 BR1060 is offline
I'm rolling. they hating!
Location: Pflugerville,TX
 
Join Date: Jul 2011
Posts: 14
Mein Auto: 2007 335i
Warranty has expired

Trying to avoid the $tealership at all cost... They tried to charge $268 to replace the micro filters... That in itself is attempted robbery
__________________
2009 //M3
Reply With Quote
  #4  
Old 02-25-2013, 09:45 AM
NASA43's Avatar
NASA43 NASA43 is offline
Make Their Ass Quit!
Location: Alabama
 
Join Date: Jul 2003
Posts: 1,266
Mein Auto: 2008 M3
Quote:
Originally Posted by BR1060 View Post
Warranty has expired

Trying to avoid the $tealership at all cost... They tried to charge $268 to replace the micro filters... That in itself is attempted robbery
The fact that the micro filters cost $105 for just the part is the really ridiculous aspect.
__________________
2008 M3 Sedan, Silverstone II, Fox Red Extended, 6MT
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E90/E92/E93 M3 (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms