Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-28-2013, 03:29 PM
BMRfanatic's Avatar
BMRfanatic BMRfanatic is online now
Officially Welcomed to the 'Fest
Location: South Shore MA
 
Join Date: Mar 2008
Posts: 4,986
Mein Auto: Bad Luck 46
Door Lock and Alarm problem

Hey guys e36'er here.

My brother got an 01 X5 3.0 and his locks just started giving problems


At first it started as all the doors would lock with the remote except the driver door. (Alarm wouldnt arm)

after a couple tries it started to work normal again (all doors lock with alarm armed)

Few days later the car sees the driver door being open all the time even though its closed and the dome light would stay lit. Along with this issue the driver door would no longer unlock or lock with the remote (so now the others lock/unlock with the remote, however the alarm wouldnt arm)

My brother also told me that the windows were acting up also he couldnt control the other windows from the driver door but they work fine on their own switches

Based off what we search online (xoutpost, etc...) we unplugged the battery for a couple minutes then the car just didnt see the driver door at all. now when the door it open the car doesnt register it as open but reports other doors.

Driver door still doesnt lock with remote but locks with the key. Even with the key the other doors dont lock unless you use the remote.

The redlight under mirror blinks fast after using the remote

As of now the car has a new window switch for the driver door but from what i assume nothing changed

any ideas?

would a new lock actuator solve this problem?
__________________

-Dino
Reply With Quote
Ads by Google
  #2  
Old 03-30-2013, 11:08 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,667
Mein Auto: 1997 740iL / 2006 X5 4.4
If the DWA red LED status light (the clown nose below the rear view mirror) is giving you 10 fast flashes...it means that one of the monitors is registering that it is still open. And from the explanation/description you gave of what's been going on...I'd have to think the issue is the driver's door actuator.

Also..remember that the 3 button remote contains 3 features that are all individual systems but work in conjunction with each other...some even sending data to the same components (GM III):
  1. EWS - immobilizing system...shuts down starter/fuel/spark until the ISN (individual serial number) coded to all the EWS components has been verified (data is sent to & from the EWS/DME/Ring Antenna & transponder inside the key)
  2. FZV - keyless entry/central locking system which locks/unlocks the doors & trunk as well as the fuel filler door...and can operate the sunroof & windows
  3. DWA - anti-theft alarm siren system...which arms/disarms the alarm siren system and monitors all the doors, trunk, hood, interior motion sensor, and tilt sensor.

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 03-30-2013 at 11:09 AM.
Reply With Quote
  #3  
Old 04-01-2013, 07:41 AM
BMRfanatic's Avatar
BMRfanatic BMRfanatic is online now
Officially Welcomed to the 'Fest
Location: South Shore MA
 
Join Date: Mar 2008
Posts: 4,986
Mein Auto: Bad Luck 46
Wow, thanks for that DWA pic

would the actuator cause the window not to work as well? I dont see how they are related but then again im new to the e53
__________________

-Dino
Reply With Quote
  #4  
Old 04-01-2013, 09:09 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,667
Mein Auto: 1997 740iL / 2006 X5 4.4
The windows are controlled by the door module/switch blocks. Below is a link to a downloadable PDF about the Central Body Electronics (ZKE III) which is used on the e38/e39/e53...there's lots of info about central locking/remote keyless entry (FZV), door locks, power windows, anti-theft alarm system (DWA), etc...that you may find helpful with the issues you're having:


(Click link to download ZKE III PDF: http://www.bmwmotorsports.org/BMW_docs/x5zkeIII.pdf

**************************************************

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #5  
Old 04-02-2013, 12:51 PM
BMRfanatic's Avatar
BMRfanatic BMRfanatic is online now
Officially Welcomed to the 'Fest
Location: South Shore MA
 
Join Date: Mar 2008
Posts: 4,986
Mein Auto: Bad Luck 46
Cool thanks, I think we narrowed it down by using that.
__________________

-Dino
Reply With Quote
  #6  
Old 04-07-2013, 10:26 AM
BMRfanatic's Avatar
BMRfanatic BMRfanatic is online now
Officially Welcomed to the 'Fest
Location: South Shore MA
 
Join Date: Mar 2008
Posts: 4,986
Mein Auto: Bad Luck 46
OK , we changed the lock actuator but still nothing. The car doesn't see the door and the alarm system sometimes will arm if you use the remote. All doors except driver door will lock.

Sometimes the alarm won't work, but the doors will lock,except for the driver door. Using DIS there wasn't, any codes for the driver door only the key(but a new key was purchased a couple months ago)

There are 2 wires that are hanging and we can't find where the belong. They seem to have ripped out of there connector



Sent from my SPH-D710 using Bimmer App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1365355579744.jpg
Views:	91
Size:	100.4 KB
ID:	370175   Click image for larger version

Name:	uploadfromtaptalk1365355593804.jpg
Views:	84
Size:	112.0 KB
ID:	370176   Click image for larger version

Name:	uploadfromtaptalk1365355604808.jpg
Views:	74
Size:	93.2 KB
ID:	370177   Click image for larger version

Name:	uploadfromtaptalk1365355617381.jpg
Views:	71
Size:	109.2 KB
ID:	370178  
__________________

-Dino
Reply With Quote
  #7  
Old 02-03-2014, 09:29 AM
vedmini vedmini is offline
Registered User
Location: GE
 
Join Date: Feb 2014
Posts: 80
Mein Auto: X5 2004
Hi, I got X5 2004 model. Alarm System does not arms. When I close the doors light does not flashes. Activating Panic mode (locking doors and pushing the third button on remote key for some seconds) car starts flashing beam lights, but does not give alarm voice. what can be an issue? How to fix?
Reply With Quote
  #8  
Old 02-04-2014, 11:00 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,667
Mein Auto: 1997 740iL / 2006 X5 4.4
First, double check to see if the alarm system (DWA) is actually being activated by observing the "clown nose" DWA (alarm siren system) red LED below the rear view mirror. The DWA system sounds an alarm & activates the lights to indicated a theft attempt. See the chart below that indicates what the red LED status light communicates by it's flashing.




The DWA (anti-theft alarm siren system) also can be programmed through a car/key memory setting (BMW DIS/GT-1/MoDiC or aftermarket software/hardware) to give an audible and/or visual alert when arm/disarm acknowledgement. This feature is optional...and can be set-up for either of the four settings to be activated or deactivated:


If the system is being armed when you lock the vehicle with the key (remotely or manually)...then perhaps the alarm siren has been disconnected...or is dead.




__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 02-04-2014 at 11:04 AM.
Reply With Quote
  #9  
Old 02-04-2014, 07:38 PM
BrandonG6 BrandonG6 is offline
Registered User
Location: San Diego
 
Join Date: May 2005
Posts: 8
Mein Auto: 1994 318is
I had wacky stuff going on with the door lock system on my e46 and it turned out to be a loose battery cable. Tightened it and the locking system started to act normal again.
Reply With Quote
  #10  
Old 02-14-2014, 07:49 PM
vedmini vedmini is offline
Registered User
Location: GE
 
Join Date: Feb 2014
Posts: 80
Mein Auto: X5 2004
QSilver7 --- Thank you very much! I could resolve the problem
Reply With Quote
  #11  
Old 02-14-2014, 09:04 PM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 351
Mein Auto: 2003 BMW X5
I know this is an old thread but I would like to coment on my lock actuator issue ,it was working once in awhile cause it was getting week and sometimes the alarm would go off because of it ,ever since I changed the lock actuator out it never happenned again and that was back in the summer sometime.
__________________
2003 X5 3.0i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms