Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2013, 09:39 AM
elliotra elliotra is offline
Registered User
Location: la jolla, CA
 
Join Date: Oct 2010
Posts: 3
Mein Auto: BMW X-5
Question x5 ws wipers stopped

help?
x5 2003 windshield wiper blades stopped working rear works fine
can't find a dedicated fuse
thanks
Reply With Quote
Ads by Google
  #2  
Old 03-30-2013, 10:03 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,388
Mein Auto: 1997 740iL / 2006 X5 4.4
I believe the wipers use a relay instead of fuses. And if like the e39...the wiper relay is probably located in the E-box in the engine bay.

I'm not familiar with the color of this relay since I've not had this issue on my e53...and I've only been on the e53 forum since Nov/2012...but I'm sure this is probably been asked before. Have you searched the forum yet or even done a google search for "BMW e53 wiper relay"? Oops...you were looking for a fuse...so the answer would be no.
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #3  
Old 03-30-2013, 10:13 AM
Zulu95's Avatar
Zulu95 Zulu95 is online now
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 803
Mein Auto: 2001 X5 3.0L
Also check the wiper linkage. There is a bolt that comes loose.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms