Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-17-2005, 09:17 PM
drewer drewer is offline
Registered User
Location: The OC, California
 
Join Date: Feb 2005
Posts: 1
Mein Auto: 1993 318i
Exclamation n00b needs help! Tach/Fuel/Temp gauges not working! (well, more too!)

Just yesterday, I got in my 93 318i, and when I started it up, the Service Interval Light area was all dim, and after the engine started, my Brake Fluid light and Park Brake light remained lit. I drove it around the parking lot, and noticed that my Tach as well as my temp gauge and fuel gauge were not responding. I tried restarting the car a few times, but no joy. Here is what I've checked so far:

Fuses under hood, all looked good and lit the light on my fuse tester. Tried disconnecting battery for 10 min and reconnecting, tried using my Peake tool to check for fault codes (none, as expected, since no CE light came on) and checked brake fluid level (at max line) and park brake functionality (worked).

I can barely read the dim odometer which does still function, which is how I'm going to have to tell when I need fuel.

Does anyone else have any ideas for me to try? I think I'm going to start replacing fuses next. . .

Thanks for any help!

-drew-
Reply With Quote
Advertisement
  #2  
Old 02-18-2005, 11:20 PM
AC Schnitzer AC Schnitzer is offline
EURO STYLE
Location: Seattle
 
Join Date: Mar 2004
Posts: 226
Mein Auto: two/325i,VW,Renault
did you check your battery, I know it seems kind of stupid but have it checked. how often do you drive your car? check relays.
__________________
Reply With Quote
  #3  
Old 02-19-2005, 02:50 PM
bol's Avatar
bol bol is offline
Crazy Canadian
Location: Victoria, BC
 
Join Date: Dec 2001
Posts: 1,095
Mein Auto: '01 M Roadster
I had to replace the gauge cluster on my '94 318 because the entire cluster would start/stop working intermittently while driving.

Faulty clusters are a fairly common problem with the early E36's.

My replacement cluster was cheap - the reprogramming of it wasn't.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: My Fan and A/C Completely stopped working palooka666 3 Series / 4 Series 4 06-26-2004 09:34 AM
Replacement Gauges on 325ci???? bsirk 3 Series / 4 Series 0 04-06-2004 11:04 PM
None of my gauges are working, and my car is hissing at me Citygal 3 Series / 4 Series 7 09-16-2003 08:58 AM
Gauges quit working (86 325ES) den 3 Series / 4 Series 0 06-07-2003 05:48 PM
Tire Pressure Gauges - Article by consumer reports. JSJAMALA 3 Series / 4 Series 0 07-21-2002 12:24 AM


All times are GMT -7. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms