Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-21-2005, 03:03 PM
Jus07 Jus07 is offline
Registered User
Location: London
 
Join Date: Feb 2005
Posts: 2
Mein Auto: 318i 1989
Unhappy Eratic misfiring M40/B18 engine - anyone else?

I've been to several mechanics with this problem and none seem to be able to help.


This problem is very erratic

A typical scenario is that car experiences misfiring / incredibly uneven firing for a period of 5 minutes (never when totally cold / usually anytime after 5 minutes of driving). I continue to drive and suddenly it then works perfectly for the rest of the journey sometimes the problem will vanish for a week or more only to return at a very odd time such as in the middle of a 2 hour motorway drive. When it happens if you stop and leave the engine at idle it splutters and revs to avoid stalling but eventually will stall.

-The misfiring can be quite severe causing the car to hop (at low speeds) if the clutch is not used.

-Higher revs helps to ease the problem.

- there are no faults recorded on the engine management system

-This can happen at idle or at very high revs, under load or not.

-Cold weather and long journeys the day before sometimes seem to be partial factors

My suspicions have ranged from:
-eratic air intake leak that his affected by air temperature?? I had the air intake -manifold gasket replaced and the problem seemed to go away for a while?
-eratic electornic sensor problems?

Has this happened to you or do you have any ideas what this could be?

Jus
Reply With Quote
Advertisement
  #2  
Old 02-22-2005, 07:58 PM
smc smc is offline
Registered User
Location: NY
 
Join Date: Feb 2005
Posts: 1
Mein Auto: 325i and 540i
Ignitor

I had the same problem and took it to the dealership. The ignitor had to be replaced. It's a common problem according to the service rep.

Quote:
Originally Posted by Jus07
I've been to several mechanics with this problem and none seem to be able to help.


This problem is very erratic

A typical scenario is that car experiences misfiring / incredibly uneven firing for a period of 5 minutes (never when totally cold / usually anytime after 5 minutes of driving). I continue to drive and suddenly it then works perfectly for the rest of the journey sometimes the problem will vanish for a week or more only to return at a very odd time such as in the middle of a 2 hour motorway drive. When it happens if you stop and leave the engine at idle it splutters and revs to avoid stalling but eventually will stall.

-The misfiring can be quite severe causing the car to hop (at low speeds) if the clutch is not used.

-Higher revs helps to ease the problem.

- there are no faults recorded on the engine management system

-This can happen at idle or at very high revs, under load or not.

-Cold weather and long journeys the day before sometimes seem to be partial factors

My suspicions have ranged from:
-eratic air intake leak that his affected by air temperature?? I had the air intake -manifold gasket replaced and the problem seemed to go away for a while?
-eratic electornic sensor problems?

Has this happened to you or do you have any ideas what this could be?

Jus
Reply With Quote
  #3  
Old 03-01-2005, 11:00 AM
Jus07 Jus07 is offline
Registered User
Location: London
 
Join Date: Feb 2005
Posts: 2
Mein Auto: 318i 1989
Quote:
Originally Posted by smc
I had the same problem and took it to the dealership. The ignitor had to be replaced. It's a common problem according to the service rep.
Thanks for your posting. When you say you had the ignition replaced. Do you know what they replaced i.e. I have replaced teh Ht leads and distributor cap and rotar arm but this does not seem to help?
Reply With Quote
  #4  
Old 04-27-2005, 02:01 AM
Damien1 Damien1 is offline
Registered User
Location: Ireland
 
Join Date: Apr 2005
Posts: 1
Mein Auto: E30 316i
Stalling/misfiring

Hi I was wondering if you have managed to sort this out at all. I'm having exactly the same issue and finding it difficult to get a diagnosis/resolution. Local BMW garage haven't cured. I'd be interested if you managed to get any more info
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Info on e46 M3 Bearings/oil pump service bulletin MUST READ TGray5 M Series 5 12-03-2007 09:08 PM
BMW ///M press release - BMW WilliamsF1 engine details PhilH Motorsports, Racing & Track 6 05-04-2006 11:33 AM
Engine freaked out (EML, DSC, Brake) FenPhen 3 Series / 4 Series 2 06-30-2004 08:14 AM
BMW Update for S54 Engines BMWNA M Series 2 08-13-2003 05:55 PM
Product review: Griot's Engine cleaner kit(m) The HACK The Detail Department 20 01-08-2002 07:56 PM


All times are GMT -7. The time now is 03:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms