help!!!radio no audio - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-01-2017, 11:55 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
help!!!radio no audio

I need help I been trying to fix the audio in my 2008 328i it doesn't have any audio no door chime/gong noise or music from radio it happened after it was at the body shop for about 3months can anyone help me could it be a fuse and what fuses would it be what symbol is the radio and the fuse for the navigation screen
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-02-2017, 02:34 AM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
Most likely the amp .
Did the car get hit in the rear driver side where the amp
resides.
You need to know which audio system you have this has nothing to do
with the Nav/idrive or head unit.
Its the amp speaker system in an 08 US car it will either be Logic 7 or
Hi Fi.

BMW stereo types
http://www.e90post.com/forums/showthread.php?t=352586
http://www.e90post.com/forums/attach...2&d=1266451970
http://www.e90post.com/forums/attach...2&d=1260829447
http://www.bmwmotorsports.org/pdf/e7...%20Systems.pdf
http://www.e90post.com/forums/showthread.php?t=343673
http://www.e90post.com/forums/showthread.php?t=138949
http://www.e90post.com/forums/attach...1&d=1209780605
http://www.e90post.com/forums/attach...1&d=1209780865
http://www.e90post.com/forums/showthread.php?t=641323
http://bmwcoders.com/forum/3-er-8/bm...1-e92-e93-291/
http://technicpnp.com/menuDiagrams/d...e90_92_93.html
http://www.musicarnw.com/page-2/
http://www.e90post.com/forums/attach...3&d=1169133185
http://www.bmwmotorsports.org/BMW_docs/mostbus.pdf
http://www.e90post.com/forums/attach...4&d=1278871872

https://www.newtis.info/tisv2/a/en/

Bently manual say Fuse F15 for Hi Fi or Logic 7 amp.

But I think its more likely it was damaged in the accident or not repaired or reconnected correctly .

Last edited by ctuna; 12-02-2017 at 02:54 AM.
Reply With Quote
  #3  
Old 12-03-2017, 01:04 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
it was a little crash in the front not the back airbag did go off tho and I have the hi go amp not the logic one mine is black I will check fuse 15 is there a fuse for the chime sound
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 12-03-2017, 02:23 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
the chimes come through the radio or idrive . If something is wrong with the audio
system no chimes . This is true on all e90's except the 06 models. The black amp is
a Hi Fi amp.
Reply With Quote
  #5  
Old 12-03-2017, 02:40 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
fuse number 15 is not there or maybe I'm using the wrong diagram
Reply With Quote
  #6  
Old 12-03-2017, 02:41 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
if I put it could anything really bad happen
Reply With Quote
  #7  
Old 12-03-2017, 03:31 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
I can not understand what your saying . Your English and spelling
is not getting the message across as to what you mean or what you
want to do.

Fuses vary by Year I looked up that fuse in the Bently manual and that is what
it said for the amp Fuse.

https://www.newtis.info/tisv2/a/en/e...5-fuse/idCA6gG

Its in the link above .

Think about it a fuse protects things as long as you put the right size fuse in the correct spot its protected.
Are you sure you have an 08 because the fuse diagram says its for the amp.
The fuse function for the other years is listed if you want to look at those.
And we are talking at the Fuse box panel behind the glove box.

Last edited by ctuna; 12-03-2017 at 03:42 PM.
Reply With Quote
  #8  
Old 12-03-2017, 03:52 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
is the fuse15 behind the glove box
Reply With Quote
  #9  
Old 12-03-2017, 04:00 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
bently manual say the following for amplifiers fuses either hi fi or logic 7
F34 to 3/07
F8 from 3/07
F15 from 9/07
these are based on build dates.
an 08 could be built in 07

Last edited by ctuna; 12-04-2017 at 12:35 PM.
Reply With Quote
  #10  
Old 12-03-2017, 04:16 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
it's a 2008 do u have a diagram u can show me maybe I'm using the wrong one I'm using a diagram for the fuses that I got from Google
Reply With Quote
  #11  
Old 12-03-2017, 04:16 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
I also notice a wire that's not connected in the trunk and it comes off the battery could that have something to do with it
Reply With Quote
  #12  
Old 12-03-2017, 04:19 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
do you kno what this is for or were it plugs in
Attached Thumbnails
Click image for larger version

Name:	15123431261911756796843_1512343152116.jpg
Views:	12
Size:	90.8 KB
ID:	724905  
Reply With Quote
  #13  
Old 12-03-2017, 06:30 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
That is the shipping wire . Its for putting the car in deep sleep during shipping
to save the battery . there is one connector that is always suppose to be unplugged back
there.
As I said the fuses change by build date so you would have to have the chart
that came with your car for it to be accurate.
You have to find the build date on the car then you can use the fuse number
I gave you. They usually start building the 08 model in the middle of 07.
Which means the amp Fuse could be F8 if the car was built from 3/07 to 9/07

http://www.bimmerfest.com/forums/sho...=shipping+wire

Hows the voltage on your battery ?
The IBS system can turn off the stereo and some other stuff if the battery volatge is low and the battery
is weak. Have the battery tested or try putting a full charge on it.

electical e90 pdf
http://www.google.com/url?sa=t&rct=j...,d.cGU&cad=rja
http://www.google.com/url?sa=t&rct=j...85464276,d.cGU
http://www.google.com/url?sa=t&rct=j...85464276,d.cGU

Last edited by ctuna; 12-03-2017 at 07:15 PM.
Reply With Quote
  #14  
Old 12-04-2017, 12:19 AM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
I am going to check the voltage tomorrow and I was watching some videos on YouTube trying to fix my problem and in one video I saw a guy instal an optical loop bypass in the satellite radio module so I went and checked in my trunk to see if I have that part and I don't have the satellite radio module or the tcu do all BMW comes with those could that be it
Reply With Quote
  #15  
Old 12-04-2017, 12:20 AM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
thanks for your help this problem been driving me crazy I miss hearing music when. I drive
Reply With Quote
  #17  
Old 12-06-2017, 07:12 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
witch symbol is the radio symbol
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20171206-180752_1512612496030.jpg
Views:	9
Size:	40.4 KB
ID:	726993  
Reply With Quote
  #18  
Old 12-06-2017, 07:17 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
when I pulled fuse number 8 the cigarette lighter stopped working is the arrow symbol with the plus and minus the symbol for cigarette lighter ?
Reply With Quote
  #19  
Old 12-06-2017, 08:24 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
08 fuses
Attached Files
File Type: pdf 08 fuses.pdf (248.5 KB, 20 views)
File Type: pdf 08 fuses page 2.pdf (249.1 KB, 17 views)
Reply With Quote
  #20  
Old 12-06-2017, 08:39 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
fuse number 8 is the cigarette lighter fuse I'm guessing fuse 15 is the radio I just put a new fuse in there what else could it be there no audio other than the turn signals make a noise nothing else does
Reply With Quote
  #21  
Old 12-06-2017, 09:26 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
F14 is radio f15 is amplifier .
Radio lights up and appears to functon
then the radio is probably not bad.
Is there power at the amplifier ?
Is the amp bad?
Is the IBS system turning of power to the amplifier?
Is there bad wiring to the amp or other places?
Ia the radio bad
All possiblitys .

If the car sat for 3 months will little driving the battery is probably shot.

Scan car for codes with a BMW capable scanner.

Last edited by ctuna; 12-06-2017 at 09:28 PM.
Reply With Quote
  #22  
Old 12-07-2017, 06:01 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
the radio lights up I put a fuse were 15 is because before there was no fuse there but it still hasn't turned on how could I test the amp to see if it works
Reply With Quote
  #23  
Old 12-07-2017, 06:08 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
this is the radio it has power just nav dosnt turn and there no sound
Attached Thumbnails
Click image for larger version

Name:	15126951208941058259578_1512695143102.jpg
Views:	10
Size:	73.4 KB
ID:	727761  
Reply With Quote
  #24  
Old 12-07-2017, 06:55 PM
ctuna ctuna is offline
Officially Welcomed to the 'Fest
Location: usa
 
Join Date: Jan 2010
Posts: 4,404
Mein Auto: 325xi wagon
Have you checked your battery voltage.
Run a BMW scanner on your car.
Run a Vin checker to determine which options you actually have.

https://www.bmwvin.com/


Now that we know you have idrive and a dead screen I would concentrate on that.
The screen would be considered part of the idrve radio so when you said its working
that is not correct. When you say radio that would indicate a car with pro radio only
and no nav/ idrive

1) http://www.e90post.com/forums/showth...ghlight=screen

2) http://www.e90post.com/forums/forumdisplay.php?f=122

F56 is the ccc/mask fuse = idrive 2nd page fuse pdf
also there is a fuse on the back of the unit.
See thread 1)

Try the search "dead screen " at link 2)

Last edited by ctuna; 12-07-2017 at 07:43 PM.
Reply With Quote
  #25  
Old 12-07-2017, 08:10 PM
1siccE90 1siccE90 is offline
Registered User
Location: los angeles
 
Join Date: Dec 2017
Posts: 22
Mein Auto: e90
the radio worked when the screen was off like sound I took it to BMW for a recall and it came back with the light all messed up so I took it back they fixed the lights but not the radio
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:35 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.