Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-30-2005, 04:29 PM
J.Clerihan J.Clerihan is offline
Registered User
Location: USA
 
Join Date: Apr 2005
Posts: 1
Mein Auto: BMW 5 series
Dash vents not working

Air conditioning working but not through dash vents, same with heat and defrost. Air flows through floor vents and back seat vents only. Could use help, mechanic not sure whats wrong.
Reply With Quote
Advertisement
  #2  
Old 05-03-2005, 10:48 AM
CheapCheap1 CheapCheap1 is offline
Registered User
Location: NY
 
Join Date: Apr 2005
Posts: 15
Mein Auto: '95 540i & '89 YuGo
When did you replace the microfilter last time?

Pls check if your car has installed w/ microfilter...

- If it has one, try to replace it 1st & see if the airflow rate is improved. (It's cost around $20-30.)
- If replacing the microfilter doesn't solve the problem, then, start looking at the blower motor to see if it's working. (Check the fuse in the box & the blower motor itself.)
- lastly, check if the motor open the flaps (in the air-duct) is working or not.

Good lucks...
__________________
'95 540i (auto)
(65K miles & running strong )
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash pixels have been repaired Cabriolet E39 (1997 - 2003) 30 03-16-2009 12:41 AM
Nokia 6230 fully working with BMW BT car kit - FINALLY !! Freddywaters Car Navigation, Audio & Electronics sponsored by BimmerTech 0 03-07-2005 07:55 AM
Keyless not working...? Thoughts pdxX5 X5 E53 (1999 - 2006) 7 02-23-2005 05:59 PM
91 850i Heater Core Removal Instructions Wanted nicko 7 Series / 8 Series 1 10-18-2004 10:56 PM
Speedometer and trip-meter not working, HELP OLd Shape! 5 Series DIY 5 09-14-2004 05:41 PM


All times are GMT -7. The time now is 02:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms