Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 06-11-2005, 09:24 AM
Gaza Gaza is offline
Registered User
Location: Edinburgh
 
Join Date: May 2005
Posts: 9
Mein Auto: 2004 X3 3.0SE
ice>link install

I have finally completed the install of an ice>link in my X3. It was a bit of a marathon!

Not wanting to damage my car I arranged for the Dension recommend installer to fit it. The technician arrived and was very perplexed. He had never fitted one to an X3 and it seemed as though no one else in his company had either.

Being curious I hung around while he began dismantling the facia. After about 20 minutes or so he attempted to connect the ice>link unit to test it but it didn't work. I pointed out to him that the instructions said the CD Changer that was currently fitted had to be completely disconnected. It was then the problems began.

Removing the CD Changer is not straight forward. It is held in place by 8 screws Ė 4 on each side. It is relatively easy to get at the front quartet as the cup holder comes out easily and provides easy access to the screws. The cup holder is removed by gripping it in an overhand grip and leveraging it upwards with your fingers.

The lower pair of the rear quartet can be accessed by removing the cigar lighter in the rear of the centre console. However, the upper pair can only be removed by dismantling the centre console. The technician was at a complete loss as to how to do this. After about 2 hours of mucking around he was eventually able to pull the connectors out of the CD Changer without removing it.

He then reconnected the head unit and ice>link but the head unit would not recognise the ice>link. At this point he declared the unit faulty and told me to order a replacement. There was no charge as their agreement with Dension is that in the event of a fault they bill Dension for the time.

In the period of time between the first attempt at fitting the kit and receiving the new one I decided to have a go at reconnecting the CD Changer. After reading reports on here it seemed quite straightforward to remove the console and reconnect the connectors.

This was not as big a job as it first seems. Iíve seen it detailed here on other threads but just to recap:-

You need to be in the rear cabin and have removed the cigar lighter assembly. You will see two medium sized nuts that hold the assembly to the floor. These have to be removed. At approximately 90 degrees to the nuts are two screws. Remove these with a stubby Phillips/Pozidrive screwdriver. This should now give enough give to lift the console and access the remaining two screws. If not then you have to remove the gearlever gator and surrounding trim. The screws and clips holding the console in place are obvious.

About a week later I was able to return the faulty equipment to the Dension agent and received a replacement a few days later. Having watched the technician the first time I felt confident in fitting it myself.

Iíve become a bit of an expert in stripping down an X3ís dashboard and can take one apart in about 5 minutes! The first thing to remove is the air vent assembly. This is done by prising the top away from the dash with your fingers. It comes out easily. To make life easier remove the hazard warning/doorlock switch and lay the unit down.

There are two screws holding the main facia plate. Remove these and ease the plate off. The easiest way to do this is to grip the bottom and prise if off with your fingers.

You know have access to the head unit. Remove the two screws that hold this in place and slide it out. Remove the Quadlock and aerial connector. In the UK Dension do not market the CD Changer cable and offer a Quadlock breakin/breakout cable. I think this is a mistake, but more on that later.

After putting the Quadlock breakin/breakout cable in place and reconnecting everything I went throught he instructions and found the head unit recongnised the ice>link instantly and began playing. Feeling extremely please with myself I put everything back together and finished the install. Getting everything in behind the head unit was a challenge but I managed it.

Later that evening I was dropping my wife off at a party and as neither of us had any ide where the house was we punched the address in to the SatNav. As I moved off I noticed that the volume on the iPOD was dipping occasionally. I wasnít sure what was causing it but then it hit me Ė Myrtle (out SatNav voice) wasnít speaking to us. I then tested the Bluetooth phone kit and that wasnít working either. I knew then it had to be related to the wiring of the kit.

This morning I stripped the dash again and looked for the problem. I could see that on the car side there was a connector but the Quadlock breakin/breakout cable did not extend this to the head unit end. It was easy to move the connector to the head unit end of the Quadlock breakin/breakout cable. I quickly reassembled the dash and turned the unit on. I noticed immediately that there was no sound from the front right speaker. I was kicking myself for not testing it before I reassembled the dash.So once again I disassembled the dash.

I found the problem to be related to the Quadlock breakin/breakout cable. It did not seem to be making a good connection on some pins. aAfter about 20 minutes of messing around I decided on a radical solution. I had figured out that the Quadlock breakin/breakout cable was not essential as it was possible with a bit of wire cutting and crimping connectors to achieve the same result with the existing harness. After about 20 minutes I had finished and after a through test (I wasnít going to make that mistake again!!) I put everything back together.

I am very pleased with the result. The sound quality is excellent and the install looks good.
Attached Thumbnails
Click image for larger version

Name:	DSC01788.JPG
Views:	194
Size:	104.4 KB
ID:	51796   Click image for larger version

Name:	DSC01789.JPG
Views:	171
Size:	61.6 KB
ID:	51797   Click image for larger version

Name:	DSC01790.JPG
Views:	242
Size:	124.8 KB
ID:	51798  

Last edited by Gaza; 06-11-2005 at 10:37 AM.
Reply With Quote
Ads by Google
  #2  
Old 06-11-2005, 12:38 PM
climrgrl climrgrl is offline
Officially Welcomed to the 'Fest
Location: SLO, CA
 
Join Date: Feb 2005
Posts: 114
Mein Auto: 2005 X3 3.0i
Thanks for the detailed post! I have the ice>link kit too, just haven't quite had a free weekend to install it yet.
__________________
2005 X3 3.0i, manual, mystic blue, matte titanium interior trim , gray leather (premium package), heated seats, chrome exhaust tips
Reply With Quote
  #3  
Old 06-17-2005, 11:35 AM
relsah relsah is offline
Registered User
Location: Philly
 
Join Date: Apr 2004
Posts: 14
Mein Auto: Ordered X3 2.5
Gaza,

Thanks for the detailed instructions, I like your install.

Can you take a picture behind the ipod holder? Iím just curios as to how you attached it to the X3.

TIA
Reply With Quote
  #4  
Old 06-19-2005, 09:39 AM
simoncpw simoncpw is offline
Psymon
Location: Singapore
 
Join Date: May 2005
Posts: 196
Mein Auto: X3
Thanks for posting the info. I'm planning to put in the ice Link as well (I don't have the Nav), and would like to know how you attach the iPod to the X3 too.
Reply With Quote
  #5  
Old 06-25-2005, 08:03 AM
climrgrl climrgrl is offline
Officially Welcomed to the 'Fest
Location: SLO, CA
 
Join Date: Feb 2005
Posts: 114
Mein Auto: 2005 X3 3.0i
I don't want to speak for Gaza, but I'm guessing that he used the ProClip USA angled mount that simply clips into the trim panels. No holes or screws needed. They're recommended by Dension, but the one for the X3 isn't on their site. It can be found here:
http://www.proclipusa.com/?sectionpa...d=&p_year=2005

The cradle with connector is supplied in the kit by Dension, the mount ordered separately through ProClip. The mount comes with a handy little plastic pry tool that I found very helpful for trim replacement as well. ProClip also sell a few more mounts for different placements.

Alternately, there are people on this forum that have installed the iPod in the glove box, or in the center console compartment. All are pretty slick, it's mostly a matter of personal preference. Maybe I'll finally get around to installing mine this weekend....
__________________
2005 X3 3.0i, manual, mystic blue, matte titanium interior trim , gray leather (premium package), heated seats, chrome exhaust tips
Reply With Quote
  #6  
Old 06-25-2005, 11:05 AM
simoncpw simoncpw is offline
Psymon
Location: Singapore
 
Join Date: May 2005
Posts: 196
Mein Auto: X3
Gaza,

Does the head unit displays the names of the song playing from the iPod?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strut Brace Install - Imp. Steps For Alee and Others! Ack Do-It-Yourself H.Q. 51 10-15-2006 07:13 AM
2004 X5 Bluetooth install questions FLY X5 X5 E53 (1999 - 2006) 11 03-14-2006 08:30 PM
Used E30 3.73 LS Diff Install for M Coupe--Pix + Notes yetiboy E36 /7 Z3 (1996-2002) 48 06-19-2004 07:32 PM
Doeboy's StealthOne and BMW BT install Kaz Car Navigation, Audio & Electronics sponsored by BimmerTech 6 06-07-2004 03:29 PM
I would like to install a tow hitch on my 330i Andy General BMW 8 01-14-2004 12:01 PM


All times are GMT -7. The time now is 07:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms