Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 09-05-2005, 03:52 AM
camperman999 camperman999 is offline
Registered User
Location: midlands, uk.
 
Join Date: Sep 2005
Posts: 1
Mein Auto: BMW 540i E34. '93.
relay problem? on e34 540i '93.

My 540i keeps coming up with "trans program" message on dash, then it won't start, after a short while it starts and drives fine, but will cut out without warning!! i've read a thread on here from somebody with the same problem, it mentions it could be a broken relay causing the problem!! does anybody know if this is an expensive repair???? or can i get away without selling the house and the dog??
__________________
Reply With Quote
Advertisement
  #2  
Old 09-28-2005, 03:36 AM
imnprsd imnprsd is offline
Registered User
Location: Los Angeles
 
Join Date: Jul 2005
Posts: 53
Mein Auto: 1992 525i Wagon
Do a search... much has been written the the transmission program light, but basically from my experience you should do cheap repairs before you do anything else:

1) Clean your gear selector switch
2) Change your fluid and filter... and don't over fill it.

More info can be found on this forum too:

http://www.automotiveforums.com/vbul...splay.php?f=89
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
This Is The Official Hijack Thread... Sabrina Off-Topic 146 05-21-2009 06:38 PM
t Nick T. The Test Board 5 07-05-2003 09:25 AM
jon...need help...big problem (m) bimmerboy Regional Forums 6 10-28-2002 06:17 PM
E34 electrical problem in_d_haus 5 Series 2 10-07-2002 07:38 PM
E34 or E36 Michael330 General BMW 44 08-25-2002 05:59 AM


All times are GMT -7. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms