Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-08-2006, 03:50 PM
gaw00 gaw00 is offline
Registered User
Location: New York
 
Join Date: Dec 2005
Posts: 17
Mein Auto: 530xi on order
Bluetooth problem with Blackberry 8700g (T-mobile)

I realized I posted this in the e90 thread, but I my issue is with an e60, so it's probably more appropriately posted here.

I have had similar intermittent problems with my BB 8700g. It has OS v. 4.1.0.284 It initially connected OK and the address book transfered over no problem. But about an hour later, everything started getting screwed up. The phone disconnected from the car Bluetooth and won't re-connect again. I tried rebooting the phone, deleting it from the car, rebooting idrive, etc. The bluetooth on/off switch in idrive would get stuck (won't turn off). When this happened, the phone didn't recognize the car's bluetooth device anymore.

After rebooting idrive, the phone worked again for a short period, then the same issues started again.

Not sure which idrive software version I have, but I have an 2006 e60 Jan / Feb build.

About a month ago, I had used an 8700c with the car for several days with no problems at all. It could be a device issue, but I suspect it's an idrive software problem. I think the software was upgraded by the VDC upon redelivery from Europe.

BMWNA says that the 8700g (T-Mobile) is not an approved device, so they can't really help, but the 8700c (Cingular) is an approved device (whatever that means - aren't they really the same device but on different mobile carriers?

Any help or thoughts on how to fix this would be greatly appreciated.

Thanks,

AG
Reply With Quote
Ads by Google
  #2  
Old 05-10-2006, 07:09 AM
dgdoc dgdoc is offline
Registered User
Location: MD
 
Join Date: Jun 2005
Posts: 88
Mein Auto: 2001 540i/6spd
We just upgraded our 2006 530xiT to CIP version 21.02.01 and now my Blackberry 8700c works reliably via Bluethooth and as an added bonus, so does my Samsung A-920. As you pointed out there may be a difference between the 8700g and 8700c, but I doubt the low-level Bluetooth stuff in the device would be any different.

Based on the date your car was built and the release dates of versions of the CIP, I'm guessing that you have CIP Version 20.

You might want to talk to your service advisor and request the upgrade to see if it will solve your problem.

Last edited by dgdoc; 05-10-2006 at 07:14 AM.
Reply With Quote
  #3  
Old 05-10-2006, 07:12 AM
TD TD is offline
Officially Welcomed to the 'Fest
Location: Not here
 
Join Date: Dec 2001
Posts: 1,480
Mein Auto: E90 330i 6-spd
Hmm... My 8700g works just fine in my E90.
Reply With Quote
  #4  
Old 05-10-2006, 08:35 AM
gaw00 gaw00 is offline
Registered User
Location: New York
 
Join Date: Dec 2005
Posts: 17
Mein Auto: 530xi on order
Quote:
Originally Posted by dgdoc
We just upgraded our 2006 530xiT to CIP version 21.02.01 and now my Blackberry 8700c works reliably via Bluethooth and as an added bonus, so does my Samsung A-920. As you pointed out there may be a difference between the 8700g and 8700c, but I doubt the low-level Bluetooth stuff in the device would be any different.

Based on the date your car was built and the release dates of versions of the CIP, I'm guessing that you have CIP Version 20.

You might want to talk to your service advisor and request the upgrade to see if it will solve your problem.

Thanks for the info. I will check with my dealer again. They were very unresponsive and unwilling to do anything without charging me for the service. They said they couldn't tell me what the software version without hooking the vehicle up to a computer and that would cost me $100 and if i insisited on doing a software upgrade that is not mandated by a BMW campaign then it would cost $200 - $400.

Has anyone experienced this? Is the dealer correct here? To me, it seems like there is a software defect and they won't fix it.

Thanks.
Reply With Quote
  #5  
Old 05-10-2006, 07:32 PM
dgdoc dgdoc is offline
Registered User
Location: MD
 
Join Date: Jun 2005
Posts: 88
Mein Auto: 2001 540i/6spd
Quote:
Originally Posted by gaw00
Thanks for the info. I will check with my dealer again. They were very unresponsive and unwilling to do anything without charging me for the service. They said they couldn't tell me what the software version without hooking the vehicle up to a computer and that would cost me $100 and if i insisited on doing a software upgrade that is not mandated by a BMW campaign then it would cost $200 - $400.

Has anyone experienced this? Is the dealer correct here? To me, it seems like there is a software defect and they won't fix it.

Thanks.
Of course. BMW should only have to fix things that are broken. If you go in there and start talking about CIP versions and stuff like that, they will probably be unresponsive. They can't be expected to just do upgrades for anyone who walks in the door and says they'd like an upgrade. There has to be justification.

Instead, tell them you have a specific problem and want it fixed -- and don't tell them how to fix it. At least this was my experience and as a result of taking this approach, they upgraded the CIP and everything works now.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blackberry 7290 (Cingular) + BlueTooth = Yes! msp_guy Car Navigation, Audio & Electronics sponsored by BimmerTech 3 10-25-2005 05:46 PM
Blackberry 7100t and Bluetooth - revisted USMCAg00 Car Navigation, Audio & Electronics sponsored by BimmerTech 1 09-22-2005 08:25 AM
Anyone having success with Blackberry and BMW Bluetooth? 3Puttr Car Navigation, Audio & Electronics sponsored by BimmerTech 5 09-22-2005 05:47 AM
Installed Bluetooth phone ....finally!(long) 03BMW330 Car Navigation, Audio & Electronics sponsored by BimmerTech 15 05-30-2003 10:26 AM


All times are GMT -7. The time now is 05:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms