Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-18-2002, 02:09 PM
gbrown gbrown is offline
M coupe
Location: SoCal
 
Join Date: Aug 2002
Posts: 132
Mein Auto: 2001 M Coupe
Scary S54 experience

Most of you know of my EML and SES light issues (the car is going in on Friday). Today I was accelerating on the 605N freeway and the DSC light came on as did my friend the EML light. Then the car bucked a bit and failed to respond to throttle input and started decelerating. I had to make an emergency stop to re-start the car and go on my way.

Needless to say no more driving it until BMW fixes it. Should I be reporting this potentially dangerous event to someone? Thank God my wife was not at the wheel.
Reply With Quote
Ads by Google
  #2  
Old 12-18-2002, 03:32 PM
scottn2retro's Avatar
scottn2retro scottn2retro is offline
into things retro
Location: Huntington Beach
 
Join Date: Mar 2002
Posts: 4,537
Mein Auto: '02 M3 SMG & '08 135i
I'm sure I missed it, but . . .

how many miles on the car?

Obviously a pain. Have you had them back out the Dinan software yet?
__________________
facebook.com/sctsracing
02 M3 SMG Coupe - prepared class BMW Club racer
08 135i 6sp - stock class BMW Club racer
Photo gallery
Reply With Quote
  #3  
Old 12-18-2002, 07:18 PM
gbrown gbrown is offline
M coupe
Location: SoCal
 
Join Date: Aug 2002
Posts: 132
Mein Auto: 2001 M Coupe
33k on it now, but someone else had the EML, SES lights on a stock M with 15k on it.
Reply With Quote
  #4  
Old 12-18-2002, 11:50 PM
DINANISR3 DINANISR3 is offline
Officially Welcomed to the 'Fest
Location: Huntington Beach, Ca
 
Join Date: Aug 2002
Posts: 513
Mein Auto: The Best of Both Worlds
which is the EML light.. a few times this happened to me.. i drive.. then all of a sudden the red battery looking light and the third light came on... not the middle one though.. the power steering seems to be completely dead.. and i have to stop.. and turn off the car and turn it back on.. then everythings fine... no lights, nothing.. this happened to me about 2 -3 times.. can u or anyone tell me what that is? should i take it in to the dealer?
Reply With Quote
  #5  
Old 12-19-2002, 04:51 AM
DannO's Avatar
DannO DannO is offline
Officially Welcomed to the 'Fest
Location: Orlando, FL
 
Join Date: Apr 2002
Posts: 636
Mein Auto: //M Coupes
The EML light is hard to miss. It's orange and looks like this:

EML



I'm the other guy with these lights. Well, one of them at least. '01 s54, stock engine and drivetrain, well cared for, 13.7k miles.

Dealer said the codes were being caused by a bad throttle potentiometer. There are two on the fuel rail - one on the front, one on the back. Apparently these provide feedback to the ECU of the throttle's actual position, closing the control circuit. My front pot wasn't reading the same as the back one, so clearly one of them was messed up. I assume they determined the front one was problematic because the rear one was correct? Something like that anyway...

My car has "bucked" as gbrown described when the lights were triggered, but I have never lost throttle response. Sounds wonderful.

You guys seen the rumor mill on .org's m3 board about BMW extending the warranty for these engines to 6yr 100k? If it's true I don't know if I should laugh or cry... I think I'll reserve judgement until 2007.

The part had to be ordered. Hopefully will be installed tomorrow or early next week. I'll post the results. Fingers crossed.

Last edited by DannO; 12-19-2002 at 04:54 AM.
Reply With Quote
  #6  
Old 12-19-2002, 09:04 AM
The HACK's Avatar
The HACK The HACK is offline
Rest in peace, Coach
Location: People's Republic of United States
 
Join Date: Dec 2001
Posts: 9,108
Mein Auto: '06 MZ4C, '09 WRX Wagon
Quote:
Originally posted by DannO
The EML light is hard to miss. It's orange and looks like this:

EML



I'm the other guy with these lights. Well, one of them at least. '01 s54, stock engine and drivetrain, well cared for, 13.7k miles.

Dealer said the codes were being caused by a bad throttle potentiometer. There are two on the fuel rail - one on the front, one on the back. Apparently these provide feedback to the ECU of the throttle's actual position, closing the control circuit. My front pot wasn't reading the same as the back one, so clearly one of them was messed up. I assume they determined the front one was problematic because the rear one was correct? Something like that anyway...

My car has "bucked" as gbrown described when the lights were triggered, but I have never lost throttle response. Sounds wonderful.

You guys seen the rumor mill on .org's m3 board about BMW extending the warranty for these engines to 6yr 100k? If it's true I don't know if I should laugh or cry... I think I'll reserve judgement until 2007.

The part had to be ordered. Hopefully will be installed tomorrow or early next week. I'll post the results. Fingers crossed.
Very common problem on electronic throttles I guess...There's another S54 that I know has had this problem, along with NUMEROUS M54 engines.
__________________
Quote:
"Bench racing" about track times driven by professionals are like a bunch of nerds arguing which Princess Leia is hotter, the slave Leia or the no-bra jail-bait Leia. No matter how compelling your argument is, the plain and simple fact is, none of you will EVER get to hit that.
Reply With Quote
  #7  
Old 12-20-2002, 08:42 AM
gbrown gbrown is offline
M coupe
Location: SoCal
 
Join Date: Aug 2002
Posts: 132
Mein Auto: 2001 M Coupe
Warranty extension or not, BMW is going to get my M Coupe handed back to them at the end of my lease.

There is also a very good chance I wont be buying another S54 powered BMW too. It's a shame, the M Coupe is an awesome machine.
Reply With Quote
  #8  
Old 12-20-2002, 06:52 PM
bmargolis's Avatar
bmargolis bmargolis is offline
Officially Welcomed to the 'Fest
Location: Simsbury, CT
 
Join Date: Apr 2002
Posts: 161
Mein Auto: 2009 E92 M3 - MDCT
similar problem

I just had my S54 in for service because of the EML light and the SES light. I had not driven the car for a few weeks and took it out last weekend for a 15 minute ride. Ten minutes in, the EML light came on and after gassing up the SES light came on.

I also have Dinan software installed.

The lights were on and off for a couple of days this week and I took it to the dealer yesterday. The lights were not on at all yesterday and the dealer found NOTHING.

They told me that if it happened again, I should bring it right in with the light on. (Of course, that's what I wanted to do on Monday, when the pricks told me they could not see the car until Thursday)

Let me know how you make out and I'll do the same.

Bob Margolis
__________________
Bob ///Margolis

2009 E92 M3 / Alpine White / Black Leather / Carbon Leather / M-DCT / 19's / Technology / Premium / Cold Weather / iPod / Smartphone / PDC / Sirius XM
Reply With Quote
  #9  
Old 12-20-2002, 07:08 PM
JST's Avatar
JST JST is offline
A sudden sense of liberty
Location: U of ///M
 
Join Date: Dec 2001
Posts: 3,936
Mein Auto: 535xiT, Golf R, 987S
Quote:
Originally posted by gbrown
Warranty extension or not, BMW is going to get my M Coupe handed back to them at the end of my lease.

There is also a very good chance I wont be buying another S54 powered BMW too. It's a shame, the M Coupe is an awesome machine.
I believe that, in true weaselly lawyer fashion, the extension applies only to "lubricated" parts of the engine, meaning that throttles wouldn't be covered under the extended warranty.
Reply With Quote
  #10  
Old 12-27-2002, 09:58 PM
gbrown gbrown is offline
M coupe
Location: SoCal
 
Join Date: Aug 2002
Posts: 132
Mein Auto: 2001 M Coupe
Shes back....20 miles so far and no EML lights.

What was replaced this 3rd..or is it 4th time around?

13-63-1-402-143 Switch
12-72-7-831-529 Throttle Actuator

Also noted: replaced potentiometers (this I have seen before).

And in typical Long Beach BMW fashion..driving around I think shes much louder than before....pop the hatch and the rear battery cover / tool cover is off as is the plastic cover covering the battery itself is off..one bolt missing. Lovely. Can't wait until customer service calls me on this one.

PS dinan software still installed and from the feedback I have received is not a potential cause of the EML / SES light issues.
Reply With Quote
  #11  
Old 12-28-2002, 06:37 PM
DannO's Avatar
DannO DannO is offline
Officially Welcomed to the 'Fest
Location: Orlando, FL
 
Join Date: Apr 2002
Posts: 636
Mein Auto: //M Coupes
Took mine in to have the front throttle position sensor replaced today. No more EMLs, no more SES. We went on a "spirited drive" west of Orlando today - clocked 110 or so miles and nary a stutter. Got to clear her throat pretty good too... nice.

Glad to hear things are looking good for you as well, gbrown.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms