Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-20-2007, 11:42 AM
jeffx5 jeffx5 is offline
Registered User
Location: los angeles
 
Join Date: May 2007
Posts: 19
Mein Auto: x5 4.8
2007 x5 4.8i problems

Hi Everyone,
I have a 2007 X5 4.8i with sports package. My car has 1400 miles. I have had the following problems> I am wondering if anyone has had the same. My car has been in the shop two times, totalling 22 days so far.
1. Thumping noise from front end when going over bumps or agressively steering. Dealer first tightened bolts, next replaced anti swway bar links ,and alstly repalced anti sway bar. Problem still occuring.
2. Since sway bar was replaced, car makes grinding noise when steering at speeds past 25mph.
3. Radio would cut out . Dealer send ccc unit back to factory for reprogramming. Came back fixed except Traffic report was not working. Dealer fixed traffic report through software.
4. Grease oozing out of back deck on to bumper. Dealer replaced seal. Dealer says problem corrected, and they will replaqce bumper because they can not clean it.
Just wondering if anyone has same circumstances.
I really like driving the car...but I need it fixed !
Reply With Quote
Advertisement
  #2  
Old 05-21-2007, 12:16 PM
emcman emcman is offline
Officially Welcomed to the 'Fest
Location: Oregon
 
Join Date: Feb 2006
Posts: 177
Mein Auto: 2015 S7
I have a non sport 07 4.8 and have none of those issues. Just a jerky transmission at times.
Reply With Quote
  #3  
Old 05-21-2007, 12:39 PM
Diver624 Diver624 is offline
Diver624
Location: Long Island, New York
 
Join Date: Jan 2007
Posts: 400
Mein Auto: Porsche 911 Turbo
Quote:
Originally Posted by jeffx5 View Post
Hi Everyone,
I have a 2007 X5 4.8i with sports package. My car has 1400 miles. I have had the following problems> I am wondering if anyone has had the same. My car has been in the shop two times, totalling 22 days so far.
1. Thumping noise from front end when going over bumps or agressively steering. Dealer first tightened bolts, next replaced anti swway bar links ,and alstly repalced anti sway bar. Problem still occuring.
2. Since sway bar was replaced, car makes grinding noise when steering at speeds past 25mph.
3. Radio would cut out . Dealer send ccc unit back to factory for reprogramming. Came back fixed except Traffic report was not working. Dealer fixed traffic report through software.
4. Grease oozing out of back deck on to bumper. Dealer replaced seal. Dealer says problem corrected, and they will replaqce bumper because they can not clean it.
Just wondering if anyone has same circumstances.
I really like driving the car...but I need it fixed !
Don't have the suspension or audio issues you described.
It sounds like they botched the suspension fix, the suspension design on the Sport package is new so not many mechanics are familiar with it.
If the "grease" is off white in color then it's a waxy product that is used to line the inside of door and tailgate panels that melts when the weather is warm and then leaks out of the drain holes at the bottom of the panels. The drain holes are covered by rubber plugs that are easy to remove. I had the same problem from the tailgate, windex and a rag took care of the drips on the bumper. I pulled off the plugs and cleaned out as much as I could with Q Tips and haven't had the problem since. If your problem is the wax material there is no need to replace the bumper. Why they use this material is beyond me.
__________________
2014 550ix Mineral White, Black
2013 X5 35i
Porsche 997 GT3
Porsche 993 Cab.
Porsche 996 Turbo (Ruf 550) gone but not forgotten
.
Reply With Quote
  #4  
Old 05-21-2007, 02:52 PM
jeffx5 jeffx5 is offline
Registered User
Location: los angeles
 
Join Date: May 2007
Posts: 19
Mein Auto: x5 4.8
thanks diver624

Thanks Diver,
I returned the car to the dealer today to fix suspension problem. I showed them all the places where the protectant was leaking on the side of the car too. They said that they will take care of everything... I will take seals off and clean with q tip when I get truck back. Thanks for your input.
Jeff
Reply With Quote
  #5  
Old 05-21-2007, 08:20 PM
packfan81 packfan81 is offline
Registered User
Location: North Carolina
 
Join Date: Mar 2007
Posts: 6
Mein Auto: 2007 X5 4.8L
Check the shield over the drive shaft. Mine was misaligned and caused a bumping noise when the chassis was stressed, such as in a turn. Came from the factory this way.
Reply With Quote
  #6  
Old 05-21-2007, 08:56 PM
jeffx5 jeffx5 is offline
Registered User
Location: los angeles
 
Join Date: May 2007
Posts: 19
Mein Auto: x5 4.8
packfan

thanks Packfan,
The dealer returned the car to my office today...such service. They said that one of the shields under car was bent...which caused the grinding noise. I am not sure which shield it was, because the porter did not bring any paperwork. I am still not sold on the thumping form under the car being completely gone. They want to replace my back bumper to because they can not restore the finish that the protectant destroyed. The bumpers come unfinished and they have to send them out to be painted. I am not sure if I like this idea. Anyways the shield will probably end up being the one that you had trouble with too.
Reply With Quote
  #7  
Old 05-22-2007, 04:01 AM
XZLR8's Avatar
XZLR8 XZLR8 is offline
Officially Welcomed to the 'Fest
Location: Ohio
 
Join Date: Sep 2002
Posts: 2,270
Mein Auto: X6M
Thankfully, (knock on wood) I've not had any problems...
__________________

2014 BMW X6 ///M | SpaceGray/BlackPerforatedFullMerino/CarbonLeather
2014 BMW 328xi Touring M-Sport | GlacierSilver/BlackDakota/DarkBurlWalnut
2014 BMW X6 35i M-Perf | TitaniumSilver/BlackNappa/DarkBamboo [wife's ride]

BMW HISTORY | '13 650xiGC, '12 650xi, '11 535xi, '11 X6 50i, '09 750i, '09 328xiT, '08 650i, '07 750i, '07 X5 4.8i, '06 650i, '05 745i, '05 325xiT, '03 745i, '02 745i, '01 325Cic, '01 X5 4.4i, and on...
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms