Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools
  #651  
Old 12-07-2008, 06:06 AM
dtanner dtanner is offline
Registered User
Location: Big Canoe, Georgia
 
Join Date: Dec 2008
Posts: 15
Mein Auto: BMW X3
Quote:
Originally Posted by dtanner View Post
My 3 month old 2008 X3 has been having problems where on accelerating from a stop sign, slowing for a curve and then accelerating or slowing at a yield sign and pulling into traffic - the car has felt like it went into neutral then jumped into gear - It also changes gears on inclines and then accelerates so fast upon changing gears that it almost jumps out from under me. The dealer "reloaded the GM software" last week but it is still not changing gears correctly. Any advice
Reply With Quote
  #652  
Old 12-07-2008, 07:47 AM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,098
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
welcome to the club!!
document everything, every single times its and issue. ask them to do the software update AGAIN (remember, it's TWO different updates they have to make) and then if it doesn't work... ask for a buy back or trade assist into a manual version.

Quote:
Originally Posted by dtanner View Post
My 3 month old 2008 X3 has been having problems where on accelerating from a stop sign, slowing for a curve and then accelerating or slowing at a yield sign and pulling into traffic - the car has felt like it went into neutral then jumped into gear - It also changes gears on inclines and then accelerates so fast upon changing gears that it almost jumps out from under me. The dealer "reloaded the GM software" last week at the dealer but it is still not changing gears correctly. Any advice
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle
Reply With Quote
  #653  
Old 12-07-2008, 08:34 AM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,574
Mein Auto: 2007 Z4+X3, 2006 530Xi
Quote:
Originally Posted by dtanner View Post
My 3 month old 2008 X3 has been having problems where on accelerating from a stop sign, slowing for a curve and then accelerating or slowing at a yield sign and pulling into traffic - the car has felt like it went into neutral then jumped into gear - It also changes gears on inclines and then accelerates so fast upon changing gears that it almost jumps out from under me. The dealer "reloaded the GM software" last week at the dealer but it is still not changing gears correctly. Any advice
I can understand companies having issues with the first year of release, but by 2008 the trans issues should have been resolved.

What version software was loaded? I posted my version earlier. Do you have the same? You need the trans and ECU software upgrades.
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
  #654  
Old 12-07-2008, 11:17 AM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,098
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
don't forget they CHANGED the transmission in 07. so it is NEW, even though the X3 is old.

Quote:
Originally Posted by madurodave View Post
I can understand companies having issues with the first year of release, but by 2008 the trans issues should have been resolved.

What version software was loaded? I posted my version earlier. Do you have the same? You need the trans and ECU software upgrades.
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle
Reply With Quote
  #655  
Old 12-07-2008, 11:45 AM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
Quote:
Originally Posted by madurodave View Post
I can understand companies having issues with the first year of release, but by 2008 the trans issues should have been resolved.

What version software was loaded? I posted my version earlier. Do you have the same? You need the trans and ECU software upgrades.
I have come to the conclusion that this issue will NEVER be resolved. These reprograms get an almost satisfactory result. Sometimes the benefits decrease over time, and the trans reverts. My lease will be up in 5/10 and until then I will continue to keep my ears open on the X3. These trans problems are in addition to the outdated electronics. If you are happy with your X3, that's great. I have mixed feelings, and feel like I am settling on some issues.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #656  
Old 12-07-2008, 06:43 PM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,574
Mein Auto: 2007 Z4+X3, 2006 530Xi
Quote:
Originally Posted by kjboyd View Post
don't forget they CHANGED the transmission in 07. so it is NEW, even though the X3 is old.
That's what I said!
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
  #657  
Old 12-07-2008, 07:47 PM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,098
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
well, the first year of release was MY2004. and considering all the other issues they are still having and it's been 5 years... why should you think they only need 1 year to work out the transmission?
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle

Last edited by kjboyd; 12-07-2008 at 09:33 PM.
Reply With Quote
  #658  
Old 12-07-2008, 09:32 PM
hunterz4's Avatar
hunterz4 hunterz4 is offline
Officially Welcomed to the 'Fest
Location: SF Bay Area
 
Join Date: Nov 2005
Posts: 367
Mein Auto: 2007 X5, 2006 530i
I havent been around in a number of months but over the weekend I have seen at least 1/2 dozen X3s and missed driving it around town. But not the transmission. Sorry to see it still hasn't been fixed.
__________________
Now:
2006 530i Amythest Grey, MT, Sport, comfort seats & access.
2006 330cic, E46 Rag top, Titanium/Black, Auto, Sport, Premium.

Then:
'07 X5 3.0 Alpine, Tobacco, Dark Burl, Sport, Tech, Premium, Rear climate, 3d row seat, ipod & running boards.
'07 X3, Silver Gray, Gray, Gray Poplar, Auto (gone and forgotten)
'03 Z4, 2.5, M. Blue, Black, MT, Sport, Premium. (RIP)
'95 325i, E36, Blk, Blk, auto, premium
'89 325i, E30, 1st one, Platinum Bronze, Black leatherette, MT.
Reply With Quote
  #659  
Old 12-09-2008, 09:23 AM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,574
Mein Auto: 2007 Z4+X3, 2006 530Xi
Quote:
Originally Posted by kjboyd View Post
well, the first year of release was MY2004. and considering all the other issues they are still having and it's been 5 years... why should you think they only need 1 year to work out the transmission?
I had a similar issue on my 2007 Harley. New engine (110 Cu in), new trans (6 speed Cruise Drive). HD had issues with engine heat and transmission complaints. Fixes were implemented and were effective when the 2008's came out.

If a company wants to keep their customer base happy and establish a larger and newer customer base, and issues should be resolved within 1 model year.

Also, I thought the 5 speed was "perfect"?
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
  #660  
Old 12-18-2008, 05:41 PM
ramjet-austin ramjet-austin is offline
Registered User
Location: Austin, Texas
 
Join Date: Nov 2008
Posts: 6
Mein Auto: X3
I bought an '07 X3 with 9K miles from Carmaxx a couple of months ago (got a great deal). And love it! But subsequently noticed the weird feeling transmission. Still under warranty, I took it to BMW of Austin, which promptly and courteously downloaded the "patch." And so far, it has worked beautifully. But I'm confused about the 2 patches mentioned throughout this thread. Would anyone explain the two and what specifically they accomplish. And what generally would one see on the summary of services performed? Mine read that they reprogrammed the "DME" and "EGS." Thanks from the Texas Hill Country...
Reply With Quote
  #661  
Old 12-18-2008, 06:03 PM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,098
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
Quote:
Originally Posted by ramjet-austin View Post
I bought an '07 X3 with 9K miles from Carmaxx a couple of months ago (got a great deal). And love it! But subsequently noticed the weird feeling transmission. Still under warranty, I took it to BMW of Austin, which promptly and courteously downloaded the "patch." And so far, it has worked beautifully. But I'm confused about the 2 patches mentioned throughout this thread. Would anyone explain the two and what specifically they accomplish. And what generally would one see on the summary of services performed? Mine read that they reprogrammed the "DME" and "EGS." Thanks from the Texas Hill Country...
those would be "the two"
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle
Reply With Quote
  #662  
Old 12-23-2008, 03:46 AM
Diane Diane is offline
Registered User
Location: Vermont
 
Join Date: Dec 2008
Posts: 1
Mein Auto: subaru
Help!!!

I am thinking of purchasing a X3 2007 with 10K on it. Lease turn in. It is certified preowned and has no transmission issues that I can tell. During CPO maintenance they did do some programming on the gear box. Below is what service did

Display of electronic gearbox module in instrument cluster/fault display, automatic transmission not
C/S TRANSMISSION FAIL SAFE WARNING LIGHT TURNS ON SHORT TESTED VEHICLE, UPDATED EGS SOFTWARE PER SIB 24-07-07

Any thoughts on this issue should I buy??



Reply With Quote
  #663  
Old 12-23-2008, 06:46 AM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,098
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
i'd skip it.
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle
Reply With Quote
  #664  
Old 12-30-2008, 10:15 AM
nycdriver nycdriver is offline
Registered User
Location: New York
 
Join Date: Dec 2008
Posts: 2
Mein Auto: X3
I'm thinking about a 2007 CPO X3. Anything I should ask the dealer about to see if the problem has been resolved before purchasing (in addition to test driving it)? I would assume if it was a CPO they would have checked for the transmission isuse. Thoughts?
Reply With Quote
  #665  
Old 12-30-2008, 10:39 AM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,098
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
Quote:
Originally Posted by nycdriver View Post
I'm thinking about a 2007 CPO X3. Anything I should ask the dealer about to see if the problem has been resolved before purchasing (in addition to test driving it)? I would assume if it was a CPO they would have checked for the transmission isuse. Thoughts?
there is NO cure for this problem... only temporary reprieve from what we keep hearing.
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle
Reply With Quote
  #666  
Old 12-30-2008, 11:25 AM
x3ml x3ml is offline
Officially Welcomed to the 'Fest
Location: Ontario
 
Join Date: Jan 2007
Posts: 177
Mein Auto: X3 2007 3.0si AT
Quote:
Originally Posted by nycdriver View Post
I'm thinking about a 2007 CPO X3. Anything I should ask the dealer about to see if the problem has been resolved before purchasing (in addition to test driving it)? I would assume if it was a CPO they would have checked for the transmission isuse. Thoughts?
No exaggeration here: I have never driven anything so unrefined, so rough in my life and BMW continues to say it's operating within designed specifications... while continues to give transmission updates. They have now refused to even test drive the vehicle again. And my X3 is still less than 1/2 way through the new car warranty. So good luck with your CPO warranty.

Some days, I can swear my X3 drives better but the problems always return with a vengeance for unknown reasons.
Reply With Quote
  #667  
Old 12-30-2008, 11:46 AM
MJS MJS is offline
HMFIC
Location: Cleveland, OH
 
Join Date: Dec 2001
Posts: 439
Mein Auto: 2002 ///M3
Quote:
Originally Posted by nycdriver View Post
I'm thinking about a 2007 CPO X3. Anything I should ask the dealer about to see if the problem has been resolved before purchasing (in addition to test driving it)? I would assume if it was a CPO they would have checked for the transmission isuse. Thoughts?
Run.....
__________________
46 & 2 just ahead of me...

Reply With Quote
  #668  
Old 12-30-2008, 05:31 PM
Evlengr's Avatar
Evlengr Evlengr is offline
Ukemi - that's how I roll
Location: MD
 
Join Date: Feb 2007
Posts: 4,252
Mein Auto: 2013 Audi S4 2010 MT MCS
This problem has never been formally acknowledged nor fixed.

It is a crap shoot at this point and for several thousand dollars and my life I wouldn't gamble on one.

Did I mention I love my 08 MT.
__________________
2013 S4 Loaded (and NO RFT's) Awesome is an understatement
2008 MT X3 RIP you were a faithful sidekick and will be missed.
2007 AT X3 RIPOS
2005 GC
2000 Jeep Cherokee
1997 Twin Turbo RX-7
1984 GTI Wolfsburg Edition Neuspeed and more
Reply With Quote
  #669  
Old 12-30-2008, 06:58 PM
Zoltar's Avatar
Zoltar Zoltar is offline
Your Wish Is Granted
Location: PA
 
Join Date: May 2007
Posts: 236
Mein Auto: 2009 X3 MT
It is quite obvious at this point that this problem will never truly be fixed.
Buy a manual or look elsewhere.
And if you do, be prepared for the hit in your resale value for being the odd man out buying a manual X3.
Reply With Quote
  #670  
Old 01-04-2009, 03:50 PM
Martlet66 Martlet66 is offline
Registered User
Location: Earth
 
Join Date: Nov 2007
Posts: 13
Mein Auto: X3 (of course)
Thumbs up It's an Xmas miracle!

I sent my 2007 X-3 automatic in for an oil change and mentioned to the tech that it was holding gears longer than it should while accelerating, and he said "oh yeah, there's a software update for that". They has the car for a day, flashed the new tranny update, then the ecm also asked for an update, so they flashed that as well. End result...

Voila! The transmission, while not perfect, is far, far better. It's like driving a new car. I'm happy now.
Reply With Quote
  #671  
Old 01-04-2009, 07:58 PM
MJS MJS is offline
HMFIC
Location: Cleveland, OH
 
Join Date: Dec 2001
Posts: 439
Mein Auto: 2002 ///M3
Give it a month. It'll re-learn and you'll hate it again....

My lease is over in 1 month and I'm glad.
__________________
46 & 2 just ahead of me...

Reply With Quote
  #672  
Old 01-06-2009, 08:57 AM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,574
Mein Auto: 2007 Z4+X3, 2006 530Xi
Quote:
Originally Posted by MJS View Post
Give it a month. It'll re-learn and you'll hate it again....

My lease is over in 1 month and I'm glad.
Well, I guess my X3 is stupid! It still has not "re-learned" the bad shift point!

So far, it is still running great after the reprogram. MPG has dropped from 24 to 21 in mixed driving. It accelerates like a bat out of hell!

The only remianing issue is still a slight hesitation going on to the highway!

very happy still!
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
  #673  
Old 01-06-2009, 07:43 PM
ramjet-austin ramjet-austin is offline
Registered User
Location: Austin, Texas
 
Join Date: Nov 2008
Posts: 6
Mein Auto: X3
Add an amen from the choir. My software "patch" is still working beautifully. I love this car...!
Reply With Quote
  #674  
Old 01-07-2009, 02:41 AM
Snow-man Snow-man is offline
Registered User
Location: Up State New York
 
Join Date: Feb 2008
Posts: 63
Mein Auto: 330Xi, Acura RDX, 968
Woohoo

Wow--not bad only several thousand complaints, numerous postings with the safety commission, BBB, and other web sites, and now they finally may have gotten a life threatening ailment fixed. Good Job
Reply With Quote
  #675  
Old 01-10-2009, 11:54 AM
700kq 700kq is offline
Registered User
Location: Western NC
 
Join Date: Feb 2008
Posts: 9
Mein Auto: 07 X3
Does anyone have a Service Bulletin Number for latest fix.

Mine is at dealer now and they said they could not reproduce this problem with not wanting to upshift. They are trying to fix my radio. When I turn on the rear defroster the radio is all static. They called me to say they had wait for BMW to approve the radio change,

Would be good to call them Monday and give them the SB#.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms