Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-18-2009, 02:56 PM
Phoenix330Ci Phoenix330Ci is offline
Registered User
Location: Phoenix
 
Join Date: Feb 2009
Posts: 5
Mein Auto: 330Ci
2883 Mixture Preparation Bank 2 Error

Hi all new here. I own a 2004 330Ci and I have a 2883 error code, yes I did do a search here and did find some topics of relevance but most had to do with getting errors on both banks or additional codes which I don't have (yet). However a lot of useful information none the less.

Any way I'm only getting the one code and need to know what to look at or what to replace without doing a bunch of part swapping. I checked the intake frome the MAF to the intake manifold and didn't see and cracks. From what I can tell I don't see any leaks around the head and intake.

Been getting a 2883 Mixture Preparation Bank 2 error for about the last 8000 miles. Have this error now three times in that time period. First time I even seen an SES error on this car was around the same time for what the dealer told me was a loose gas cap. Dealer double checked the cap and cleared the code. A week or so later the ses light came on again, I tought it must be the cap. So I ordered the Peake Research reset tool because I was going to change the oil anyway. Read the code and got a 2883 Mixture Preparation Bank 2 error. Great no real discription as to a specific component. Did my oil change, change the air filter to a pre-oiled K&N and cleared the code. All was fine for a few weeks until I got the same code. Did some more research, cleared the code (did nothing except poke around in the engine compartment looking for something obvious). Well the code came on for the third time this morning. Obviously there is something wrong.

From what I have been reading it could be a whole bunch of things, the MAF, the O2 Sensor on Bank 2, leaking injectors in 4,5,6, vacuum leak.....any way I can narrow this done without spending a ton of money on this?

Here are some observations:

1. May/may not have anything to do with this, however, the steering wheel has some play in it about 1/4 to 1/2 inch in each direction. I was reading some where that this error fault can maybe caused by a DME (or something) because the steering sensor maybe off??? I'm almost thinking this problem may be because of a loose/worn bolt in the column which need to be replaced with a new one - read this in the shop manual. However I throw this here incase this is triggering the problem.

2. The car does have a rough idle on start up some of the time. Usually first thing in the morning lasting about twenty minutes tops. Some mornings it has it others not as noticeable. However, the only time the SES light came on during a rough idle was for the gas cap. 2 times when I got code 2883 was within 5 - 10 minutes after start up and not when the car was running rough. The other time was on the highway, about 20 minutes after start up, with no noticable trigger. Looked down the light was on.

3. RPMs at idle in park is roughly 600 according to the cars guage, RPM with car in drive and stopped is 500 - 550.

4. Fuel pump has been changed in this car about a year ago by the dealer. I was complaining that there would be an extreme rough idle, immediately after taking the car through a car wash or within the first few minutes of a rain storm and everything getting wet. Car would rough idle for about 5 minutes, no SES or code thrown. Dealer replaced Fuel pump and problem went away. So I'm going to rule out Fuel pump.

5. I'm also thinking about ruling out MAF because it looked clean to me and figure I would have a problem on both banks and not just one bank???

Engine wise, everythiong is stock or original as far as I can tell.

If I need to give more information, please let me know.
Reply With Quote
Ads by Google
  #2  
Old 02-18-2009, 06:35 PM
Phoenix330Ci Phoenix330Ci is offline
Registered User
Location: Phoenix
 
Join Date: Feb 2009
Posts: 5
Mein Auto: 330Ci
UPDATE: I cleared the codes tonight and yes I now have both the 2882 and 2883 code, meaning Mixture Preparation Bank 1 and Bank 2.

Where do I go now? Try cleaning the MAF first?
Reply With Quote
  #3  
Old 02-18-2009, 06:52 PM
Solidjake's Avatar
Solidjake Solidjake is offline
The one and only
Location: NYC
 
Join Date: May 2007
Posts: 17,672
Mein Auto: 2002 330i
Yea clean the maf. Did you change your fuel filter?
Reply With Quote
  #4  
Old 02-19-2009, 03:38 AM
Nov99328i's Avatar
Nov99328i Nov99328i is offline
(o0\(III)(III)/0o)
Location: Back in the great state of TEXAS!
 
Join Date: Jul 2006
Posts: 516
Mein Auto: 99 E46 328i
Do you have an aftermarket cold air intake?
__________________

ADR gunmetal 18's, Clears up front & sides, DVD system mounted in headrests + 1 up front, Dinan CAI + software
Mirror tint all around, M-TECH II front bumper, Front and rear Foglights




For my yoke is easy, and my burden is light. Matthew 11:30
Reply With Quote
  #5  
Old 02-19-2009, 06:32 AM
Phoenix330Ci Phoenix330Ci is offline
Registered User
Location: Phoenix
 
Join Date: Feb 2009
Posts: 5
Mein Auto: 330Ci
Yeah, I'll get a can of MAF cleaner tonight. I priced the fuel filter last night, $50 so I'll need to pick up one of those too.

No I don't have a CAI. I replaced the stock drop in filter with a K&N pre-oiled drop in filter. The filter box is stock. I got the first 2883 code and checked the filter first which was pretty dirty so I went to several parts stores in the area and didn't like the filters they had on hand so I went with a K&N. Have a K&N CAI in my truck and no problems. still got a 2883 after the filter change about a few thousand after the change,
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms