Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-04-2009, 08:37 PM
speedemn speedemn is offline
Officially Welcomed to the 'Fest
Location: Ontario, Canada
 
Join Date: Nov 2004
Posts: 157
Mein Auto: 2003 540i 6-spd
MID backlight problem???

I have a 2003 540i ... it has the 20-character display for the CCD.

A couple of days ago I noticed that the right half of the CCD went dim as if there is a backlight that has a dead bulb. The pixels themselves are lit up and legible but the right half of the CCD looks like it is missing a back light (if one exists) and the left half of the CCD looks normal.

I snapped a couple of pics with my cell phone camera in the daytime to illustrate. Hope the pics aren't too crappy and are able to convey what I am trying to describe. One pic was taken in the day time and the other at night on my way home.

Does the MID have backlighting? Are they bulbs that can be easily replaced? From the looks of it, it looks like 2 bulbs for the 20-character display unit. Does anyone here know for sure what the problem might be?
Attached Thumbnails
Click image for larger version

Name:	img032.jpg
Views:	219
Size:	47.8 KB
ID:	176643   Click image for larger version

Name:	img033.jpg
Views:	228
Size:	49.7 KB
ID:	176644  
__________________
2003 540i/6 black sapphire on black
BBS RG-R, CDV, Dinan Exhaust, Dinan RSB, Dinan RSTB, Dinan SSK, Dinan FSTB, Dinan CAI, Dinan TB, Dinan MAF, Dinan stage 4 software
BMW 13th gen ULF Bluetooth, BMW Sirius, Dice Silverline iPod
Dynocom numbers: 320HP, 420LB.FT TQ (crank)

Last edited by speedemn; 03-05-2009 at 02:14 PM.
Reply With Quote
Advertisement
  #2  
Old 03-05-2009, 11:06 AM
jfmjr442 jfmjr442 is offline
Registered User
Location: Maryland
 
Join Date: Jun 2007
Posts: 47
Mein Auto: 1997 328 ic
yes the bulbs can be replaced. Requires removal of the cluster - which is easy. Best to replace all when you are there. I believe there are 2 - search cluster removal or dash trim rings for DIY on cluster removal. Then take the bulbs to your local dealer for replacements.

John
Reply With Quote
  #3  
Old 03-05-2009, 11:30 AM
speedemn speedemn is offline
Officially Welcomed to the 'Fest
Location: Ontario, Canada
 
Join Date: Nov 2004
Posts: 157
Mein Auto: 2003 540i 6-spd
Looks like 5 bulbs... ?

http://www.realoem.com/bmw/showparts...09&hg=62&fg=05

02 BULB 12V 1,5W 5 62111391260 $2.68
__________________
2003 540i/6 black sapphire on black
BBS RG-R, CDV, Dinan Exhaust, Dinan RSB, Dinan RSTB, Dinan SSK, Dinan FSTB, Dinan CAI, Dinan TB, Dinan MAF, Dinan stage 4 software
BMW 13th gen ULF Bluetooth, BMW Sirius, Dice Silverline iPod
Dynocom numbers: 320HP, 420LB.FT TQ (crank)
Reply With Quote
  #4  
Old 03-05-2009, 12:09 PM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 6,175
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by speedemn View Post
I have a 2003 540i ... it has the 20-character display for the MID.
Ditto what jfmjr442 said...check for burnt out bulbs.

Just for clarification...that display on your instrument cluster is NOT the MID...it's affectionately referred to as the CCD (Check Control Display) since it is the display designed specifically for the Priority 1 and 2 warnings....and that's why any other info that appears in this display gets removed IMMEDIATELY if the Check Control System requires to communicate with you.

The MID is the multi-informational display (used for cars without NAVIGATION) that is used to access the AUDIO/OBC/CLOCK/PHONE functions.
(this is what the MID is...although this is the MID from the e38...you get the gist )
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 03-05-2009 at 12:12 PM.
Reply With Quote
  #5  
Old 03-05-2009, 02:14 PM
speedemn speedemn is offline
Officially Welcomed to the 'Fest
Location: Ontario, Canada
 
Join Date: Nov 2004
Posts: 157
Mein Auto: 2003 540i 6-spd
Oops! My mistake... thanks for clarifying.
__________________
2003 540i/6 black sapphire on black
BBS RG-R, CDV, Dinan Exhaust, Dinan RSB, Dinan RSTB, Dinan SSK, Dinan FSTB, Dinan CAI, Dinan TB, Dinan MAF, Dinan stage 4 software
BMW 13th gen ULF Bluetooth, BMW Sirius, Dice Silverline iPod
Dynocom numbers: 320HP, 420LB.FT TQ (crank)
Reply With Quote
  #6  
Old 03-05-2009, 08:58 PM
x2nervisx x2nervisx is offline
BMW's are cool
Location: Deer Park, NY
 
Join Date: Feb 2005
Posts: 61
Mein Auto: 1995 M3 & 2000 540i
I have the same problem except mind is actually in the MID not in the cluster. Do those take replaceable bulbs as well or is the MID non serviceable?
Reply With Quote
  #7  
Old 03-06-2009, 01:36 PM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 6,175
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by x2nervisx View Post
I have the same problem except mind is actually in the MID not in the cluster. Do those take replaceable bulbs as well or is the MID non serviceable?
Are you sure the issue is burnt out back lighting...or is it pixel degradation?

There's a difference...and the MID does NOT have replacable incandescent bulbs like the instrument cluster. If there are any incandescent bulbs in the MID...they are soldered in. You would have to open it up and desolder the old and replace with new (if back-lighting is the issue).

If the problem is missing pixels (pixel degradation)...it will look like the image below...and if that's the case...either a replacement MID is in order or you can try the OFT TRIED write-up...look for it in the DIY or FAQ threads...or look for a write up on www.bmwtips.com or www.e38.org/e39 :


(image below is from this website: http://www.northernautotech.co.uk/pixels.html )

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #8  
Old 03-06-2009, 07:17 PM
x2nervisx x2nervisx is offline
BMW's are cool
Location: Deer Park, NY
 
Join Date: Feb 2005
Posts: 61
Mein Auto: 1995 M3 & 2000 540i
it's definitely not the pixels just yet. I can see all the pixels fine. It's just station presets 1 and 2 are dim.
Reply With Quote
  #9  
Old 08-21-2009, 12:29 AM
richardm1981 richardm1981 is offline
Registered User
Location: usa
 
Join Date: Aug 2009
Posts: 1
Mein Auto: 1999 528I
Weird problem with a 1999 528i

Same problem here with the MID display where they are not dead pixel but more like dimmer then the other ones like fading away or something but call me crazy because I really can't understand this but it only does it in the day time. During night time the pixels are all normal.
Reply With Quote
  #10  
Old 08-21-2009, 09:01 AM
BlueKnight1 BlueKnight1 is offline
Registered User
Location: Brooklyn NY
 
Join Date: Jul 2009
Posts: 10
Mein Auto: '98 528i, '08 GMC Acadia
Same here with 1 and 2

Quote:
Originally Posted by x2nervisx View Post
it's definitely not the pixels just yet. I can see all the pixels fine. It's just station presets 1 and 2 are dim.
Remedy to the problem?
Reply With Quote
  #11  
Old 08-21-2009, 12:43 PM
ztom's Avatar
ztom ztom is offline
I gotta have more cowbell
Location: Thousand Oaks CA
 
Join Date: Sep 2007
Posts: 855
Mein Auto: 1997 528i
I took my MID apart and swapped the backlight panel with another one from salvage unit. Had to do this to get the good LCD with the good back light together in one unit. Bulbs didn't look easily serviceable. It was an interesting task for me but if you do it, count on buying a replacement mid, then you won't be disappointed if it doesn't' go right. Getting the mid out of the car is like 30 seconds. Alert - the electrical connector has a plastic lever that swings 90 degrees to release. A nice design but be aware it's there.
Reply With Quote
  #12  
Old 10-06-2009, 10:33 PM
Eurojay89's Avatar
Eurojay89 Eurojay89 is offline
Faithful to the fest
Location: Providence, Rhode Island
 
Join Date: Jan 2009
Posts: 366
Send a message via AIM to Eurojay89
Mein Auto: 2003 530i
Quote:
Originally Posted by ztom View Post
Alert - the electrical connector has a plastic lever that swings 90 degrees to release. A nice design but be aware it's there.
yea i accidentally broke mine
Reply With Quote
  #13  
Old 04-17-2013, 11:28 PM
sdb48 sdb48 is offline
Registered User
Location: Northern CA
 
Join Date: Apr 2013
Posts: 86
Mein Auto: 3 Series
Where can you get the MID bulbs?
Reply With Quote
  #14  
Old 04-18-2013, 03:56 PM
sdb48 sdb48 is offline
Registered User
Location: Northern CA
 
Join Date: Apr 2013
Posts: 86
Mein Auto: 3 Series
Found these for $11.95
http://bavauto.com/shop.asp
Reply With Quote
  #15  
Old 04-18-2013, 06:03 PM
caryalon caryalon is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Jun 2010
Posts: 234
Mein Auto: 2002 530i, 2001 325i
Quote:
Originally Posted by x2nervisx View Post
it's definitely not the pixels just yet. I can see all the pixels fine. It's just station presets 1 and 2 are dim.
I'm confused - your pictures are of the instrument cluster, yet you say that you can't see the station presets of the MID. Which was/is the problem?
Reply With Quote
  #16  
Old 04-18-2013, 08:26 PM
JimLev JimLev is online now
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,827
Mein Auto: 540/6, S60 Volvo, Tribeca
Quote:
Originally Posted by caryalon View Post
I'm confused - your pictures are of the instrument cluster, yet you say that you can't see the station presets of the MID. Which was/is the problem?
He posted that 4 years ago, don't think he's around anymore.

Speedo bulbs can be purchased at BMW, they are cheap.
MID bulbs can be ordered from electronic supply houses, IIRC they are CM-712.
__________________

2000 540/6 Slightly tweeked...everywhere
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms