Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 05-10-2009, 10:04 AM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
Help! Tried Everything Car will not start

I am so confused! My 86 528e used to work fine and after sitting for awhile it would only start when it wanted to. It fires fine; but will not start all of the time. I've replaced fuel filter and the engine is getting gas and I'm not sure where to go from here.
Reply With Quote
Ads by Google
  #2  
Old 05-11-2009, 07:20 AM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
Replace the main relay (is real cheap). It sounds like you are not getting spark. If main relay is not it then check OBC relay inside the car under the dashboard (mounted on the same spot as the 'gong') Also check all fuses.
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
  #3  
Old 05-11-2009, 11:35 AM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
which is the main relay? I'm new to BMW's and would appreciate any help! Thank you
Reply With Quote
  #4  
Old 05-12-2009, 09:20 AM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
Check on the side of your fuse box. It's the one with 5 pins as the other ones (fuel pump, O2 sensor) have only 4 pins.
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
  #5  
Old 05-12-2009, 10:23 AM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
Got it and it works great! Thank you so much hun! -Erin
Reply With Quote
  #6  
Old 05-21-2009, 03:26 PM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
Okay I replaced the main relay and was so excited because the car started right up. Two days later I went to start it up and nothing????? Do you think I should check the OCB relay; you said that was under the dash? Any input would help so much and I really appreciate it.
Reply With Quote
  #7  
Old 05-22-2009, 12:41 PM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
Did you also replaced the fuel pump relay? If replacing this one doesn't help then do the OBC realy check.
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
  #8  
Old 05-22-2009, 01:28 PM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
is the fuel pump relay located beside the main? did i ask you that already if i did i'm sorry!
Reply With Quote
  #9  
Old 05-22-2009, 01:41 PM
willysully's Avatar
willysully willysully is offline
Officially Welcomed to the 'Fest
Location: New Orleans, Louisiana
 
Join Date: Apr 2008
Posts: 174
Mein Auto: 1995 325i
To test fuel pump relay simply listen for hum or whirling noise by pass rear fender. Possible causes are erratic continuity of ignition switch, bad fuel pump relay, intermittent function of fuel pump.
__________________
Keep the shiney side up!
Reply With Quote
  #10  
Old 05-22-2009, 03:40 PM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
i don't hear any sound from the sound where the fuel pump is located. there is a relay right beside the main with four pins; is this the fuel pump relay?
Reply With Quote
  #11  
Old 05-22-2009, 06:04 PM
ErinRenae ErinRenae is offline
Registered User
Location: Ohio
 
Join Date: May 2009
Posts: 7
Mein Auto: 528e
okay i've pulled the fuel pump relay and cannot find a replacement anywhere! It's original BMW and no place has this part; are the 4 pin relays interchangeable and or where do you get them?
Reply With Quote
  #12  
Old 06-01-2009, 05:56 PM
selmore selmore is offline
Registered User
Location: Petal, M
 
Join Date: May 2009
Posts: 5
Mein Auto: 1987 525e
fuel pump relay

1987 525e wheres the fuel pump relay, i hot wired the FP and it whirrled i still am not getting fuel to the engine. i figure its the relay. i know where the fuse is but i dont know which ones the relay
thanks
Reply With Quote
  #13  
Old 06-12-2009, 05:59 AM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
For a 1986 528e (M20 engine just as yours) it is outside of the fuse box, last one to the rear of the car just behind the big black connector.
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 06:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms