Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-08-2009, 06:01 PM
Joegoesfishing Joegoesfishing is offline
Registered User
Location: CT
 
Join Date: Dec 2008
Posts: 57
Mein Auto: 08 Cad CTS DI-67 Olds 455
2009 X5 Bluetooth Gone Bonkers

After using my Blackberry for months without a problem, my connection has gotten really squirelly. When my phone pairs up, the bluetooth now shows that I'm on a call to a number that is four asterisks. Nothing works thru the I drive controller. I have to power my phone off to clear the screen. I tried deleting & pairing again but that did not clear the problem. Has anyone else had this experience & how did it get resolved?
__________________
2009 X5 35D Black Sapphire Tobacco Nevada
Reply With Quote
Ads by Google
  #2  
Old 09-08-2009, 07:03 PM
ride and destro ride and destro is offline
Registered User
Location: Ontario Canada
 
Join Date: Sep 2009
Posts: 2
Mein Auto: 325i
2009? take it back to the dealer for warranty
Reply With Quote
  #3  
Old 09-09-2009, 02:12 PM
Craig B Craig B is offline
Officially Welcomed to the 'Fest
Location: MO
 
Join Date: Jan 2008
Posts: 613
Mein Auto: 2009 X5 35d 2007 Lexus LS
Is it on the approved list of phones?

No problems like that with mine...

Craig
Reply With Quote
  #4  
Old 09-16-2009, 06:22 PM
Joegoesfishing Joegoesfishing is offline
Registered User
Location: CT
 
Join Date: Dec 2008
Posts: 57
Mein Auto: 08 Cad CTS DI-67 Olds 455
Turns out that its a known problem with some cell phones. It requires that the cell phone battery be removed to reset the cell phone. Works fine now.
__________________
2009 X5 35D Black Sapphire Tobacco Nevada
Reply With Quote
  #5  
Old 09-19-2009, 07:41 PM
Scott09X5 Scott09X5 is offline
Registered User
Location: Austin
 
Join Date: Sep 2009
Posts: 8
Send a message via Yahoo to Scott09X5
Mein Auto: 2009 X5
No offense Joegoesfishing but are you serious? You're bluetooth in your 09 X5 works fine? I have two phones, one a Blackberry Curve and the other an iPhone, both approved phones and on the list. BMW's bluetooth integration with both of them is terrible. Here's what I've experienced:

Suppose I'm on a phone call on my blackberry in my house. It's my wife ranting about one of her friends and she's going on and on and I'm late for my poker game. So I think to myself I'll keep the call going and just get in my brand new 2009 70+k BMW X5 4.8 and continue the call through the integrated bluetooth. NOT SO FAST!! It turns out that BMW is aware that there's an issue when trying to transfer a call from the headset to the car automatically. An "Issue"? It's more than an issue. The fricken thing doesn't work, PERIOD!!! When I start the car it takes a long time for the on-board computer to start-up and then recognize my phone's bluetooth capability (yes, it's paired correctly) however the phone thinks the car has taken it and drops my ability to continue my conversation via the phone. So, what am I left with? I'm left with not being able to hear/talk via my handheld phone or hear/talk via the car's integrated bluetooth for almost 45 secs. In that amount of time the caller has hung-up thinking I had hung up and I then have to call back.

Here's the good part. Now I'm driving, so if I try and call back from my car sometimes it will work okay and sometimes it still won't think the pairing was done correctly and ask me to pair my phone. If I were to try it from my phone the call goes through okay, but not on my phone. It goes through on my car and I can't talk because the pairing is messed up.

Suffice it to say BMW's got a mess on their hands with this. No one at BMW is giving me any real solutions. All I'm hearing is that they are "aware" of the issue. Great, that and about $3.50 get's me a cup of coffee at Starbucks.

If anyone's got any suggestions on how I should handle this I'm all ears.
Reply With Quote
  #6  
Old 09-19-2009, 07:55 PM
Penguin Penguin is offline
Officially Welcomed to the 'Fest
Location: Illinois
 
Join Date: Aug 2003
Posts: 1,915
Mein Auto: Z4 and X5 Diesel
Quote:
Originally Posted by Scott09X5 View Post
If anyone's got any suggestions on how I should handle this I'm all ears.

Trade it in for a Ford Focus with Sync?

Last edited by Penguin; 09-19-2009 at 07:58 PM.
Reply With Quote
  #7  
Old 09-19-2009, 08:10 PM
Scott09X5 Scott09X5 is offline
Registered User
Location: Austin
 
Join Date: Sep 2009
Posts: 8
Send a message via Yahoo to Scott09X5
Mein Auto: 2009 X5
How about trade it in for FOUR Ford Focus' with Sync?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms