Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-27-2009, 06:39 PM
barearrow barearrow is offline
Registered User
Location: Seattle
 
Join Date: Feb 2009
Posts: 3
Mein Auto: 1999 M Coupe
Post 99 Z3M - Unusual Check engine light

I purchased my Z3M Coupe in February of this year with 106K on it. Until Friday it has run without a hitch. Driving home from work I was greeted with a CEL. It doesnt run any different. The gas cap is tight, no wires or hoses loose, and the air filter was changed 2K miles ago with the oil, oil filter, and fuel filter. I suspect it may be a 02 sensor as I have been running some Lubro Molly injector and valve cleaner through it. It currently has 118K. Any other Ideas?

I purchased a reset/code reader from Bavauto and it is on its way. Any thoughts would be appreciated.
Reply With Quote
Advertisement
  #2  
Old 10-27-2009, 09:35 PM
Randy Forbes's Avatar
Randy Forbes Randy Forbes is offline
Investigative Tinkerer
Location: SW Florida
 
Join Date: Apr 2002
Posts: 4,951
Mein Auto: ///Motorized Vehicles
Too many potential causes to speculate, best to just read the codes and act upon the information given.
__________________

Randy Forbes
1957 Austin-Healey 100/6 Wine Red
1961 McCulloch R1 go-kart Screaming Yellow
1995///M3 Coupe Dakar Yellow Eurosport Twinscrew S/C
1999///M Rdstr Cosmos Black Eurosport Twinscrew S/C
1999///M Coupe Estoril Blue Eurosport Twinscrew S/C
2001///M Rdstr Steel Gray
2011 X5 35i Sport Deep Sea Blue/Cinnamon
Reply With Quote
  #3  
Old 10-27-2009, 10:04 PM
barearrow barearrow is offline
Registered User
Location: Seattle
 
Join Date: Feb 2009
Posts: 3
Mein Auto: 1999 M Coupe
Right on... Should be here in a day or so. Didnt know if there were any maintenance intervals that would cause CEL to light. Love the car it has really captured my interest and given me an excuse to focus on something other than work. Thanks
Reply With Quote
  #4  
Old 11-21-2009, 07:13 PM
barearrow barearrow is offline
Registered User
Location: Seattle
 
Join Date: Feb 2009
Posts: 3
Mein Auto: 1999 M Coupe
Back from SC to read codes

Okay codes E4 and Cb Ox sensor codes.

This is what I suspected as I have been running some of the Lubro Molly injector and valve cleaner through it. I cleared the codes and it ran rough for a few minutes. Took it for a drive and let it warm up good. It seems to run fine now, and the CEL has not come back on.

Any recommendations?
Reply With Quote
  #5  
Old 11-22-2009, 03:49 PM
iwanna330cic iwanna330cic is offline
Iwanna330Cic
Location: Beachwood, OH
 
Join Date: Feb 2005
Posts: 907
Mein Auto: '11 E91 & '12 Z4 3.5i
Quote:
Originally Posted by barearrow View Post
Okay codes E4 and Cb Ox sensor codes.

This is what I suspected as I have been running some of the Lubro Molly injector and valve cleaner through it. I cleared the codes and it ran rough for a few minutes. Took it for a drive and let it warm up good. It seems to run fine now, and the CEL has not come back on.

Any recommendations?
Sounds like the Lubro Molley should take a hike. ?
__________________
"The trouble with quotes on the internet is you never know if they are genuine. - Abraham Lincoln
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms