Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 12-01-2009, 03:58 PM
x3lemon x3lemon is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Dec 2008
Posts: 156
Mein Auto: X3
Strange Electrical Problem

My 'lamp out' light came on two weeks ago. i checked all the lamps and could not find a faulty lamp. So i ignored the light waiting for my next visit to the dealership. Today on the highway, the lamp out light went off but at the same time a number of strange things happened....

the direction indicators stopped working, no light or sound.
then the tire pressure low and airbag error lights lit up on the console.

when I turned on the headlights and/or foglamps no indicator lights came up on the console.

I got home, turned the car off. 15 mins later turned it on and everything was fine.

it's scheduled to goto the dealer tomorrow for investigation but now the problem has resolved itself I'm sure they will say they can't do anything.

Anyone have this problem or have an idea what it could be?

09 X3...
Reply With Quote
Advertisement
  #2  
Old 12-01-2009, 04:49 PM
X3 Skier's Avatar
X3 Skier X3 Skier is offline
Powder Days
Location: Ohio and Colorado
 
Join Date: Aug 2005
Posts: 1,950
Mein Auto: 2005 X3 2.5i (ED 2004)
I had something similar happened to my 05 where many electrical items went haywire and eventually the car died completely. They replaced the entire instrument cluster which is somehow a central node in the system.

Cheers
__________________
Just Some Consultant

"I never understood the dread term "terminal illness" until I saw Heathrow for myself." Dennis Hopper
Reply With Quote
  #3  
Old 12-01-2009, 07:02 PM
x3lemon x3lemon is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Dec 2008
Posts: 156
Mein Auto: X3
Oh great! I have a total meltdown to look forward to!

Thanks for the heads-up.
Reply With Quote
  #4  
Old 12-01-2009, 09:12 PM
enamoured enamoured is offline
Officially Welcomed to the 'Fest
Location: Alberta, Canada
 
Join Date: Aug 2008
Posts: 1,045
Mein Auto: 2005 BMW X3 3.0i
I am thinking it was more of a glitch that got resolved when car was restarted, much like restarting a computer that has been misbehaving. No matter how sophisticated a computer is, they all have their bugs/problems and limitations.
__________________

(OO \ (|||) (|||) / OO)
Reply With Quote
  #5  
Old 12-02-2009, 05:03 AM
X3 Skier's Avatar
X3 Skier X3 Skier is offline
Powder Days
Location: Ohio and Colorado
 
Join Date: Aug 2005
Posts: 1,950
Mein Auto: 2005 X3 2.5i (ED 2004)
The things that happened to me was over several days/weeks. Things like spurious warning lights, radio working then not working and missing Sirius and then having it back, power windows working then not working then working again and other screwball anomalies.

Eventually, the car was dead one morning when I went to start it, just as I was planning to take it to the Dealer. Took about two days to diagnose and then the Dealer had a new cluster air freighted from Germany. Since it was under warranty and they gave me a loaner, no big deal.

Cheers
__________________
Just Some Consultant

"I never understood the dread term "terminal illness" until I saw Heathrow for myself." Dennis Hopper
Reply With Quote
  #6  
Old 12-02-2009, 07:27 PM
x3lemon x3lemon is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Dec 2008
Posts: 156
Mein Auto: X3
took it to the dealer and of course they couldn't find a problem and furthermore apparently nobody has ever had a similiar problem - go figure. Anyway, I'll keep you all posted...

They did replace the lamp that was out - free of charge - which rather decent of them!

Last edited by x3lemon; 12-02-2009 at 07:33 PM.
Reply With Quote
  #7  
Old 12-05-2009, 07:25 AM
BCX BCX is offline
Registered User
Location: Colorado
 
Join Date: Jan 2009
Posts: 9
Mein Auto: 2007 X3 Sport Package
I just had a similar problem (light bulb warning light on the dash) on my '07 XC3 over the past couple of weeks. I have noticed my headlamp washers are not popping up now (I have full washer fluid). They have been itermittent. The light bulb light on the dash was off and they were working. The light is now on and they are not working. The car is do for service in under 900 miles, so I am planning to have thm look at it then.
__________________
Reply With Quote
  #8  
Old 12-05-2009, 04:43 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 14,034
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
The headlamp washers only operate on the 1st pull, and every 5th pull after that, of the wiper stalk to wash the windshield when the headlamps are on.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms