Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-10-2009, 05:54 PM
japbike736 japbike736 is offline
Officially Welcomed to the 'Fest
Location: Pismo Beach, CA
 
Join Date: Apr 2009
Posts: 109
Mein Auto: 1990 535i, 1999 911
Pulling my hair out...92 525i

After 3 or 4 weeks of my door locks, windows and sun roof working fine, today nothing works....I do not think this car will ever be the same after being in the flood last April..One thing I noticed this time is the power window switches do not light up....Inside lights work in the manual position but will not come on when the door is opened...The wipers only work on the high setting and will stop where ever they are when turned off...I love this car. It runs like a top , has many new parts and would go anywhere but it is driving me nuts!!! Im sure alot of you have seen my threads about this car.....Any more idea's on what I can try???
Reply With Quote
Ads by Google
  #2  
Old 12-10-2009, 08:54 PM
Tourburgring Tourburgring is offline
Officially Welcomed to the 'Fest
Location: Beamsville, Ontario
 
Join Date: Nov 2008
Posts: 456
Mein Auto: 1993 525iT
One of the Electronic Modules known as the "General Module" controls many of the items you mention you are having trouble with. It's possible moisture got inside and over time has caused corrosion that is now affecting the electrical systems. It is one of the larger units located under the LH rear passenger seat. Check section 610 in the Bentley Manual for the exact location. The neighbouring "Relay Module" could also be similarly affected and will also cause problems.
Reply With Quote
  #3  
Old 12-10-2009, 10:20 PM
nmp411 nmp411 is offline
Officially Welcomed to the 'Fest
Location: Iowa
 
Join Date: Jan 2008
Posts: 299
Mein Auto: 90 535iM
If you want to give the RM and GM (relay and general modules) a try as suggested above, I've got a set of them boxed up and ready to be shipped out to you if you are interested. $45 shipped gets them!


Also, has your ecu been replaced since the flood?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms