Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 12-11-2009, 04:01 PM
Eric Arrow Eric Arrow is offline
Registered User
Location: Allison Park PA
 
Join Date: Nov 2009
Posts: 49
Mein Auto: BMW
X3 left it's mark in the garage last night..

.....little puddle of Smurf pee....IE: antifreeze. I checked the level and it was low. Heather took it to work and I told her to call if the low coolant light came on.. phone rang. So off to the dealer for some coolant. I made an appointment for Monday...could'nt tell exactly where it was coming from..Hopefully just the expansion tank. I called my warranty company and the dealer I bought it from and both gave the right answers. Warranty company siad the warranty was in effect...dealer said if there are any issues call them right away. So far so good...car runs fine...doesn't smell like french toast ...no white smoke and there is no coolant in the oil. Wish me luck
Reply With Quote
Ads by Google
  #2  
Old 12-11-2009, 08:39 PM
ericbell1 ericbell1 is offline
Registered User
Location: Pittsburgh PA
 
Join Date: Oct 2007
Posts: 60
Mein Auto: '08 Monaco Blue X3 3.0si
Good luck neighbor - how do you and the wife like it so far?
__________________
2008 X3 3.0si
Monaco Blue / Beige
Premium / 18in Wheels / Xenons / Heated Seats / Heated Wheel / Privacy
Reply With Quote
  #3  
Old 12-11-2009, 08:52 PM
codog2 codog2 is offline
Officially Welcomed to the 'Fest
Location: boston, ma
 
Join Date: May 2006
Posts: 698
Mein Auto: 5
Quote:
Originally Posted by Eric Arrow View Post
.....little puddle of Smurf pee....IE: antifreeze. I checked the level and it was low. Heather took it to work and I told her to call if the low coolant light came on.. phone rang. So off to the dealer for some coolant. I made an appointment for Monday...could'nt tell exactly where it was coming from..Hopefully just the expansion tank. I called my warranty company and the dealer I bought it from and both gave the right answers. Warranty company siad the warranty was in effect...dealer said if there are any issues call them right away. So far so good...car runs fine...doesn't smell like french toast ...no white smoke and there is no coolant in the oil. Wish me luck
what year, how many miles?
Reply With Quote
  #4  
Old 12-11-2009, 08:58 PM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,069
Mein Auto: 2004 X3 2.5i
Quote:
Originally Posted by Eric Arrow View Post
... Hopefully just the expansion tank.
I'd say hopefuly less than that.

For your new-to-you '06, even with 52K miles, a bit early for a cracked expansion tank.

Maybe a small leak in the upper rad hose, or a smaller by-pass hose, or possibly -

the selling dealer might have done a coolant flush as part of a general reconditioning,
and didn't fully tighten a connection.

Even if you wont be paying the bill, here's hoping for a simple explanation and an easy fix.
Reply With Quote
  #5  
Old 12-11-2009, 09:18 PM
Eric Arrow Eric Arrow is offline
Registered User
Location: Allison Park PA
 
Join Date: Nov 2009
Posts: 49
Mein Auto: BMW
Thanks folks......she loves it so far. Hopefully the fix will be minimal. It's tough for me since I have 25 years in the automotive field to actually make an appointment at a dealership As stated it's an 06' with 52k.
Reply With Quote
  #6  
Old 12-12-2009, 11:47 AM
Eric Arrow Eric Arrow is offline
Registered User
Location: Allison Park PA
 
Join Date: Nov 2009
Posts: 49
Mein Auto: BMW
Well...bigger puddle last night. I stopped Heather as she was pulling out of the garage and gave her the keys to the Explorer. I pulled the splash shield off the bottom and cleaned everything up....refilled and ran it waiting for the leak. Tough to tell but the good news is it's not coming out of the motor...looks like either the expansion tank,rad..or a line going to the rad. I'll fill it again and take it to the dealer on Monday....
Reply With Quote
  #7  
Old 12-15-2009, 11:00 AM
madhatch madhatch is offline
Registered User
Location: PDX
 
Join Date: May 2004
Posts: 16
Mein Auto: 06 X3 MT
Be very careful driving it there.....if your coolant takes a dump because of burst hose/connector. Your chances of overheating go up which could cause busted headgasket & engine damage..i would consider towing in if your not sure where it's coming from if do drive watch that gauge.....
__________________
present
06 X3 MT6
98 318ti M-sport
93 Miata LE

BMWCCA Member
past fun ones
99 540iT sport
91 318is M42
93 300E Sportline
99.5 A4 Avant 1.8T

Reply With Quote
  #8  
Old 12-15-2009, 02:04 PM
Eric Arrow Eric Arrow is offline
Registered User
Location: Allison Park PA
 
Join Date: Nov 2009
Posts: 49
Mein Auto: BMW
Thanks for the advice....It's fixed now...it was the expansion tank as expected.
Reply With Quote
  #9  
Old 12-15-2009, 02:13 PM
madhatch madhatch is offline
Registered User
Location: PDX
 
Join Date: May 2004
Posts: 16
Mein Auto: 06 X3 MT
cool... plastic expansion tanks known problem changed it twice on my E39 540iT w/149,000 miles b4 I traded.....
__________________
present
06 X3 MT6
98 318ti M-sport
93 Miata LE

BMWCCA Member
past fun ones
99 540iT sport
91 318is M42
93 300E Sportline
99.5 A4 Avant 1.8T

Reply With Quote
  #10  
Old 12-15-2009, 02:21 PM
Eric Arrow Eric Arrow is offline
Registered User
Location: Allison Park PA
 
Join Date: Nov 2009
Posts: 49
Mein Auto: BMW
I had it apart to the point that I could have done it myself...but we needed to get it inspected anyway. The dealer fixed it and we payed the $100 deductable plus the overage between the labor rate our warranty company would pay $75hr and thier $98 rate. I was a little pissed the dealer did'nt call with that info...but oh well.
Reply With Quote
  #11  
Old 12-15-2009, 07:07 PM
ericbell1 ericbell1 is offline
Registered User
Location: Pittsburgh PA
 
Join Date: Oct 2007
Posts: 60
Mein Auto: '08 Monaco Blue X3 3.0si
Which dealer do you go to? I highly recommend Rahal... there's also a good indy dealer my wife's uncle uses.. the name slips me.
__________________
2008 X3 3.0si
Monaco Blue / Beige
Premium / 18in Wheels / Xenons / Heated Seats / Heated Wheel / Privacy
Reply With Quote
  #12  
Old 12-15-2009, 07:16 PM
Eric Arrow Eric Arrow is offline
Registered User
Location: Allison Park PA
 
Join Date: Nov 2009
Posts: 49
Mein Auto: BMW
We went to P&W in Oakland.....I'm thinking of using Foriegn Traffic here in Allison Park...they have good ratings and are within walking distance if needed.
Reply With Quote
  #13  
Old 12-16-2009, 11:23 AM
HeadRoom HeadRoom is offline
Registered User
Location: Pennsylvania
 
Join Date: Jun 2009
Posts: 73
Mein Auto: Z3 / M3
Glad to hear that the X3 is back on the road! *Going out to check my expansion tank now*
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms