Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-03-2009, 06:58 AM
induscreed induscreed is offline
Registered User
Location: VA
 
Join Date: Oct 2009
Posts: 5
Mein Auto: Z4 3.0
Z4 Stalling with EPS, Brake, ABS and Traction Light on at Idle

I have a 2005 Z4 3.0 with only 35k Miles. The car has been have some electric issues as of late with the Yellow-Brake, ABS and Traction Control lights coming on and off at idle at different speeds. Having done some research online, it seems the DSC Module needs to replaced on the car. Please advise if you've found a remedy or have experienced similar issues.

On a separate note, my car stalled a few times at 40-50mph on local and interstate roads with the car completely shutting off. A trusted mechanic said it was excessive carbon deposits on the throttle body is what's been causing it to stall.
Remedy-Had an Induction Service done with BG44 at a price of $250. I'll keep you posted where this would solve the problem.

Feel free to keep adding your comments/stories to this thread for us to find an educated solution to these issues.
Reply With Quote
Ads by Google
  #2  
Old 12-30-2009, 07:12 AM
induscreed induscreed is offline
Registered User
Location: VA
 
Join Date: Oct 2009
Posts: 5
Mein Auto: Z4 3.0
Solution

Ok. Thanks to BMW of Fairfax and $152, the lights have stopped coming on and the EPS light no longer engages. The car does not stall anymore.

It was voltage issue that can only be removed by BMW mechanics, i.e. your standard diagnostic devices don't delve into the detail extracted by the the BMW diagnostic software. There were multiple voltage faults that had to be erased by BMW mechanics.

If you guys come across an issue like I had...do yourself a favor and take it into a dealership for diagnosis. At BMW of Fairfax, they charge $125 + 6% shop fee. The important thing is for BMW NA to have a record of the diagnosis.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms