Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-16-2010, 03:19 AM
Ashwani01 Ashwani01 is offline
Registered User
Location: uk
 
Join Date: Oct 2009
Posts: 5
Mein Auto: bmw 525i
Angry EML light on

Hi I drive a 2002/520i SE, The EML light has come.. have taken to BMW twice @ $60 a time, to have code read and reset the light but they couldn,t tell me what exactly is causing it.. they say it's running lean hence maybe a air leak...but couldn't come up with anything! they want me to book it in for at least1 hour @ $170/time ..I can't belive they can be so useless! Has any body got any ideas what this could be and does any one know how to reset the EML light..I understand once triggered it latches ON.. any help will be most appreciated... thks
Reply With Quote
Ads by Google
  #2  
Old 01-16-2010, 05:08 AM
Fudman's Avatar
Fudman Fudman is online now
Officially Welcomed to the 'Fest
Location: Sudbury, MA
 
Join Date: Apr 2007
Posts: 6,152
Mein Auto: '02 530i Sport auto
You need to get a code reader appropriate for your model. That will pay for itself after the second time you use it. The code reader will also allow you to erase an error message. It is very difficult to properly diagnose a problem based on a brief description. Error codes are needed to eliminate possibilities and/or to confirm certain assumptions. Lean mixture could be a vacuum leak. Or something else... Sorry.
Reply With Quote
  #3  
Old 01-16-2010, 09:17 AM
bmw_n00b13's Avatar
bmw_n00b13 bmw_n00b13 is offline
Freude am Fahren
Location: Cambridge, ON
 
Join Date: Feb 2008
Posts: 6,372
Mein Auto: 99 528iA
If you take it to the dealer, ask them to print the diagnostics out for you.

Read up on vacuum leaks on the forums, there's a lot of threads.
__________________
'99 528i ('98/12 build). 174,000km BY29428/Royalrot
Breaking My Wallet since 2009
Mods: Stoptech SS brake hose, 280piece toolkit resting on trunk floor, Beisan VANOS seals
'99 540i (grandfather's)

Reply With Quote
  #4  
Old 01-17-2010, 04:18 AM
Ashwani01 Ashwani01 is offline
Registered User
Location: uk
 
Join Date: Oct 2009
Posts: 5
Mein Auto: bmw 525i
Thks Guys for your response, i'll follow up on air leaks thks. Approx how much are the code readers?
Reply With Quote
  #5  
Old 01-17-2010, 04:42 AM
kbnn_'s Avatar
kbnn_ kbnn_ is offline
...
Location: Kyrgyzstan
 
Join Date: Jul 2009
Posts: 148
Mein Auto: e34 & e39
I had EML issue on my 528. Electronic throttle (Drossel Klapan) caused this problem in my case. Dealer said - 400 Eur.
I just cleaned the throttle, and loosen it a little bit. For free

but i'm not telling that you have same problem.
__________________
2008 BMW X5 3.0si Space Gray
2005 BMW 320CD Silbergrau
1995 BMW 525i Aktissilber Japan spec
2003 BMW e39 530dA Individual & Sport (Special Series "ka152 Deutschland")
1995 BMW 740i Flat Black
2000 BMW 528i Titanium silver
Reply With Quote
  #6  
Old 01-19-2010, 06:31 AM
Ashwani01 Ashwani01 is offline
Registered User
Location: uk
 
Join Date: Oct 2009
Posts: 5
Mein Auto: bmw 525i
Hi, my car has done 101k..No loss of performance with this fault light.. yeah got a code reader it throws up P0313,P0171,P0174,P0313! I have looked it up in the diagnostic code manual, P0313 is a misfire detected and P0171 & P0174 is lean mixture in Bank1 and Bank2! what is bank1 and bank2? where are the sensors for this? I have reset the light but it comes right back after a short trip! Does anybody have any idea where I should be looking for this air leak? or what I should try next to eradicate this fault. thks folks
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms