Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 01-15-2010, 07:46 PM
MarkusBMW MarkusBMW is offline
Inventor of Hotcross Buns
Location: Monterey, CA
 
Join Date: Jan 2010
Posts: 32
Mein Auto: X3, 323i
Exclamation DICE BMW iPod Kit

I just hooked one of these up and followed the instructions carefully. The 6 and 3 pin connectors were in the trunk area, and I made sure the brown wire on the 3 pin connector was on the outside, and not in the middle. But when I go to use it, the nav screen says speed dialling, and shows the song title. The song is muted, and there is allot of feedback. My X3 has the before mentioned nav, and bluetooth options. Any ideas on what is going one? Any input would be greatly appreciated!
__________________
AREA5100
Reply With Quote
Ads by Google
  #2  
Old 01-16-2010, 09:19 AM
Zeemz Zeemz is offline
Registered User
Location: Alexandria, Va
 
Join Date: Dec 2009
Posts: 7
Mein Auto: 07 X3
I haven't installed one, but I have been looking into it. The video instructions I watched the connectors were in the arm rest console.

http://www.wonderhowto.com/how-to/vi...onsole-143439/
Reply With Quote
  #3  
Old 01-16-2010, 09:20 AM
MarkusBMW MarkusBMW is offline
Inventor of Hotcross Buns
Location: Monterey, CA
 
Join Date: Jan 2010
Posts: 32
Mein Auto: X3, 323i
Quote:
Originally Posted by Zeemz View Post
I haven't installed one, but I have been looking into it. The video instructions I watched the connectors were in the arm rest console.

http://www.wonderhowto.com/how-to/vi...onsole-143439/
Mine appears to be prewired to the trunk. Apparently some are.
__________________
AREA5100
Reply With Quote
  #4  
Old 01-16-2010, 08:02 PM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,574
Mein Auto: 2007 Z4+X3, 2006 530Xi
I hope your kit works out. I had nothing but problems so I returned it. I decided to use my $6 Radio Shack cable from headphone jack to AUX jack instead. Not as clean, but it works and is much cheaper.
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
  #5  
Old 01-16-2010, 08:28 PM
MarkusBMW MarkusBMW is offline
Inventor of Hotcross Buns
Location: Monterey, CA
 
Join Date: Jan 2010
Posts: 32
Mein Auto: X3, 323i
Quote:
Originally Posted by madurodave View Post
I hope your kit works out. I had nothing but problems so I returned it. I decided to use my $6 Radio Shack cable from headphone jack to AUX jack instead. Not as clean, but it works and is much cheaper.
Thanks! I hope it does too. Waiting for someone at BSW to get back to me.
__________________
AREA5100
Reply With Quote
  #6  
Old 01-17-2010, 02:07 PM
MarkusBMW MarkusBMW is offline
Inventor of Hotcross Buns
Location: Monterey, CA
 
Join Date: Jan 2010
Posts: 32
Mein Auto: X3, 323i
Called the guys as DICE and got it all straightened out! I had it plugged into the cell phone plug. I didn't see any of the connectors in the center console so I figured it must be the trunk ones, but they were in the center console, just way wedged in there. I'm all good in the hood now!
__________________
AREA5100
Reply With Quote
  #7  
Old 01-18-2010, 04:43 PM
eXhilarat3d eXhilarat3d is offline
Officially Welcomed to the 'Fest
Location: Las Vegas
 
Join Date: May 2009
Posts: 108
Mein Auto: '06 X3
How is the product working for you so far? Would you recommend it to others?
__________________
'13 BMW 528i
'06 BMW X3

Previously owned:
'12 Audi TT
'06 Subaru WRX
'01 Audi S4
'02 Acura RSX-S
Reply With Quote
  #8  
Old 01-18-2010, 05:29 PM
MarkusBMW MarkusBMW is offline
Inventor of Hotcross Buns
Location: Monterey, CA
 
Join Date: Jan 2010
Posts: 32
Mein Auto: X3, 323i
Works as published! Yes I would.
__________________
AREA5100
Reply With Quote
  #9  
Old 01-21-2010, 02:43 PM
Hatzenbach Hatzenbach is offline
Registered User
Location: California
 
Join Date: Jul 2009
Posts: 68
Mein Auto: 2006 X3 & 2009 Carrera
I have the DICE iPod kit and yes it works great
One caveat though is that the control of the iPod through the head unit is very limited and cumbersome, so make sure that you have access to the iPod itself to select your music.

The controls on the head unit even lack a Pause/Play button ...
But when I bought it I knew that so I am happy with it
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms