Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-16-2010, 12:51 PM
sexipink sexipink is offline
Registered User
Location: NJ
 
Join Date: Sep 2009
Posts: 9
Mein Auto: 2005 X3
Unhappy X3 electrical problems... PLEASE HELP

I have a 2005 X3 with about 50k miles and about 2 months ago I started having electrical problems. 1st it started with my inside lights flickering on and off, and my radio shutting off. The inside lights flickered for a couple of days then stopped, but my radio still ocassionaly shuts off. Then I noticed that my outside lights wouldnt work when on auto, but worked fine when I manually turned them on. My seat & steering warmer, and back windshield wiper no longer work as well.

My car is no longer under warranty with Bmw, but I do have a third party warranty that covers eletrical problems. So I took it into Bmw last thursday. After 6 days of having my car they still dont know what the problem is. So finally they called me today saying they think they know what the problem is (what do you mean think). They claim it appears someone spilled something on the passenger side and its all over the wires because there very sticky, and since it appears to be a spill most likely my warranty wont cover it. So for them to finish diagnosing the problem its going to cost me $750, and thats not including whatever the cost is to fix this unknown problem.


This just sounds like a bunch of BS to me, I would think the wires wouldve been the 1st place they looked especially since they said these wires run into everything im having problems with. It took them 6 days to find this???
So needless to say im picking my car back up with the same promblems it had when I dropped it off. And on top of that I have to pay them $100.00 for the diagnostics when they didnt even actually tell me what the problem is.



Sorry for the loooonng post, but can someone please help me. Do you think what their saying makes sense?? (mind you I dont recall anyone spilling anything in my car). Does anyone know someone in the Northen NJ area that deals with bmw electrical problems???
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms