Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-23-2010, 01:23 PM
ggrantfamu ggrantfamu is offline
Registered User
Location: Orlando, FL
 
Join Date: Dec 2008
Posts: 8
Mein Auto: 2006 BMW 650
Rollover Protection Malfunction (iDrive Warning)

Has anyone here had any experience with this?

There was a change in the grade of the road when I was getting on the interstate (going from asphalt to black top) that was abrupt and not smoothed over, that I hit it going pretty fast. The impact was almost the equivalent of falling into a bad pothole or something similar.

Well, as soon as I hit the bump the iDrive gave me a "rollover protection malfunction" warning. I took it to my mechanic today and he says that he's gonna have to download everything from my computer to try and trace the problem. I didn't have time to wait today, but have an appointment for Thursday AM.

The car drives fine and I haven't noticed any type of degradation.

Do you guys have any clue what the problem could be?
Reply With Quote
Advertisement
  #2  
Old 03-23-2010, 05:42 PM
chasz17 chasz17 is offline
Officially Welcomed to the 'Fest
Location: Franklin, MA
 
Join Date: May 2007
Posts: 479
Mein Auto: x5 4.4i
I'm not in front of my owner's manual but absolutely do recall a reset procedure that the owner can do. Check your manual for the info and good luck.
Reply With Quote
  #3  
Old 03-23-2010, 05:49 PM
ggrantfamu ggrantfamu is offline
Registered User
Location: Orlando, FL
 
Join Date: Dec 2008
Posts: 8
Mein Auto: 2006 BMW 650
When I checked out the manual, the only thing I saw was that you could retract the roll bars when they deployed, mine never deployed.

Is that what you're talking about?
Reply With Quote
  #4  
Old 03-23-2010, 08:48 PM
TopDownInFL's Avatar
TopDownInFL TopDownInFL is offline
Officially Welcomed to the 'Fest
Location: Fort Lauderdale, FL
 
Join Date: Apr 2008
Posts: 3,663
Mein Auto: 2012 650 Coupe
Once you've restarted your car, does it come back? My SA has always said it's only an issue if it repeatedly comes back (like every computer system, there are glitches...).
__________________
Nick / TopDownInFL (sans the "top down")

2012 650 Coupe - Alpine White / Black Interior / M Package / Premium Sound
Previous Bimmers:
2008 650i Convertible
2004 645Ci Convertible - Reverse Sensors / Reverse Camera
2005 545i Sedan
2003 330Ci Convertible
2001 330Ci Coupe
1998 323i Convertible
1995 318i Sedan
Reply With Quote
  #5  
Old 03-23-2010, 09:38 PM
All-Or-Nothing's Avatar
All-Or-Nothing All-Or-Nothing is offline
Woo Hoo FREE Donuts
Location: Big Ol' House
 
Join Date: Mar 2007
Posts: 899
Mein Auto: 2004 645Ci Convertible
Anyone have a pic of the rollover bars deployed.
__________________
Reply With Quote
  #6  
Old 03-23-2010, 11:08 PM
ggrantfamu ggrantfamu is offline
Registered User
Location: Orlando, FL
 
Join Date: Dec 2008
Posts: 8
Mein Auto: 2006 BMW 650
Quote:
Originally Posted by TopDownInFL View Post
Once you've restarted your car, does it come back? My SA has always said it's only an issue if it repeatedly comes back (like every computer system, there are glitches...).
It hasn't gone off since it came on. I've restarted the car, and let the top back and forth multiple times. It's still there.
Reply With Quote
  #7  
Old 03-24-2010, 07:25 AM
TopDownInFL's Avatar
TopDownInFL TopDownInFL is offline
Officially Welcomed to the 'Fest
Location: Fort Lauderdale, FL
 
Join Date: Apr 2008
Posts: 3,663
Mein Auto: 2012 650 Coupe
Quote:
Originally Posted by ggrantfamu View Post
It hasn't gone off since it came on. I've restarted the car, and let the top back and forth multiple times. It's still there.
Then (obviously) definitely take it in.
__________________
Nick / TopDownInFL (sans the "top down")

2012 650 Coupe - Alpine White / Black Interior / M Package / Premium Sound
Previous Bimmers:
2008 650i Convertible
2004 645Ci Convertible - Reverse Sensors / Reverse Camera
2005 545i Sedan
2003 330Ci Convertible
2001 330Ci Coupe
1998 323i Convertible
1995 318i Sedan
Reply With Quote
  #8  
Old 03-24-2010, 07:31 AM
ggrantfamu ggrantfamu is offline
Registered User
Location: Orlando, FL
 
Join Date: Dec 2008
Posts: 8
Mein Auto: 2006 BMW 650
Quote:
Originally Posted by TopDownInFL View Post
Then (obviously) definitely take it in.
Sure thing. I have an appointment tomorrow. I was just wondering if anyone else had ever experienced this, so I could kinda have some idea of what to expect tomorrow.

They already told me that they're going to have to download everything from the onboard computer just to start diagnosing the problem.
Reply With Quote
  #9  
Old 03-25-2010, 10:18 AM
ggrantfamu ggrantfamu is offline
Registered User
Location: Orlando, FL
 
Join Date: Dec 2008
Posts: 8
Mein Auto: 2006 BMW 650
Turns out that it needed a software update to decrease the sensitivity of the roll sensor. Apparently its fairly common for this to happen as some ppl reported the fault even going over a speed bump too hard, so BMW made a software update for it. Cost me 200 bucks, but could have been a lot worse I suppose.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms