Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools
  #826  
Old 06-06-2010, 07:20 PM
WillInDenver's Avatar
WillInDenver WillInDenver is online now
1oz perception-1# obscure
Location: Denver
 
Join Date: Oct 2007
Posts: 2,427
Mein Auto: 2013 535i XDrive M-Sport
Quote:
Originally Posted by togles View Post
The dealer told me that the aux input was not available for my car!, ?? I have a '05 545. Does that sound right?
It doesn't sound right. My '05 545i was a 9/04 build, so pretty early in the model year, and I was able to add an aux input. It was necessary to purchase the part, have the dealer install it, and program iDrive to see it. Total cost was around $65 for the part (www.bavauto.com) and under $200 for the install IIRC.

Your dealer may not have understood your question and thought you were asking if your car had an aux input, not if one could be added?
__________________
-Will
2013 535i xDrive M-Sport | 2005 545i Sport (Retired and Missed) | 2001 X5 3.0 Sport (Retired)
Reply With Quote
  #827  
Old 06-25-2010, 07:12 AM
CompSciBimmer CompSciBimmer is offline
Registered User
Location: New Jersey
 
Join Date: Jun 2010
Posts: 14
Mein Auto: 2008 528i
I have a 2008 iDrive with AUX and USB. My iPhone has always worked beautifully with the iPod integration. Ever since I upgraded to iOS4, however, the iPod integration seems really flaky.

Anyone else experience this? My iPhone is a 3GS. If you haven't already you might want to hold off on the update if iPod functionality in your car is really important to you.
Reply With Quote
  #828  
Old 06-25-2010, 08:13 AM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
I have been driving a loaner '09 535 Xi with factory ipod/usb in the center armrest. It was working well and then starting acting funny. This was before the OS4 update. The update seems to have had no effect. I have a 2nd Gen iPod Touch. I just had the OEM iPod adaptor installed in my '07 530 XI (glovebox). I will report back on that once I start using it.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #829  
Old 06-26-2010, 04:31 PM
cccplus cccplus is offline
Officially Welcomed to the 'Fest
Location: ca
 
Join Date: Mar 2007
Posts: 108
Mein Auto: 550i
Does anyone have iphone 3gs with ios4 fully working on the ipod adapter? Can you play and control music thru idrive? TIA
Reply With Quote
  #830  
Old 06-26-2010, 05:20 PM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
I have an iPod Touch 2nd Gen iOS4 using glovebox adaptor. I can control the music through iDrive. Hope this helps some.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #831  
Old 06-26-2010, 07:17 PM
CompSciBimmer CompSciBimmer is offline
Registered User
Location: New Jersey
 
Join Date: Jun 2010
Posts: 14
Mein Auto: 2008 528i
Quote:
Originally Posted by cccplus View Post
Does anyone have iphone 3gs with ios4 fully working on the ipod adapter? Can you play and control music thru idrive? TIA
YES! I was having a lot of intermittent failures with my 3GS and iOS4, but I think I figured out a work around. It seems as though if I have the iPod app open before I connect the adaptor everything works perfectly. I've tested this several times today and every time it works. When I connect with just the home screen or the lock screen I get numerous random issues. I hope this helps.
Reply With Quote
  #832  
Old 06-26-2010, 07:21 PM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
Quote:
Originally Posted by CompSciBimmer View Post
YES! I was having a lot of intermittent failures with my 3GS and iOS4, but I think I figured out a work around. It seems as though if I have the iPod app open before I connect the adaptor everything works perfectly. I've tested this several times today and every time it works. When I connect with just the home screen or the lock screen I get numerous random issues. I hope this helps.
I too have noticed this. Setting the iPod on "iPod" before connecting is definitely helpful imo.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #833  
Old 06-28-2010, 04:19 PM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
I have found that using an iPod Nano, even the most current works better than my iPod Touch 2nd gen. The manual says that the Nano 4G will not charge, but my 5G does. Keeping the number of playlists down is helpful too. By using the Nano, I can make this a dedicated device and keep my touch for everything but car use. I also tried a 2 GB older (think 2G) Nano with good results. My opinion, iPhone and iPod Touch=so so results with glovebox adaptor. YMMV
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #834  
Old 07-06-2010, 12:20 PM
300zxmuro's Avatar
300zxmuro 300zxmuro is offline
CARPE DIEM
Location: Fremont CA
 
Join Date: Jul 2006
Posts: 298
Send a message via AIM to 300zxmuro Send a message via MSN to 300zxmuro Send a message via Yahoo to 300zxmuro
Mein Auto: 2008 535i
Why the Speck Dock is that expensive ($599) it is because the fiber cable? all other are around 150 and the OEM is 370.
__________________
By 300ZXMURO

2008 535i Black Sapphire, Black Dakota Leather, Blue-tooth, Nav, iDrive, Premium Pkg, Sports Pkg, SIRIUS, Comfort Access, Comfort Seats, Parking Sensors, Xenon, Paddles, Sport Suspension, Lane Departure Warning, Rear Power Shade, etc.
Reply With Quote
  #835  
Old 07-09-2010, 05:25 PM
stewie stewie is offline
Registered User
Location: fingerin, djibouti
 
Join Date: Mar 2007
Posts: 88
Mein Auto: 335
iOS 4 issues on a 2G iPod Touch. The car recognizes that an iPod is connected, but won't play anything. The only way I can get it to play is to press play BEFORE connecting it to the car, and then it picks up from the current location. But I can no longer use the car controls to rewind or FF, and the display (non-iDrive) doesn't show the song title.

Functionality is very restricted, obviously. I wonder if this has something to do with the general sluggishness the iPod has been experiencing since the update. Seems like memory is maxed out, and maybe it just can't support the BMW integration any more, for whatever reason.
Reply With Quote
  #836  
Old 07-09-2010, 06:08 PM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
I found that my 2G touch did not get along with BMW interface even before IOS4. The display on the iPod shows "accessory connected" instead of showing the BMW Logo. Using a 5G Nano I can see the BMW logo. It seems to work pretty well. I am using the glovebox adaptor. I had an '09 535 loaner with the console iPod interface. That worked much better and didn't take as long to load the songs etc.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #837  
Old 07-09-2010, 07:05 PM
mschuler mschuler is offline
Registered User
Location: Burlington, Ontario
 
Join Date: Jan 2010
Posts: 27
Mein Auto: 2012 BMW 335 is Cabriolet
I upgraded my iPod to the latest software, OS4, and it still works well in my '07 550i. Am able to control it from the idrive controller. Now the OS on my iPhone (not connected to the car) is another matter; the phone has slowed down considerably to the point that I want to dump it.
Reply With Quote
  #838  
Old 08-04-2010, 04:14 PM
CT535ix CT535ix is offline
Registered User
Location: CT
 
Join Date: Jun 2010
Posts: 94
Mein Auto: 535ix
I have a 3gS iphone on OS4 in my 2009 535ix via the center arm rest plugs and have full functionality through the idrive system. Ipod part actually now includes a display for playlists with the OS4 upgrade that didn't display before.
__________________
_______________________________________________
2009 535ix, Jet Black/Cream Beige Dakota Leather, Light Poplar wood trim, Active Cruise, Keyless, Logic7, Cold Weather, Premium, Nav, Xenon
2000 528i, Titanium/Black leather, Cold weather, Premium
Reply With Quote
  #839  
Old 08-05-2010, 02:13 PM
SirLoins SirLoins is offline
Timing is everything
Location: Atlanta
 
Join Date: Jun 2010
Posts: 32
Mein Auto: 2005 545i
Could someone clear this up for me.

If a the MOST bus ipod adapter or Denison adapter take the place of the 6DCC in the glove box, why do you have to have the car coded to recognize the ipod?
Reply With Quote
  #840  
Old 08-17-2010, 08:00 AM
rxhrchick rxhrchick is offline
Registered User
Location: Las Vegas
 
Join Date: Aug 2010
Posts: 1
Mein Auto: 2008 528i BMW
aux input

Ok just bought my 2008 528i and I cant find the aux input port. Owners manual says center console, theres a hole in there but its too big for the plug. Is it possible that its an option that didnt come on all these cars? I cant believe its that primitive, Im hoping im just blind.
Reply With Quote
  #841  
Old 08-17-2010, 09:21 AM
300zxmuro's Avatar
300zxmuro 300zxmuro is offline
CARPE DIEM
Location: Fremont CA
 
Join Date: Jul 2006
Posts: 298
Send a message via AIM to 300zxmuro Send a message via MSN to 300zxmuro Send a message via Yahoo to 300zxmuro
Mein Auto: 2008 535i
In my car is located in the back of the center console. Between the two chargers.
__________________
By 300ZXMURO

2008 535i Black Sapphire, Black Dakota Leather, Blue-tooth, Nav, iDrive, Premium Pkg, Sports Pkg, SIRIUS, Comfort Access, Comfort Seats, Parking Sensors, Xenon, Paddles, Sport Suspension, Lane Departure Warning, Rear Power Shade, etc.
Reply With Quote
  #842  
Old 08-17-2010, 12:49 PM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
Yes. Between the 2 cigarette lighter sockets.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #843  
Old 08-19-2010, 06:32 AM
adtian adtian is offline
Registered User
Location: Australia
 
Join Date: Aug 2010
Posts: 21
Mein Auto: 530i Msportd
dun bother about the aux. it basically plays the iphone and you cannot control it on the idrive....
Reply With Quote
  #844  
Old 08-19-2010, 07:29 AM
CT535ix CT535ix is offline
Registered User
Location: CT
 
Join Date: Jun 2010
Posts: 94
Mein Auto: 535ix
Quote:
Originally Posted by adtian View Post
dun bother about the aux. it basically plays the iphone and you cannot control it on the idrive....
In my 2009 the idrive provides full functionality of the iphone and ipod features.
__________________
_______________________________________________
2009 535ix, Jet Black/Cream Beige Dakota Leather, Light Poplar wood trim, Active Cruise, Keyless, Logic7, Cold Weather, Premium, Nav, Xenon
2000 528i, Titanium/Black leather, Cold weather, Premium
Reply With Quote
  #845  
Old 08-20-2010, 09:42 AM
mermar mermar is offline
Officially Welcomed to the 'Fest
Location: Minnesota
 
Join Date: Apr 2010
Posts: 117
Mein Auto: 535xi
Newest iPod Nano

Just bought a new iPod Nano last night along with a new iMac. My intent is to dedicate (leave plugged in) by leaving it attached to the iPod connector in the armrest of my 2009 535xi with the OE BWM attachment/cord/charger. Sounds like the current Nano should work very well (display a BMW logo even) with the iDrive. Any first hand expereince would be appreciated. Question about shuffle - I think it works that when a song is playing you push down on the idrive controller and select 'random' - and this will start shuffling songs on the nano after the current song is done playing?/

Also, paired my new iPhone4 this morning - no problem paired super easy and was making calls from the idrive right away.
Reply With Quote
  #846  
Old 08-20-2010, 10:47 AM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
Quote:
Originally Posted by mermar View Post
Just bought a new iPod Nano last night along with a new iMac. My intent is to dedicate (leave plugged in) by leaving it attached to the iPod connector in the armrest of my 2009 535xi with the OE BWM attachment/cord/charger. Sounds like the current Nano should work very well (display a BMW logo even) with the iDrive. Any first hand expereince would be appreciated. Question about shuffle - I think it works that when a song is playing you push down on the idrive controller and select 'random' - and this will start shuffling songs on the nano after the current song is done playing?/

Also, paired my new iPhone4 this morning - no problem paired super easy and was making calls from the idrive right away.
The nano may not charge,but otherwise it works well. If it doesn't charge it's not a big deal really. You can let it charge when you sync it to your iMac. That's been my experience. I have the iPod adaptor in the glovebox. Yours may work a little differently. I have good control of my nano using the iDrive controller.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #847  
Old 08-20-2010, 12:52 PM
mermar mermar is offline
Officially Welcomed to the 'Fest
Location: Minnesota
 
Join Date: Apr 2010
Posts: 117
Mein Auto: 535xi
Quote:
Originally Posted by x3ronnie View Post
The nano may not charge,but otherwise it works well. If it doesn't charge it's not a big deal really. You can let it charge when you sync it to your iMac. That's been my experience. I have the iPod adaptor in the glovebox. Yours may work a little differently. I have good control of my nano using the iDrive controller.
I have read about a part that resolves the charging issue - it is available through apple. I also have an older G3 Nano - maybe that one would both charge and play music.
Reply With Quote
  #848  
Old 08-20-2010, 08:06 PM
x3ronnie's Avatar
x3ronnie x3ronnie is offline
My Other Car Is A Bus
Location: Syracuse, N.Y.
 
Join Date: Jan 2005
Posts: 1,095
Mein Auto: 07 530Xi
Quote:
Originally Posted by mermar View Post
I have read about a part that resolves the charging issue - it is available through apple. I also have an older G3 Nano - maybe that one would both charge and play music.
The G3 nano should be fully compatible. The newer nano would be ok though. I have not bought the charging adaptor because it's really a minor annoyance. Having a dedicated iPod for the car is nice.
__________________
'07 530 Xi ,Auto, Gray, Black Leather, Premium, Cold Weather, Nav,Xenons,iPod,Sirius

'04 X3 2.5i gone
'07 X3 3.0si gone
Reply With Quote
  #849  
Old 08-20-2010, 09:44 PM
adtian adtian is offline
Registered User
Location: Australia
 
Join Date: Aug 2010
Posts: 21
Mein Auto: 530i Msportd
Quote:
Originally Posted by CT535ix View Post
In my 2009 the idrive provides full functionality of the iphone and ipod features.
I have got a e60 and it does not work with the controls.... Is there something I should switch on? I got the original cables from the dealers...
Reply With Quote
  #850  
Old 08-28-2010, 07:48 PM
gurujeff03 gurujeff03 is offline
Registered User
Location: California
 
Join Date: Aug 2010
Posts: 10
Mein Auto: 2006 525i
ipod kit

So what is the difference between these factory BMW ipod kits?

Is one newer than the other?

65-11-0-036-448 and 65-11-0-439-425
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bentley E46 Repair Manual (Tips, tricks and general info) Thread LilEccentricJ General BMW 12 12-18-2010 03:28 PM
iPod in X3 (BMW Business CD) simoncpw Car Navigation, Audio & Electronics sponsored by BimmerTech 6 07-05-2005 03:06 PM
Apple to Introduce a Cheaper iPod Spiderm0n Off-Topic 19 01-06-2004 05:09 PM


All times are GMT -7. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms