Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 07-28-2010, 11:18 PM
suream suream is offline
Registered User
Location: Las Vegas
 
Join Date: Jul 2010
Posts: 9
Mein Auto: 95 745I
95 740i Check Engine light

Hello everyone! New to the forums here and new to BMW. I bought a 95 740i in april and love the car. I have an issue with it though.

I first noticed it is running rich. The car can run for several hours and not have a problem. Then out of nowhere it will start running rough and die. It will start again but run terrible with the check engine light on. Now if I rev it up above 2000 rpm the check engine light will go out. When I let it idle the check engine light will come back on and run rough.

I have cleaned the idle control valve, mass airflow sensor, and checked for possible vac leaks but have found none.

I can let it sit for a few days and the car will start and run fine for about 5 or so hours. Then back to the same again. Today it runs with no check engine light on, but has some rough acceleration but seems fine at a running rpm of around 2000 or higher. When drop to idle it will run rough but no check engine light yet. I have noticed on occasion that from idle I can rev quickly but get slight hesitation and a little pop, like the timing is off.

I have done the stomp test and it comes back as lambada sensor, but that just seems a general test and could be any one of multiple things causing that.

I do have some white smoke at start up but then goes away. Probably due to a head gasket.

I have replaced the spark plugs also. I don't run premium gas in it, if that would make a difference.

Any thoughts on what this might be would be appreciated.

Thanks!

Last edited by suream; 07-28-2010 at 11:20 PM.
Reply With Quote
Ads by Google
  #2  
Old 07-30-2010, 11:27 AM
JUNEBLOOD JUNEBLOOD is offline
Registered User
Location: BROOKLYN
 
Join Date: Jul 2010
Posts: 43
Mein Auto: BROOKLYN
It could be the o2sensors or the maf or a vacum leak
Reply With Quote
  #3  
Old 07-30-2010, 03:59 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 762
Mein Auto: 97 740iL
The lambda sensor is the O2 sensor, and sinse it is one of the sensors that control the air/fuel mixture, it could be the reason your car is running rich.
Reply With Quote
  #4  
Old 07-30-2010, 04:49 PM
HLB HLB is offline
Registered User
Location: Australia
 
Join Date: Feb 2010
Posts: 74
Mein Auto: 1997 740il
I think the white smoke at start up is a sign the valve cover gaskets need replacing. If you remove the engine covers (black plastic with BMW written on them), you should notice a little bit of oil welling underneath the top of the spark plugs where they go into the cylinder. This shouldn't cause the hesitation and running problems you are having. The smoke at start up is oil burning off when you first start the car after it has leaked down onto the pistons while the engine was off.
Reply With Quote
  #5  
Old 07-30-2010, 11:33 PM
suream suream is offline
Registered User
Location: Las Vegas
 
Join Date: Jul 2010
Posts: 9
Mein Auto: 95 745I
Thanks for the input. I will check the O2 sensors. I have already checked one and it seemed fine.

I already have the parts to repair the white smoke.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms