Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-08-2010, 02:23 PM
Imajoi Imajoi is offline
Registered User
Location: Florida
 
Join Date: Sep 2010
Posts: 2
Mein Auto: z4
Electrical Problem?

In March of this year I bought a 2006 Z4. The car was (is) in excellent condition and everything worked fine. Last week the automatic door lock for the passenger side would stop working periodically. Then on Friday the bluetooth stopped working. The car didn't even recognize that it had a bluetooth (meaning, when I hit the buttons on the steering wheel, nothing happened). The car sat over the weekend in the garage and on Monday morning, it had a dead battery. I had the battery changed and everything worked again for a day and now the clock won't allow me to set it and the bluetooth is not working again. I would imagine that this is electrical but I don't want to take it in to the dealer without some sort of idea of what the problem could be. Any ideas??
Reply With Quote
Ads by Google
  #2  
Old 09-08-2010, 05:40 PM
wildag's Avatar
wildag wildag is offline
///M 'n it up!
Location: Reston, VA
 
Join Date: Dec 2004
Posts: 1,686
Send a message via AIM to wildag
Mein Auto: '06 Z4 M Roadster
Check the voltage level on the battery. If it's low, then it sounds like you have a small short in a circuit, which is draining the battery quickly.
__________________

DreamingWell.com Web Services
Reply With Quote
  #3  
Old 09-08-2010, 05:42 PM
RufusKing RufusKing is offline
Officially Welcomed to the 'Fest
Location: Florida
 
Join Date: Sep 2009
Posts: 284
Send a message via MSN to RufusKing
Mein Auto: Z4 3.0i Roadster
you certainly have a drain on the battery. I would check interior lights etc. That may be a start. However, to run down the exact cause of the draw you may have to get it to the shop where they have the tools to test each circuit.
__________________
This one is called OPey

2009 BMW Z4 sDrive 3.0i


I call her weezey

2006 BMW Z4 3.0i Roadster - Sold and I miss her.
Reply With Quote
  #4  
Old 09-08-2010, 05:56 PM
Imajoi Imajoi is offline
Registered User
Location: Florida
 
Join Date: Sep 2010
Posts: 2
Mein Auto: z4
Thanks so much. I'll have them check the battery again
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms