Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #101  
Old 11-28-2010, 08:54 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
That was my thought too, I swapped with some others I had in the garage, but that didn't help... I'm gonna try the boots first and see if that makes it stop
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #102  
Old 11-28-2010, 09:09 PM
Eight Thirty Eight Thirty is offline
nothing.
Location: Rochester, Ny
 
Join Date: Jan 2009
Posts: 13,453
Mein Auto: A dream
You need the NGK +R's


thats what it says on the plug... idk the code for em
__________________
Reply With Quote
  #103  
Old 11-28-2010, 09:12 PM
FenderBender's Avatar
FenderBender FenderBender is offline
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,160
Mein Auto: Red Sled
So, the other plugs didn't help?

Oil must be in there.

Take each coil out, and take an air compressor and blow in there until they are completely dry.
__________________
Turbo Build Here


Reply With Quote
  #104  
Old 11-28-2010, 09:23 PM
ZeGerman's Avatar
ZeGerman ZeGerman is online now
Warm Leatherette
Location: Seattle, WA
 
Join Date: Mar 2009
Posts: 18,437
Mein Auto: 1998 BMW 328is
The NGK BKR6EK plugs are the ones to get. Strange though. Someone on my local BMW CCA forum recently had issues with skipping, and it wound up being a bad CPS. It's worth thinking about, anyway.
__________________

1998 BMW 328is
1966 Pontiac GTO
2007 Subaru Impreza 2.5i 5-door
View my photos: Caught in the Wild
For sale: E30/E36 front sway links
For sale: OEM E36 328 catback

Last edited by ZeGerman; 11-28-2010 at 09:24 PM.
Reply With Quote
  #105  
Old 11-29-2010, 05:57 AM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Hmmm, ok thanks guys. I'll get all the oil out before I put the new boots on.

I have the NGK BKR6EK plugs in there now, and they have the +R on them Franklyn. I guess it could be failing coil wire harness too.
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #106  
Old 12-01-2010, 01:34 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Ok got lots of parts, now just need time to install them.

Will update with pics as i get stuff done
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #107  
Old 12-01-2010, 08:59 PM
E36youngster's Avatar
E36youngster E36youngster is offline
blank
Location: Fort Mill, SC
 
Join Date: Sep 2007
Posts: 1,614
Mein Auto: 07 e92 335i
this thread doesn't have nearly enough pictures to be a build thread!


__________________
Reply With Quote
  #108  
Old 12-02-2010, 03:59 AM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
I know, but its too dark when I have time!

In other news, I have dinan throttle body (3" version)

Valve cover gasket, new spark plug boots, and clean ICV fixed my miss at idle!

M-contours are on the way, along with a new cluster and sun visors too
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #109  
Old 12-02-2010, 05:44 AM
E36youngster's Avatar
E36youngster E36youngster is offline
blank
Location: Fort Mill, SC
 
Join Date: Sep 2007
Posts: 1,614
Mein Auto: 07 e92 335i
i happen to have an M3 MAF sitting in the shop if you happen to need one..
__________________
Reply With Quote
  #110  
Old 12-02-2010, 04:03 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Thanks man!

Ok so I failed smog today, hydrocarbons 328 max allowed 220.

Help me smog experts! The good thing is that a Check engine light came on. Will edit after I read it.

*Edit: Mass air sensor, but I threw that code when I unplugged it once while running. More research is in order.
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....

Last edited by crisscross; 12-02-2010 at 04:21 PM.
Reply With Quote
  #111  
Old 12-02-2010, 04:23 PM
FenderBender's Avatar
FenderBender FenderBender is offline
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,160
Mein Auto: Red Sled
Sooo glad I don't have to do that crap.

Seems pretty high, everyone else says seafoam, so why not right?
__________________
Turbo Build Here


Reply With Quote
  #112  
Old 12-02-2010, 04:28 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
I have the can in the garage, I just haven't gotten around to it yet.....I guess I'll try that soon.
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #113  
Old 12-02-2010, 04:43 PM
FenderBender's Avatar
FenderBender FenderBender is offline
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,160
Mein Auto: Red Sled
Does it cost to redo your smog?
__________________
Turbo Build Here


Reply With Quote
  #114  
Old 12-02-2010, 06:56 PM
E36youngster's Avatar
E36youngster E36youngster is offline
blank
Location: Fort Mill, SC
 
Join Date: Sep 2007
Posts: 1,614
Mein Auto: 07 e92 335i
Quote:
Originally Posted by crisscross View Post
Thanks man!

Ok so I failed smog today, hydrocarbons 328 max allowed 220.

Help me smog experts! The good thing is that a Check engine light came on. Will edit after I read it.

*Edit: Mass air sensor, but I threw that code when I unplugged it once while running. More research is in order.



well how coincidental! lol hope it works out dude, no emissions test here so i have no idea what you are going through
__________________
Reply With Quote
  #115  
Old 12-02-2010, 06:58 PM
Mr Gusta's Avatar
Mr Gusta Mr Gusta is offline
Fireballs inc.
Location: long Island
 
Join Date: Jul 2008
Posts: 9,226
Send a message via AIM to Mr Gusta
Mein Auto: big turbo hellrot sedan
do you have cats?
__________________

Turbo lag is just a headstart because the chase is more exciting than the win - Abraham Lincoln
Reply With Quote
  #116  
Old 12-02-2010, 07:32 PM
kanovic's Avatar
kanovic kanovic is offline
His Name is Carlos
Location: Rossville,Ga
 
Join Date: Aug 2008
Posts: 1,457
Mein Auto: 98 M3
Quote:
Originally Posted by E36youngster View Post
well how coincidental! lol hope it works out dude, no emissions test here so i have no idea what you are going through
omg me neither yayyyyyy
__________________
Reply With Quote
  #117  
Old 12-02-2010, 07:38 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Yes I have a cat, not two....someone replaced it at some point.....that could be it.

I found another code for the intake air temp sensor, so i'll swap it from the 325 and see if that works.

Does anyone know if intake air temp sensor would cause a missfire? I know def know it would cause a closed loop rich idle, and I guess that could cause a missfire?

Thoughts?
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #118  
Old 12-10-2010, 07:01 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Ok so I got contours and tires all mounted up last night....I will post pics tomorrow after I get home from skiing tomorrow and get her all washed up. I may try to smog again tomorrow....I'm slowly making progress on all the little things.

So far I have done:

New sun visors
Replaced cluster
Fixed side skirt
Replaced rear suspension with sach's shocks and H&R springs
Sparks plugs
Coil boots
Intake air temp sensor
No name CAI
Found out I have Dinan throttle body
Contours and new tires
Replaced fog lights
Turner RSM's
Replaced missing panels in the trunk
Fuel filter
Mobil one oil change
Cabin air filter
Vavle cover gasket
Cooling system overhaul

And I have only dirven it about 600 miles
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #119  
Old 12-10-2010, 08:29 PM
FenderBender's Avatar
FenderBender FenderBender is offline
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,160
Mein Auto: Red Sled
Good job!

How does it drive now?
__________________
Turbo Build Here


Reply With Quote
  #120  
Old 12-10-2010, 08:59 PM
David-C David-C is offline
Officially Welcomed to the 'Fest
Location: Salinas CA
 
Join Date: Nov 2010
Posts: 276
Mein Auto: 1992 BMW 325i
Wat is the seafoam thing i keep reading about and wat does it do?

Sent from my PC36100 using BimmerApp
Reply With Quote
  #121  
Old 12-10-2010, 09:51 PM
TRaV MaNN's Avatar
TRaV MaNN TRaV MaNN is offline
Somebody stop me....
Location: Slackramento, CA
 
Join Date: Apr 2009
Posts: 3,691
Mein Auto: EW/// 86
google: seafoam

alan, thats an impressive list for 600 miles. Hurry up and make it pass smog now

__________________
You canít spend all your time worrying about where your next Twinkie is going to come from, so follow rule #32 and Enjoy The Little Things.

Reply With Quote
  #122  
Old 12-11-2010, 06:51 AM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Quote:
Originally Posted by FenderBender View Post
Does it cost to redo your smog?
Yeah it costs to redo it whether you pass or fail. Its around 20 bucks, and we have to do it every year.

Quote:
Originally Posted by FenderBender View Post
Good job!

How does it drive now?
Thanks! It pulls really hard now.....I just want to mod the hell out of it, but I need to get it registered and all my maintenance done first.

Quote:
Originally Posted by TRaV MaNN View Post
google: seafoam

alan, thats an impressive list for 600 miles. Hurry up and make it pass smog now

I may try again today, it seems like its not idling as rich now that I repaced the IAT sensor that threw my CEL.
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #123  
Old 12-11-2010, 06:59 AM
drivinfaster's Avatar
drivinfaster drivinfaster is offline
bimmerfest Supporting Member
Location: in the sticks you piney
 
Join Date: Nov 2007
Posts: 10,579
Mein Auto: rescued bmw's
Quote:
Originally Posted by crisscross View Post
Does anyone know if intake air temp sensor would cause a missfire? I know def know it would cause a closed loop rich idle, and I guess that could cause a missfire?

Thoughts?
no. i have not come across any instance where the air intake temp sensor caused a misfire. running rich would also not cause a miss. it would bog, run like poo, and co would be through the roof, not hc.

hc is a misfire indicator, so i would be looking faulty ignition (coil/plug/boot), or, if caused by a lean mis, faulty injector.

a cat would not cause a misfire, so i would not worry about that at this time.

find the cylinder that is missing and then do this. swap the coil with one cylinder, and the plug with another cylinder. see if the miss moves. if it does, then you have found the defective part. if it stays at the same cylinder, then you car going to be looking injector or valve issue.

good luck.


df
__________________
Reply With Quote
  #124  
Old 12-11-2010, 07:16 AM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,578
Mein Auto: 1995 M3 Boston Green
Thanks df, I am having a hard time locating the misfire...its OBD1 and I'm not getting a code. Should I disconnect one plug at a time when its misfiring and see if I can locate it that way, or do I need to have it hooked up to a computer?

It seems to only miss at idle after running at constant rpm when the engine is warm, like on an offramp after driving on the freeway. It doesn't miss when cold.

The car seems to run alot better after I replaced the IAT sensor.
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
  #125  
Old 12-11-2010, 09:46 AM
FenderBender's Avatar
FenderBender FenderBender is offline
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,160
Mein Auto: Red Sled
Have you checked for leaks around the ICV or cleaned it?
__________________
Turbo Build Here


Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms