Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 12-06-2010, 02:43 PM
oldschool85 oldschool85 is offline
Registered User
Location: Chicago
 
Join Date: Dec 2010
Posts: 2
Mein Auto: 2001 BMW X5
No Heat-Blows Cold Air Thru Side and Center Vents

2001 BMW X5 4.4L. Blower fan works, heat works only in defrost and floor mode. No heat coming out of center or side vents.(blows cold air) Dial is set to red mark....

Any Ideas?
Reply With Quote
Ads by Google
  #2  
Old 12-07-2010, 10:27 AM
Wayne's World Wayne's World is offline
Monkey Wrencher
Location: Easton, PA
 
Join Date: Dec 2010
Posts: 215
Mein Auto: 2005 325i Sport 5spd
Well I haven't experienced this problem but I know how the heating system works. Fan blowing (i'm assuming at low, medium & high speeds) and cold air coming out means your heater core is not getting the coolant through it. So likely the heater/blower relay is toast. That's my educated guess. Other possibilities is the heater core is cracked or leaking. But likely you would've either smelled coolant burning or experienced a leak in your cabin.
Reply With Quote
  #3  
Old 12-07-2010, 05:39 PM
oldschool85 oldschool85 is offline
Registered User
Location: Chicago
 
Join Date: Dec 2010
Posts: 2
Mein Auto: 2001 BMW X5
No Heat

I think if it was the heater core - I would have no heat from the floor or defrost mode... which is working...
Reply With Quote
  #4  
Old 12-09-2010, 10:50 AM
Wayne's World Wayne's World is offline
Monkey Wrencher
Location: Easton, PA
 
Join Date: Dec 2010
Posts: 215
Mein Auto: 2005 325i Sport 5spd
Final stage resistor? Have you come across this in your readings?
__________________
2002 Sterling Gray M5
'nuff said
Reply With Quote
  #5  
Old 12-31-2010, 03:34 PM
vdv1 vdv1 is offline
Registered User
Location: NYC
 
Join Date: Dec 2010
Posts: 1
Mein Auto: 2005 X5
Your thermostat could be stuck closed which would not allow hot coolant to circulate through the heater core.
Reply With Quote
  #6  
Old 01-23-2013, 10:53 AM
malonzo malonzo is offline
Registered User
Location: wisconsin
 
Join Date: Jan 2013
Posts: 24
Mein Auto: 2005 X5 4.4
malonzo

i have 2003 X5 4.4, same problem heat from floor vent and defroster vent but no heat from center vents just cold air.
Reply With Quote
  #7  
Old 01-23-2013, 07:13 PM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 512
Mein Auto: BMW, Lotus, Porsche
Have you guys read the owner manual?
Reply With Quote
  #8  
Old 01-24-2013, 01:52 PM
QSilver7's Avatar
QSilver7 QSilver7 is online now
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,795
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by oldschool85 View Post
I think if it was the heater core - I would have no heat from the floor or defrost mode... which is working...
We have to ask since you didn't tell us that it was ruled out as the culprit like the OP did in the 1st post in this thread "dial is set to red".

What position do you have the stratified air dial? This is the dial (#3) in the middle of the dash's center vent that allows the front passengers to "temper" the air from those vents warmer or cooler...independent of the set temp that is coming from the floor or defrost vents.

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #9  
Old 01-25-2013, 09:18 AM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 512
Mein Auto: BMW, Lotus, Porsche
Quote:
Originally Posted by QSilver7 View Post
We have to ask since you didn't tell us that it was ruled out as the culprit like the OP did in the 1st post in this thread "dial is set to red".

What position do you have the stratified air dial? This is the dial (#3) in the middle of the dash's center vent that allows the front passengers to "temper" the air from those vents warmer or cooler...independent of the set temp that is coming from the floor or defrost vents.


That's what happened to me when I first try using the heat in the X. Finally read the owner manual and found out about the thumbwheel in the center of the vent.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms