Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-03-2011, 02:13 AM
mgooding mgooding is offline
Registered User
Location: London, UK
 
Join Date: Jan 2011
Posts: 2
Mein Auto: 2004 Z4 2.2i
Z4 windscreen spray not firing

After a very cold winter in the UK my washer jets on my 2004 (04) Z4 2.2i aren't performing as they should.

here's what i know:

- the pump is firing (or at least there's a whirring sound)
- the jets dribble a bit and with constant pumping can sometimes just about hit the windscreen
- the fluid may have ran out - it certainly got low. it's full again now
- this affects both jets so assume it's not localised to a single blocked jet

any help appreciated.
Reply With Quote
Ads by Google
  #2  
Old 01-03-2011, 02:14 AM
mgooding mgooding is offline
Registered User
Location: London, UK
 
Join Date: Jan 2011
Posts: 2
Mein Auto: 2004 Z4 2.2i
additional - the washer mix is at 50% and went in a few days ago. also it's not cold here anymore and there's no signs of leakage.
Reply With Quote
  #3  
Old 01-03-2011, 06:45 AM
GeorgeT's Avatar
GeorgeT GeorgeT is offline
Officially Welcomed to the 'Fest
Location: Seneca, SC
 
Join Date: Jun 2007
Posts: 948
Mein Auto: '07 750i BMW; '03 Z4 BMW
Check for holes/tears in the lines going to the nozzles. Also, check the reservoir and make sure there is nothing blocking the pick-up. Finally, just because a pump is making noise doesn't mean that it is pumping: the impeller blades may have broken.
Reply With Quote
Reply

Bookmarks

Tags
fluid, washer, windscreen, z4


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms