Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-17-2010, 03:57 PM
BigStevie BigStevie is offline
Registered User
Location: Chicago
 
Join Date: Oct 2010
Posts: 1
Mein Auto: 2003 X5
2003 X5 Radio keeps shutting of on it's own

I recently purchased a used 2003 X5 3.0. I have encountered several problems. The most annoying one is the radio turning off by itself. It seems to act very erratically. It also appears to be affected sometimes by lifting the arm rest and turning down the interior dimmer. But that is only the case at night.

Also, the BC function occasionally stops working.

Should I look at replacing the radio or is the problem more computer based. I also have an issue with missing pixels on the main display below the speedometer/Tach. Are they related?

Thanks for any help.
Reply With Quote
Ads by Google
  #2  
Old 11-02-2010, 08:49 PM
m5james's Avatar
m5james m5james is offline
Officially Welcomed to the 'Fest
Location: Boise, ID
 
Join Date: Nov 2005
Posts: 861
Send a message via AIM to m5james Send a message via MSN to m5james Send a message via Yahoo to m5james
Mein Auto: 98 740iL - Tweaked a bit
Oddly, sounds like you might have a battery issue...you'd be surprised. Try getting a replacement battery @ Autozone for around $80, keep the receipt and see if that fixes it. Burnt pixels are typical for BMW OBC and MID clusters, the ribbon cable can be replaced for about $50 on eBay OR the wild change that you can get in touch with BMWNA and ask about their replacement, but sometimes their labor and parts costs can outweigh the saving of just getting the ribbon replaced.
__________________
New here? Please visit www.e38.org, THEN you ask questions

325hp 98 740iL, black/black - Eatin 540's & $hittin 318's
PERFORMANCE:///M5 6spd conv., Iron sleeves, L/W Teflon coated pistons, 3 angle valvejob, P&P head, cams, electric fan, CF intake tube w/aluminum heatshield, Magnaflow 14816'd
INTERIOR:
Hardwired V1 above rearview, 12" RE Audio DVC sub, MTX 81000D, silver trim, 5% tint
EXTERIOR:19" Beyern Mesh staggered, Shadowline kidneys, Axxis pads
01 X5 4.4 - F90BT, L5
Reply With Quote
  #3  
Old 11-09-2010, 04:44 AM
swipe swipe is offline
Registered User
Location: UK
 
Join Date: Mar 2008
Posts: 9
Mein Auto: E30 325i Black Touring
Got the same problem with the radio on my 4.4 getting annoying now did the new battery solve the problem?
Reply With Quote
  #4  
Old 11-16-2010, 08:50 AM
swipe swipe is offline
Registered User
Location: UK
 
Join Date: Mar 2008
Posts: 9
Mein Auto: E30 325i Black Touring
bump
Reply With Quote
  #5  
Old 11-17-2010, 02:40 AM
m5james's Avatar
m5james m5james is offline
Officially Welcomed to the 'Fest
Location: Boise, ID
 
Join Date: Nov 2005
Posts: 861
Send a message via AIM to m5james Send a message via MSN to m5james Send a message via Yahoo to m5james
Mein Auto: 98 740iL - Tweaked a bit
Try wigglng the ignition switch and see if anything happens. There have been instances where heavy and bulky keyrings cause the contacts inside the lock tumbler to get screwed up and cause erratic issues as well.
__________________
New here? Please visit www.e38.org, THEN you ask questions

325hp 98 740iL, black/black - Eatin 540's & $hittin 318's
PERFORMANCE:///M5 6spd conv., Iron sleeves, L/W Teflon coated pistons, 3 angle valvejob, P&P head, cams, electric fan, CF intake tube w/aluminum heatshield, Magnaflow 14816'd
INTERIOR:
Hardwired V1 above rearview, 12" RE Audio DVC sub, MTX 81000D, silver trim, 5% tint
EXTERIOR:19" Beyern Mesh staggered, Shadowline kidneys, Axxis pads
01 X5 4.4 - F90BT, L5
Reply With Quote
  #6  
Old 11-17-2010, 10:59 AM
Jap Scrap Jap Scrap is offline
Registered User
Location: ireland
 
Join Date: Oct 2010
Posts: 29
Mein Auto: X5
its your bm 54 unit radio module is dodgy
Reply With Quote
  #7  
Old 12-03-2010, 10:05 AM
Gronwenwills Gronwenwills is offline
Registered User
Location: North Wales United Kingdom
 
Join Date: Dec 2010
Posts: 4
Send a message via Skype™ to Gronwenwills
Mein Auto: X5 3.0 diesel
X5 radio problem

Hi Guys

Buying a 2002 X5 3.0ltr diesel, the radio is jammed on the MW wavelength can it be fixed or will I need to replace ?:::
Reply With Quote
  #8  
Old 12-15-2010, 07:07 PM
skeetjunkie skeetjunkie is offline
Registered User
Location: Georgia
 
Join Date: Aug 2007
Posts: 4
Mein Auto: '85 325e/'06 330i/'04 X5
Check out this thread from Xoutpost:

http://www.xoutpost.com/bmw-sav-foru...dio-issue.html
Reply With Quote
  #9  
Old 12-16-2010, 04:25 AM
Gronwenwills Gronwenwills is offline
Registered User
Location: North Wales United Kingdom
 
Join Date: Dec 2010
Posts: 4
Send a message via Skype™ to Gronwenwills
Mein Auto: X5 3.0 diesel
Thanks for link, unfortunately it's a separate issue. Additional info is that radio will turn off or on but only when the vehicle has been turned off, key removed and vehicle locked ! Then when you re enter the radio can be turned on or off ( depending on the last mode) but only once , you then have to go through previous process, in any case it will only function on MW band ( as I gather that it remembers which mode was last used and you cannot select Cd mode either. Other info is that the time display is blank , the year is set to 2007 and can't accept input. The mileage and avg speed function is working ok
Reply With Quote
  #10  
Old 12-16-2010, 01:45 PM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 843
Mein Auto: 2001 X5 3.0L
Try a battery disconnect/reconnect with a few minutes in between.
Reply With Quote
  #11  
Old 12-17-2010, 04:04 PM
Gronwenwills Gronwenwills is offline
Registered User
Location: North Wales United Kingdom
 
Join Date: Dec 2010
Posts: 4
Send a message via Skype™ to Gronwenwills
Mein Auto: X5 3.0 diesel
Hi
Thanks for suggestion, but already tried this method no better

Any other suggestions welcome

Best regards

Alwyn
Reply With Quote
  #12  
Old 01-04-2011, 11:20 AM
jolie Court jolie Court is offline
Registered User
Location: uk
 
Join Date: Jan 2011
Posts: 2
Mein Auto: x5
dont know if anyone can help me, my radio will not turn on, i did have a new battery fitted a couple of weeks ago
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms