Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-27-2011, 06:50 AM
thornton_chris thornton_chris is offline
Registered User
Location: MK
Join Date: Jan 2011
Posts: 1
Mein Auto: BMW X5
Rear wiper and washer stoped working

Hi all,

After the recent dreadful snow we have just had in the UK my rear wiper and washer have both stopped working.

Has anyone got any ideas?

I have checked the fuses (glove box and boot) and they are both fine.

Is there a common relay which controls these and where would I find it?

Any help would be appreciated.

Many thanks.

Reply With Quote

See More Related BMW Stories

Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -7. The time now is 06:09 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms