Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-30-2011, 01:19 PM
quickspoolsr quickspoolsr is offline
Registered User
Location: iowa
 
Join Date: Jan 2011
Posts: 1
Mein Auto: 99 323i
e46 323i Not running right

My car is a 99 323i, its an automatic with 200,000 miles. When it is cold it takes forever to get warmed up, and while its warming up it idles rough and dies a lot, and after warming up it runs almost perfect. I had the codes checked and there are a ton of error codes. they are

p1750 Secondary pressure solenoid
p1751 Secondary Pressure Solenoid
p1748 Transmission control module self test
p1749 Secondary Pressure Solenoid communication error
p0705 Transmission range circuit
p0727 Engine speed sensor circuit No Signal
p0731 Gear 1 Ratio incorrect
p0734 Gear 4 Ratio incorrect
p1747 CAN Bus Monitoring
p1748 Transmission Control Module self test
p1770 CAN Torque Interface
P0705 Trans Range sensor circuit malfunction
p0753 Shift selenoid A circuit electrical
p0758 shift selenoid B circuit electrical
p0763 shift selenoid C circuit electrical

I recently replaced the battery, spark plugs and fuel filter. I also had the transmission fluid level checked and it is fine. the trans shifts just fine. Im thinking it might be something electrical. can anyone give me some advice as to where to go from here?
Reply With Quote
Advertisement
  #2  
Old 01-30-2011, 08:26 PM
marinekilz's Avatar
marinekilz marinekilz is offline
Noone Special
Location: Bronx, NY
 
Join Date: Jul 2010
Posts: 671
Mein Auto: 02 e46 325 xi
well no two cent is the only fault I see that isn't related to the trans is the crank sensor
__________________
02 E46 325Xi
03 X3 3.0i
07 E92 335i ZSP

E9 One Day It Will Be Mine
Reply With Quote
  #3  
Old 02-17-2011, 09:09 PM
BMWTASTE BMWTASTE is offline
Registered User
Location: NEW JERSEY
 
Join Date: Feb 2009
Posts: 28
Mein Auto: 323I BMW
Make shure that scan socket under the hood by the pasenger side wall is not loose that will cuase errors
Reply With Quote
Reply

Bookmarks

Tags
323i, e46, idle, rough, transmission


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms