Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-27-2011, 05:28 AM
mikemcn mikemcn is offline
Registered User
Location: Lex, KY
 
Join Date: Aug 2007
Posts: 36
Mein Auto: X5 4.8is, 535i x-drive
Cooling hose connection fail

2005 X5 4.8is
Coolant reservoir had a split so picked up a new one and exchanged the old one. Mistake - can't reference the old one.

Lower hose (P/N 17127509966) connection leaks - really just drains the coolant as I add it. Wondering if there should be a washer/gasket on that connection to the reservoir (and the other two hose connections). I don't see any on the parts diagrams that I'm looking at online.

If not, any ideas why it is leaking? I have reconnected it several times, making sure it is fully pressed in and the lock clamp is secured.

Thanks!

Mike
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms