Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 02-27-2011, 03:55 PM
xbdrabbitx xbdrabbitx is offline
05 X3 3.0i Prem pkg
Location: philadeplhia
 
Join Date: Jan 2011
Posts: 36
Mein Auto: 05 x3 3.0i
Exclamation Headlight wash inop??

05 x3. Headlights on and I think in heard the pump activate when i ask for wash on the third time, but receive no fluid expelled. I don't see any leaks from here the fluid is. Any ideas?
Reply With Quote
Advertisement
  #2  
Old 02-27-2011, 03:57 PM
xbdrabbitx xbdrabbitx is offline
05 X3 3.0i Prem pkg
Location: philadeplhia
 
Join Date: Jan 2011
Posts: 36
Mein Auto: 05 x3 3.0i
Also just bought the car and this is the first time i wanted to see it work.
Reply With Quote
  #3  
Old 02-27-2011, 08:18 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 14,034
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
The headlight washer sprays the first time the windshield is washed when the headlamps are on, and every 5th time after that.

If you are hearing the pump activate but nothing is spraying, check the hose connection next to the washer fluid tank for any clogs or leaks. If all is okay, likely your pump has gone bad and needs to be replaced (this was my case last year). The part is around $60-70 and easy to do yourself.
Reply With Quote
  #4  
Old 02-28-2011, 08:11 AM
CmfortblyNumb CmfortblyNumb is offline
Registered User
Location: Denver, CO
 
Join Date: May 2008
Posts: 4
Mein Auto: '06 BMW X3
I had the same problem after I got my 2006 X3. I could hear a pump, but the headlight washer wouldn't pop up. I mentioned it to the dealer while getting an oil change, and they replaced the pump (under warranty) and everything's been working fine ever since.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms