Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-23-2011, 11:37 AM
Cyros Cyros is offline
Trololololo
Location: nova
 
Join Date: Mar 2011
Posts: 2
Mein Auto: e86
Thumbs up New(ish) E86 "Owner"

I say "Owner" cuz technically my bank owns it.

I got this beast back in September. It was a lazy Labor day off of work and I decided out of nowhere: "Imma go buy an M Coupe". I drove my 996TT down to a semi-reputable dealer and completed the transaction in one day. The hard part was agreeing on a price for that damn 996TT (attempts to sell it privately were futile, I blame the economy ).

So yeah, kinda a downgrade, but not really. The 996TT is insanely fast but I'm at -8 points on my license and "insanely fast" is a sure way to be commuting to work "insanely slow" on my bmx bike.

I'm going to dig a grave real quick and say I've never been extremely impressed or interested in BMWs, so I wasn't sure the M Coupe would do it for me. After the first test drive I knew I had to have one someday, good job BMW. This car is great fun to drive...blah blah everyone already knows how great it is so I won't go further.

The main reason I'm starting this thread is the damn CEL has a mind of it's own. I took it to a dealer and they said they fixed it with some flash upgrade. A week later and it came back. Then a few weeks later it goes away, then comes back, so on and so forth. Does anyone else have/had this issue? The main dealer is slightly out of my way so I hate making the trip there unless needed. I have tried disconnected the battery to no avail.

This car is a cop magnet. Pulled over 3 times in 2 months just after modifying the exhaust. I quickly went back to stock (boo boring stock exhaust sound). I might just go with an xpipe and call it a day ($750 for an xpipe? wth...).

Ok here's pics (I have since removed those ugly chrome thingy's on the front):






And what it replaced (feel free to ask questions about the 996tt):

Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms