Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-05-2011, 10:49 PM
dan2875 dan2875 is offline
Registered User
Location: Olympia
 
Join Date: Apr 2011
Posts: 4
Mein Auto: 2008 528xi
Malfunction codes after battery change

Hello Folks!
I just bought a 2008 528xi last weekend. The battery went dead that night after parking in downtown for a couple hours. Anyways, I drove home about 60miles on the freeway, and assumed the battery would be charged. The next morning, nothing. So I decided to get a new battery, because Ive heard of battery issues with the car, and figured because the car was sitting for so long (probably a few months on the lot),and it has almost 60000miles,I would just get it replaced. I called the dealer, because I know the batt has to be registered afterward. Anyways, besides being 30 miles away, they were booked out a couple of weeks. So, I decided I would change the battery myself and get it registered. I called interstate battery right by my house, and they said they could do it. So I jumped my car, took it down there, and they changed the battery to a mega-tron plus MTP-49/H8 100AH for $230. Anyways, right afterwards, I start the car and have a bunch of error codes. 4x4 malfunction, electrical malfunction, transmission malfunction, AWD, DSC, ABS, EBV malfunction. On top of that, my windows do not work, my remote only locks and unlocks the rear doors. I even changed the battery back to the oem, and same codes. I have bumper to bumper warranty that I bought but there is a 30 day waiting period. I still drive it to work about 2miles a day. Im planning on waiting 30 days and going to the dealer. Interstate batt says they're not liable and refuse to do anything.
Any suggestions? Thanks a bunch.
-dan
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms