Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-08-2011, 06:53 PM
540 M-Sport's Avatar
540 M-Sport 540 M-Sport is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2004
Posts: 4,930
Mein Auto: 01' 540 M-Sport cdn, F355
Bilstein PSS strut problem

Hey guys, just an FYI. About two years ago, I had a Bilstein B14 PSS kit installed in my 540. New shock/strut mounts at the same time. Love the kit, handles and rides great, but after a bit over a year, I started getting a faint, intermittent knock from my front suspension. Figured it was time (over 140k miles) to start replacing much of the front end, so went ahead and installed new everything...center, left and right steering tie rods, new thrust arms with the Meyle HD bushing upgrade, new control arms, new end links, new sway bar bushings...everything but sub frame bushings. But the knock persisted. Had one strut mount replaced and the knock went away for about a month, then returned...and has only gotten worse over the winter.

I finally took it to a really good shop called Group 2 Motorsports here in Seattle, and they did a very detailed inspection, test drive and diagnosis and traced it to both front struts! Right side was worse than left, but both were doing it. I contacted Bilstein for warranty help, and they said "no problem, send them in". This is my daily driver, so no go, and asked them to sell me replacements, and credit me when I return the old ones....problem is they do not normally stock the B14 PSS kit for older cars like the E39 540/M5 much anymore....I had to wait two months for them to get back into stock. Well they finally came in and were sent to me this week and installed today. FIXED! No more annoying knock (it was mostly as low speeds).

I will be contacting Bilstein USA for an RMA authorization to return the old ones and get my credit. Labor and alignment is still expensive, as is shipping, but at least it is fixed.

Just an FYI, and wondering if anyone else has experienced this with Bilstein, either their regular sport/HD, as well as the PSS kits?

I have always heard Bilstein are top notch quality, but this has kind of shaken my confidence. I am not a super agressive driver, and the car is not slammed really low either.

I am happy with the Bilstein customer service, just wish they had these in stock and I didn't have to wait so long...otherwise, it all turned out fine. Just hope the new ones don't have a repeat of this issue.
__________________
Factory M-Sport package with factory installed M-tech bumpers, factory Bluetooth, factory M-Audio 10" dual voice coil subs, Homelink, M5 rear stabilizer bar, Bilstein B14 PSS coil overs, Stop Tech ss brake lines, Akebono Euro Ceramic brake pads, oem Brembo and Zimmerman rotors, Dinan Stage 1 software, Strong Strut front upper stress bar.

Last edited by 540 M-Sport; 04-08-2011 at 08:29 PM.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms