Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-18-2011, 08:31 AM
ragal ragal is offline
Registered User
Location: Germany - Berlin
 
Join Date: Jun 2009
Posts: 4
Mein Auto: E65 730d Breyton
05' 645ci convertible Logic 7 Amplifier Replacement

Hello

i come from Germany-Berlin

I got a 645ci and my sub from left, rear side are sound like he blowing up

its the amp 100% but now i tryed to open the plastic trunk cover but there's one problem:

I removed all screws etc,,, but theres 1 fiber cable that hold the cover?

how i remove him??, and

DOES Somebody have a nice guide how to replace amp????? this would be nice!!!!

gretting's from hauptstadt berlin

Last edited by ragal; 04-18-2011 at 08:33 AM.
Reply With Quote
Advertisement
  #2  
Old 04-18-2011, 06:24 PM
ragal ragal is offline
Registered User
Location: Germany - Berlin
 
Join Date: Jun 2009
Posts: 4
Mein Auto: E65 730d Breyton
Please could someone help me!!

I used the search function but only found 1 thread and there's no guide how to replace :/
__________________
BMW Fanatic
Reply With Quote
  #3  
Old 04-18-2011, 06:42 PM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,509
Mein Auto: '04 M3 / '06 650i Cab
Here are the TIS instructions: Online TIS Logic 7 Amp Removal

I'll go take a few screenshots of the missing first 2 steps. I'll need to get those from my local copy of the TIS.

Here is a step by step set of instructions, no pictures but it explains that you need to unplug the fibre optic cable. coug60's Logic 7 amp install DIY
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #4  
Old 04-18-2011, 07:49 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,823
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by ragal View Post
Hello

I removed all screws etc,,, but theres 1 fiber cable that hold the cover?

how i remove him??
Seems like you may be stumped pulling off the cover. If I read this right, it is a metal cable and is nothing more than a ball end, release it by pulling the metal wire sideways out of the channel. The little ball comes out last. When you put it back in make sure and snap the little ball back into the clip all the way. Just take a look at the picture to see what it looks like with the clip removed.

Make sure you reattach all the way, this has something to do with the convertible top if memory serves me correctly.

EDIT: On a side note, the TIS program also has a special warning you should be aware of. When removing and installing the Wheel Arch Cover take extra care and confirm that the convertible drain hose is still attached. It is easy to knock it off and then you will have water ruin your electronics in the trunk.
Attached Thumbnails
Click image for larger version

Name:	bmw cover 004 (Large).jpg
Views:	136
Size:	102.7 KB
ID:	275185   Click image for larger version

Name:	bmw cover 006 (Large).jpg
Views:	134
Size:	162.3 KB
ID:	275186  

Last edited by tampamark; 04-18-2011 at 08:00 PM.
Reply With Quote
  #5  
Old 04-18-2011, 11:54 PM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,509
Mein Auto: '04 M3 / '06 650i Cab
Here are a few more TIS instruction pages. First 2 on how to remove trim and last is how to remove the amp.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #6  
Old 04-19-2011, 05:07 AM
ragal ragal is offline
Registered User
Location: Germany - Berlin
 
Join Date: Jun 2009
Posts: 4
Mein Auto: E65 730d Breyton
Hello,,


Omg, Thanks to all who help me!!, it helped me allot!

This is the best helpful forum in the world for Beamers

Thanks again...


EDIT:

Now i removed the whole cover (trim or w/e) , And Removed 5 Screws

But the Amp Dont move a bit!!!

Now i Explore , Behind the Amp are 2 screws more

But how the hell i get the screws removed?? my fingers are fat and even with the pincers i cant get it drilled

Here i tryed to show u what screws i removed:



I'm now @home

I will make later a Photo with my M-O-B-I-L-E P-HoNE


Sry for my bad english =)
__________________
BMW Fanatic

Last edited by ragal; 04-19-2011 at 07:11 AM.
Reply With Quote
  #7  
Old 04-19-2011, 10:04 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,823
Mein Auto: 2006 650 convertible!!!
hmmm, I have never gone so far as to have to pull the amp out. I had removed the back carpet and arch for another issue so I am no help there. There must be something you are missing, perhaps you do not need to remove those behind the amp? The TIS shows some releases in the front.

Good luck.
Reply With Quote
  #8  
Old 04-19-2011, 03:43 PM
ragal ragal is offline
Registered User
Location: Germany - Berlin
 
Join Date: Jun 2009
Posts: 4
Mein Auto: E65 730d Breyton


NVM


I Fixxed the problem was i dont removed the plates under the amp



Now the amp is removed and i try to fix this by a local hifi dealer



Thanks to all!
__________________
BMW Fanatic
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms