Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-29-2011, 02:00 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
1998 z31.9 auto shift cover loose.

Hi, slowly getting to grips with the little roadster, have the car booked into get all the oils changed. I did the motor oil myself, but its getting cold here and wont have time to do the tranny and the diff oils myself, so booked it in.

now for this post question:

The cover for the auto transmission shifter in the cockpit is loose and sits nice and flush when in park, but when in drive or shifting between 1,2 or 3 its loose. The front or back of it comes up. Ive tried to push it down, but it seems the shifter is set about 5-7 mills to high on the chassy, thus making the plastic shifter cover bulge and dislodge when shifting.

anyone come across this before, is there an easy fix?

cheers
Reply With Quote
Advertisement
  #2  
Old 04-29-2011, 03:26 PM
Monolith Monolith is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: May 2008
Posts: 751
Mein Auto: 1997 Z3 1.9L DASC Auto
Any chance you can post a photo of it?
Reply With Quote
  #3  
Old 04-29-2011, 11:00 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
Pics arrived.
That's in park where it fits all snug.


And this us when it's shifting.


And from the side on.


Any idea or help would be great!!
Cheers Vanne.
Reply With Quote
  #4  
Old 05-01-2011, 03:51 PM
Monolith Monolith is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: May 2008
Posts: 751
Mein Auto: 1997 Z3 1.9L DASC Auto
There's only four tabs that hold the plate on. Any chance you can pop off the plate and take a pic of the underside of the plate and also the shifter mechanism?

Be careful as there are wires for the gear nmbers lights.
Reply With Quote
  #5  
Old 05-03-2011, 05:59 AM
Monolith Monolith is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: May 2008
Posts: 751
Mein Auto: 1997 Z3 1.9L DASC Auto
Forgot to ask if your gear selection light works correctly. As you move the shift lever to a different gear, does the light move to the correct gear?

It's possible someone had the cover off and did not get the light sliding mechanism over the shift lever. This would push the light mechanism up under the cover at the back popping up the cover. If this is the case, you need to fix this as soon as possible, because you're damaging the light mechanism. You can't buy parts for the cover. You have to buy the entire cover.
Reply With Quote
  #6  
Old 05-03-2011, 03:47 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
You mean as you shift there is a light that changes? Besides the plastic non light indicator that slides with the shifter as in the pics it's orange little square? Is there a dash indicator what gear your in as well?
Reply With Quote
  #7  
Old 05-03-2011, 04:01 PM
Monolith Monolith is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: May 2008
Posts: 751
Mein Auto: 1997 Z3 1.9L DASC Auto
The plastic non light indicator is lighted when your headlights are on. No dash indicator.
Reply With Quote
  #8  
Old 05-06-2011, 04:28 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
Here are some pics from below the trans cover.



And


And



I just had a quick
Play and it seems all the wires and plugs are in proper sockets. So I am lost why this doesn't sir right and is pushed up from underneath when shifting.. Any help would be great!
V.
Reply With Quote
  #9  
Old 05-06-2011, 04:29 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
Oh and all the lights and all the other stuff works just great. It's just the annoying shift lifts up the cover.
Reply With Quote
  #10  
Old 05-06-2011, 06:47 PM
Monolith Monolith is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: May 2008
Posts: 751
Mein Auto: 1997 Z3 1.9L DASC Auto
I don't see anything out of place and the light assembly seems to be on correctly. The base of the shift lever (where it splits) at the bottom could lift the panel up if the shift lever is loose at the base.

Check if the base assembly is loose. Check the rear bolt on the base assembly and see if someone accidentally installed a washer, etc. under it lifting the rear of the assembly too high.

Last edited by Monolith; 05-06-2011 at 06:49 PM.
Reply With Quote
  #11  
Old 05-06-2011, 08:27 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
nope, base of essembly is tight as a nuns.... anyways, you get the drift. i also checked if there was a wayward washer underneath the essembly, and there isnt. *sigh* nything else you can think of. By the way Monolith, thanks so much for the input so far
Reply With Quote
  #12  
Old 05-06-2011, 08:29 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
just thinking, it looks like it touches on the middle top of that yellow thing as it shifts, if felt it and its also tight as, what is that thing?, maybe i can loosen it and sit it elsewhere if it doesnt do much specific...?
Reply With Quote
  #13  
Old 05-06-2011, 08:56 PM
Monolith Monolith is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: May 2008
Posts: 751
Mein Auto: 1997 Z3 1.9L DASC Auto
The yellow thing is your gear selector for the transmission. It has copper traces with copper fingers to electrically tell the transmission computer what gear you have selected with the shifter. Not something you really want to move around.

Have you looked at your console overall to see if maybe someone sat on it and crushed it down? That's about the only thing I can think of at this time. Try pushing the console upward near where the shift selector is to give a little more clearance.
Reply With Quote
  #14  
Old 05-06-2011, 08:59 PM
Vanne Vanne is offline
Registered User
Location: Christchurch
 
Join Date: Apr 2011
Posts: 38
Mein Auto: Z3
thanks Mono, il head down to my garage and give that a look over/shot.....


rightoh, had another look and you know that metal guide rail that the red gear indicator follows, well its bent from being pushed down onto the top of that yellow gear selector thingy. so its definitially rubbing.. but why.. also had a look, the center console is exatctly where its supposed to be, its all bolted down nice and tight.

just wondering maybe, just maybe my cover is deformed from sun? is it supposed to be dead flat? (mine is) or concave? id recon it only rubs by 2 mill at most...

Last edited by Vanne; 05-06-2011 at 09:09 PM.
Reply With Quote
  #15  
Old 09-22-2012, 01:49 PM
Jortiz96 Jortiz96 is offline
Registered User
Location: Wilmington, NC
 
Join Date: Sep 2012
Posts: 76
Mein Auto: 1996 BMW Z3
Hello guys, i am new to the Forums and i was looking for some help. I have a 96 z3 and i too am having problems with the shift selector; not only does it get loose when im shifting from drive-park etc., the little orange gear selector does not move anymore. Does anybody know if i can fix it or do i have to get a new one?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms