Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 06-07-2011, 09:07 AM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
2011 Z4 Fuel Pump Noise

Two to three weeks after I took delivery of our 2011 30i Z4 it started to make a high pitched howling noise. It has continued to get louder as the weeks go by . . . it can now be heard while standing several feet away from the car. The dealer said that has been an issue with the 2011 Z4's and there is nothing they can do about it. They have tried changing the fuel pump in other 2011 Z4's and it is quiet for a couple of weeks and then the noise returns.

I called BMW N.A. and they do not have a fix for it at this time. Has anyone else had this issue?

Love the car except for this constant noise . . . which I can now hear over the radio.
Reply With Quote
Ads by Google
  #2  
Old 06-07-2011, 11:58 AM
SANguru SANguru is offline
Officially Welcomed to the 'Fest
Location: Bay Area, CA
 
Join Date: Jun 2009
Posts: 605
Mein Auto: '13 M5, 08 E93 M3, F430
Quote:
Originally Posted by Atlas350XL View Post
Two to three weeks after I took delivery of our 2011 30i Z4 it started to make a high pitched howling noise. It has continued to get louder as the weeks go by . . . it can now be heard while standing several feet away from the car. The dealer said that has been an issue with the 2011 Z4's and there is nothing they can do about it. They have tried changing the fuel pump in other 2011 Z4's and it is quiet for a couple of weeks and then the noise returns.

I called BMW N.A. and they do not have a fix for it at this time. Has anyone else had this issue?

Love the car except for this constant noise . . . which I can now hear over the radio.
bring it to another dealer! East Bay is a lot better than Fremont. Nothing they can do? that's BS. Have them open a PUMA case ASAP.
__________________
2013 M5
2014 X5 xDrive 50i M Sport
2005 Ferrari F430
Reply With Quote
  #3  
Old 06-07-2011, 05:02 PM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
Took it to BMW Concord. I already know about BMW of Fremont . . . I would not take anything to them. Thanks for the suggestion . . . I may try East Bay BMW.

Did you have the same noise problem with yours?
Reply With Quote
  #4  
Old 06-07-2011, 05:04 PM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
What is the PUMA?
Reply With Quote
  #5  
Old 06-07-2011, 05:15 PM
SANguru SANguru is offline
Officially Welcomed to the 'Fest
Location: Bay Area, CA
 
Join Date: Jun 2009
Posts: 605
Mein Auto: '13 M5, 08 E93 M3, F430
no. I am not picking up my Z4 until July. Don't bother with Concord either. Go to East Bay. a PUMA is a problem case that gets logged into a database with BMW when something has not been able to be fixed. BMW Regional Techs get involved and it gets funneled back up to BMW.
__________________
2013 M5
2014 X5 xDrive 50i M Sport
2005 Ferrari F430
Reply With Quote
  #6  
Old 06-07-2011, 06:07 PM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
Oh! OK . . . well that makes sense then. I have been reading about a HP Fuel Pump recall that happened last Dec. Similar problem . . . I believe BMW needs to get fuel pumps from another vendor . . .

I am not going to let this go as I like the car and want it to be the same way it was when I drove it off the dealer's lot in Feb. Thanks again for your comments and feedback. Much appreciated.
Reply With Quote
  #7  
Old 06-07-2011, 08:49 PM
baconway baconway is offline
Registered User
Location: Illinois
 
Join Date: Jun 2010
Posts: 4
Mein Auto: New Beetle
My 2011 Z4 30i has the same problem. It was ordered in Jan and delivered March 30.

As with yours, it did not make the noise for a few weeks.

I've noticed that with mine once the gas tank gets below 1/2 full the noise disappears.

It is really irritating and I've asked the service dept. about it. They told me a BMW rep needs to visit and approve the repair.
Reply With Quote
  #8  
Old 06-08-2011, 08:16 AM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
Interesting that the noise goes away after the fuel drops below 1/2 tank. Mine still makes the noise below 1/2 tank of fuel. BMW obviously has a problem with High Pressure Fuel Pumps. Make a formal complaint about it to the number I posted in a previous post above . . . the more complaints they get will help prompt BMW to come up with a fix for this.
Reply With Quote
  #9  
Old 06-08-2011, 08:39 AM
baconway baconway is offline
Registered User
Location: Illinois
 
Join Date: Jun 2010
Posts: 4
Mein Auto: New Beetle
I could be mistaken but I don't think our Z4 30i's have HPFP's. I think those are exclusive to the cars with turbochargers.

BMW certainly does have problems making HPFP's-but it seems they also have problems making plain old electric fuel pumps.
Reply With Quote
  #10  
Old 06-08-2011, 09:41 AM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
Yes I believe you are correct, those are for the turbo's. I've been reading too many posts about the HPFP's. Sure wish they'd come up with a fix for the 30i's as I love the car except for that incessant noise...
Reply With Quote
  #11  
Old 06-23-2011, 09:05 PM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
SANguru . . .

Got a call from BMW of North America last Wed. As per their suggestion I took it to East Bay BMW on Thursday morning for a second opinion. East Bay BMW said they thought it was the fuel pump and want to put it on a lift to look at that area of the under carriage. They asked if I could leave it till later in the afternoon . . . and they gave me a loaner car for the day. They changed the fuel pump and VOLIA! NO more fuel pump noise . . . . I hope it stays that way.

SANguru . . . thanks for your suggestion to take it to Easy Bay BMW . . . good dealership! Think I may switch to them for my service needs from now on...
Reply With Quote
  #12  
Old 07-10-2011, 07:34 PM
baconway baconway is offline
Registered User
Location: Illinois
 
Join Date: Jun 2010
Posts: 4
Mein Auto: New Beetle
I had the fuel pump replaced two weeks ago. Now after only 200 mi the humming sound is returning. It's really disappointing.

Has anyone had better luck?
Reply With Quote
  #13  
Old 07-11-2011, 08:14 AM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
Sorry to hear your noise is back on the new pump, something neither of us wanted to see happen. Had mine replaced 337 miles ago and it is still OK . . . "knock on wood". We'll keep everyone posted as the miles roll by . . .
Reply With Quote
  #14  
Old 11-27-2012, 04:48 AM
BEAMN BEAMN is offline
Registered User
Location: Houston, Texas
 
Join Date: Jun 2011
Posts: 52
Mein Auto: 2011 Z4 & 2012 X5D
I am now just staritng to have this problem with 5K miles on my 2011. Curious if the noise has returned since the pump was replaced.

This car is a dream to drive and love to shift but hate the noise. Hope to get the pump replaced soon.

Regards,
Reply With Quote
  #15  
Old 11-27-2012, 08:07 AM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
Yes, the noise is still gone and now have 17K miles on the Z-4 after the fuel pump was replaced.
Reply With Quote
  #16  
Old 11-27-2012, 08:14 AM
Atlas350XL Atlas350XL is offline
Registered User
Location: Fremont, CA
 
Join Date: May 2008
Posts: 18
Mein Auto: 2011 Z-4
New Problem Happened . . .

About 700 miles ago . . . around 16K total miles . . . one or two lifters must have bled down because the lifters were making lots of noise . . . took it to BMW and the replaced all the lifters. Noise gone but the car just doesn't seem to have the get-up-and-go it used to have with the new lifters. Sad . . . I am starting not to enjoy the car as much as I once did . . .
Reply With Quote
  #17  
Old 11-27-2012, 02:48 PM
RoadstergalZ4 RoadstergalZ4 is offline
Registered User
Location: United States
 
Join Date: Oct 2009
Posts: 92
Mein Auto: 2010 Z4 35i
The whining that you hear is from the LPFP. I had the same problem and my dealer replaced mine about six months into ownership. It was a high pitched whining sound that seem to be coming from behind my seat. Anyway after the dealer replaced the pump two years ago, I have never had a problem with it.

I have a 35i which has the HPFP. I never experienced any problems with that, but my dealer replaced it anyway as it was a recall. The people that had problems with that had the car going into a limp mode, there wasn't any sound coming from that. The whining sound is from the LPFP. I would take it to another dealer as your dealer apparently doesn't have a clue.
__________________
2010 Z4 35i - Orion Silver, Ivory white extended leather, anthracite trim, premium pkg, sport pkg, premium sound pkg, cold weather pkg, navigation, 6 sp manual

2006 Z4 30i - Monaco Blue, beige leather
2003 Z4 2.5- Sterling Gray, black leather
1998 Z3 2.8 - Bright Red, black leather
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms